Can't get MyDNS installation to work

Discussion in 'General' started by Nielsterp, Jun 13, 2010.

  1. Nielsterp

    Nielsterp New Member

    Hi there,

    I have just installed ISPConfig 3 on SUSE 11.2 64-bit,following the how-to at

    There is a few files that is not immediately found, but I found a newer version with webpin.

    But I couldn't get the rpm for mysql-mydns. The command wget just freezes. When i gave the URL to WS-FTP Pro it told me: Could not resolve the address ... But much to my surprise, when I copy/pasted the URL to Internet Download Manager (Windows - yak!) - it gave me the file straight away ! I put the file in the /tmp folder via a samba share, and tryed to install it, but it fails "Unknown service mydns, scriptlet failed...". And sure enough, when I look at the monitor the DNS is not running.

    If I repeat the installation command rpm -ivh --force mydns-mysql-1.1.0-1.i386.rpm it seems to work. No error messages, but in the control panel DNS is still not running.

    I have tried to reboot the machine, I have even tried to start the server manualy with /etc/init.d/mydns start. It returns: /etc/init.d/mydns start
    Starting mydns mydns[11198]: mydns 1.1.0 started Sun Jun 13 13:11:14 2010 (listening on 4 addresses).

    I am relatively new to Linux, and I simply can't get this to work. Can anybody help ?

  2. Nielsterp

    Nielsterp New Member

    I think it works now - error in configuration file

    I just found this:

    and applied this section:

    Fix Error report on web Interface MyDNSConfig when you login
    vi /etc/mydns.conf

    And edit line:
    55: use-rr-active = yes # To fix bug 295 where active or inactive status is ignored.
    Need the space between Yes and #


    then I did: /etc/init.d/mydns restart

    and all lights are green...

    But I still wonder why I cant wget from bboyz ?

  3. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page