Can't get htaccess to work.

Discussion in 'HOWTO-Related Questions' started by muucest, Jul 5, 2009.

  1. muucest

    muucest New Member

    I just installed CentOS by the directions provided here.

    Everything else seems to work fine (although i had to install "apr-devel" to get SuPHP to install properly) but I can not use htaccess files unless I change PHP mode to "Fast-CGI" in ISPConfig control panel.

    The error I keep getting in SuPHP and Mod-PHP modes is ".htaccess: Options not allowed here".

    I have changed "AllowOverride" to "All" in various places in "/etc/httpd/conf/httpd.conf" but this doesn't help.

    ------

    I already feel bad about posting this topic. Being a huge n00b that I am, I just found out about the different .vhosts files. And changing AllowOverride there (or adding simple directives to the domain in ispconfig) fixed everything!

    I thought this was some mystical error from hell, since everything worked in fastCGI mode.

    So sorry & please feel free to delete this topic.
     
    Last edited: Jul 5, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    The Options directive must go into your main Apache configuration, not into an .htaccess file.
     

Share This Page