Can't get control panel in browser

Discussion in 'Installation/Configuration' started by linuxfast, Sep 8, 2005.

  1. linuxfast

    linuxfast New Member

    Firstly, congrats on a superb project and a superb "perfect guide for FC4".

    I have successfully installed ISPConfig with no problems (using http:// for ISPConfig)
    I have installed twice since, selecting the option to use the control panel through SSL (https://) and encountered the same problem.

    Incidentally, the domain I have used is a FQDN but I am behind a router, as such I have a line in my hosts file which is: www

    This line appears both on my FC4/ISPconfig server and my local client machine.

    When I put into my browser, I get as expected:
    Bad Request
    Your browser sent a request that this server could not understand.
    Reason: You're speaking plain HTTP to an SSL-enabled server port.
    Instead use the HTTPS scheme to access this URL, please.


    When I put I get:

    The page cannot be displayed

    Any ideas ?

    Just checked the logs and also tried to access the page using lynx on the server.
    The logs show no requests from my machine using SSL, but shows http:// requests.
    When using lynx it does the certificate thing and then goes to login.php, so obviously a network problem ?
    Not sure what though !
    Last edited: Sep 8, 2005
  2. domino

    domino New Member

    Edit your host file and try the fallowing.

    Also sometime, I have had to restart the compuer (where you edited the HOSTS file) to get https working.
  3. linuxfast

    linuxfast New Member

    I didn't manage to solve this but it was obviously a local dns prob in some way.
    I have since installed ispconfig on a fresh server in a data centre and so far it's almost 100% fine !
    Thanks for the reply though

Share This Page