Cant figure this DNS things out! Need some help with this.

Discussion in 'Installation/Configuration' started by Gleno0h, Apr 22, 2009.

  1. Gleno0h

    Gleno0h New Member

    Well, this is the deal;

    Im trying to make a server with a small hosting plan..
    I've got my domain with www.starthosting.nl
    NS1; ns3.firstfind.nl
    NS2; ns4.firstfind.nl

    I just cant figure out how to add domains, should i add the DNS info that i got from starthosting into ispconfig 2 or not?
    Those kind of things, i dont know where to start, imma post some screens and im hoping somebody could explain it step to step .. this is the 5th forum im asking it and all the others wouldnt want to explain it

    my domain is www.sion-hosting.nl
    i DID NOT change anything in my cpanel of my domain hosting.

    screens;
    screen to direct the domain to ip adress
    screen to custom direction
    and final, dns info from starthosting; NOTE, i did not change anything there! (inhoud means Content)

    i wanted to ask "falco" cauze i seen him answering allot of issues i had, but when i was at his profile he had so many messages about helping people so i dont want to bother him with this :p

    Please, someone explain me, i would realy appreciate it.

    I also got a problem that my websites are only working on; http://externalIP/www.domain.nl and not www.domain.nl.
    But ill figur that out later!

    Sorry for any typo's, im dutch eheh!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. rdv25772

    rdv25772 New Member

    Are you sure that your domain has been registered? On the website of SIDN it stated: sion-hosting.nl is vrij

    Is the externalIP your public IP? The IP, shown in the "dns info from starthosting", directs to the website of starthosting.
     
  4. Gleno0h

    Gleno0h New Member

    Oh yea i forgot to say, i have changed the ip there, but i first wasnt sure about if i should change it to my external ip or to just leave that ip.

    Im a starter with this, now i get on the main url a shared IP page, but that isnt a error page i assume, just a message of multiple site's or something i guess. then i made 1 name.hopto.org and 1 name.servequake.com address, set them up with ispconfig and they work.
    The only problem i have now is that if a user uploads a file, it goes to the wrong folder... any solution to that?

    for the rest its fixed i think :D
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Did you check the admin checkbox for that user in ISPConfig?
     
  6. Gleno0h

    Gleno0h New Member

    No, i've tried it with a free domain name.hopto.org and if i use the webftp or ftp via total commander (file explorer with ftp build in) i see a "web" folder and in that there's an index file.

    I've placed a index2.html file in it and when browsing to name.hopto.org/index2.html it cant find the file.

    Then i've looked at the folders in /var/www/ and i found out that the ftp is not showing the folders that are used for the website but just an other web folder.
    i believe it uploaded to /var/www/name.hopto.org/user/web14/web or something instead of /var/www/web14/web.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Yes, that happens because your FTP user is not the site admin. Therefore you must check the admin checkbox for that user.

    Take a look at http://ispconfig.org/downloads/manual_en/manual_kunde_en_src.htm#4_2_2 , chapter 2.2.1 step 4 and chapter 2.2.9.
     
  8. Gleno0h

    Gleno0h New Member

    Oh, didnt know that ..
    Ive seen the site, i realy need to check the documentation, i always skip that step with everything :p but thnx though, ok i only got 2 more question, then everything is clear..
    proftpd is always slow, and the identlookup off ( i think it was that ) didnt work to get it faster, i fixed it a time back but it want identlookup, maybe you know what it was cause i cant find it again..
    and 2nd Q. the domain name.hopto.org works if server is just on but after 30 min or so, it redirects me to starthosting.nl's domain parking space, do i need to make cname's there?

    thnx falko, you helped me allot at this!!
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Have you tried both active and passive transfers in your FTP client? Might be a firewall problem.


    You must make sure that name.hopto.org points to your router's public IP address.
     
  10. Gleno0h

    Gleno0h New Member

    Falko, i've tried everything you said, and it's starting to work like i want to.
    the hopto.org stays on, and after 2 hours it still goes to my ip, and the banner says welcome to name.hopto.org, so thats fixed :D But my brother had a domain, now if i add that domain it pops the shared ip page :\

    Ive just fired linux op so imma check into it, probable a dns problem or something ..
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Did you create a web site for that domain in ISPConfig?
     

Share This Page