Can't enable SSL for sites in ISPConfig

Discussion in 'General' started by FeraTechInc, Feb 25, 2007.

  1. FeraTechInc

    FeraTechInc ISPConfig Developer ISPConfig Developer

    I can't seem to get SSL working on my sites. I am trying to install ZenCart with SSL. However, when installed with SSL whe I try to log in I get an error code 11236.

    Then when I try to enable SSL in the ISPConfig admin panel I can an error stating there already is a SSL certificate for this IP.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You can have only one SSL website per IP. Disable the other website that has SSL enabled and then enable it on the new website.

    This is not a limitation of ISPConfig, it is a limitation of the SSL protocol.
     
  3. FeraTechInc

    FeraTechInc ISPConfig Developer ISPConfig Developer

    Wow that is some pretty bad news...

    So I can't have 2 clients that want to use SSL shopping carts unless I can get them separate IPs?
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Yes. You need a dedicated IP for every SSL certificate.
     
  5. kcackler

    kcackler New Member

  6. pwalsh110

    pwalsh110 New Member

    How to set up shared SSL

    I have seen a couple references to Shared SSL, do you have or know of a guide on how to implement this? I have been searching for this information to no avail.

    Thanks

    Phillip
     
  7. rdtech

    rdtech New Member

  8. jcaston

    jcaston New Member

    I'm interested in shared ssl as well... does anyone have any experience implementing it with ispconfig?
     

Share This Page