Can't do it. Mono-Project

Discussion in 'Installation/Configuration' started by BullyWug, Nov 20, 2006.

  1. BullyWug

    BullyWug New Member

    Hi to all

    Im having some problems in configure mono in my ispconfig server.

    I have read the lasts posts related to this, but i still can´t show my asp pages.

    This is my Vhosts_ispconfig.conf file:

    <VirtualHost *:80>
    DocumentRoot /srv/www/web1/web
    ServerName www.example.com
    MonoApplications default "/:/srv/www/web1/web"
    MonoDocumentRootDir " /srv/www/web1/web"
    <Location />
    SetHandler mono
    </Location>

    </VirtualHost>

    and the httpd.conf file is:

    DirectoryIndex index.asp index.html index.htm index.shtml index.cgi index.php index.php5 index.php4 index.php3 index.pl index.html.var index.aspx default.aspx

    #Mono-Project INSTALL docs
    LoadModule mono_module /usr/lib/apache2/mod_mono.so
    MonoApplications '/:/srv/www/web1/web'
    MonoDocumentRootDir '/srv/www/web1/web'
    <Location />
    SetHandler mono
    </Location>


    <Location /mono>
    SetHandler mono-ctrl
    </Location>

    When i try open the website www.example.com, get the error
    Service Temporarily Unavailable

    The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

    Additionally, a 503 Service Temporarily Unavailable error was encountered while trying to use an ErrorDocument to handle the request.


    if i open with this url: www.example.com/index.asp, the opens the file for download.

    Can the master's of ISPCONFIG help me in this one :p

    Best Regards
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in Apache's error log?
     
  3. BullyWug

    BullyWug New Member

    I falko i'm sorry not reply sonner, my ploblems with mod_mon still happens this my last update when i try to open my website. http://example.com

    Server error in '/' application
    File '/' not found.
    Description: Error processing request.

    Error Message: HTTP 404. File '/' not found.

    when i try http://example.com/index.asp

    it open's the transfer browser page.

    the Vhosts_ispconfig.conf file


    ######################################
    # Vhost: example.com:80
    ######################################
    #
    #
    <VirtualHost xxx.xxx.xxx.xxx:80>
    ServerName example.com:80
    ServerAdmin [email protected]
    DocumentRoot /srv/www/web11/web
    MonoApplications default "/:/srv/www/web11/web"
    MonoDocumentRootDir "/srv/www/web11/web"
    AddHandler mono .asp .aspx .ascx .asax .ashx .config .cs .asmx .axd
    <Location />
    SetHandler mono
    </Location>

    ServerAlias
    #DirectoryIndex index.asp index.php index.html index.htm index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias /cgi-bin/ /srv/www/web11/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /srv/www/web11/log/error.log
    #AddType application/x-httpd-php .php .php3 .php4 .php5
    #<Files *.php>
    # SetOutputFilter PHP
    # SetInputFilter PHP
    #</Files>
    #<Files *.php3>
    # SetOutputFilter PHP
    # SetInputFilter PHP
    #</Files>
    #<Files *.php4>
    # SetOutputFilter PHP
    # SetInputFilter PHP
    #</Files>
    #<Files *.php5>
    # SetOutputFilter PHP
    # SetInputFilter PHP
    #</Files>
    #php_admin_flag safe_mode Off
    Alias /error/ "/srv/www/web11/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /srv/www/web11/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /srv/www/web11/user/$1/web/$3
    </VirtualHost>


    In the web.conf file
    <appSettings>
    <add key="MonoServerDefaultIndexFiles" value="index.asp,index.aspx, index.html, index.htm" />
    </appSettings>


    In the httpd.conf file:

    Include /etc/apache2/conf.d/mod_mono.conf

    Any ideas??

    Best regards
    BullyWug
     
  4. falko

    falko Super Moderator ISPConfig Developer

    And what's in Apache's error log?
     
  5. BullyWug

    BullyWug New Member

    error_log file:

    Unhandled Exception: System.ArgumentException: Should be something like [[hostname:]port:]VPath:realpath
    at Mono.WebServer.ApplicationServer.AddApplicationsFromCommandLine (System.String applications) [0x00000]
    at (wrapper remoting-invoke-with-check) Mono.WebServer.ApplicationServer:AddApplicationsFromCommandLine (string)
    at Mono.XSP.Server.Main (System.String[] args) [0x00000]

    Unhandled Exception: System.ArgumentException: Should be something like [[hostname:]port:]VPath:realpath
    at Mono.WebServer.ApplicationServer.AddApplicationsFromCommandLine (System.String applications) [0x00000]
    at (wrapper remoting-invoke-with-check) Mono.WebServer.ApplicationServer:AddApplicationsFromCommandLine (string)
    at Mono.XSP.Server.Main (System.String[] args) [0x00000]
    Another mod-mono-server with the same arguments is already running.
    Another mod-mono-server with the same arguments is already running.
    Another mod-mono-server with the same arguments is already running.

    Unhandled Exception: System.ArgumentException: Should be something like [[hostname:]port:]VPath:realpath
    at Mono.WebServer.ApplicationServer.AddApplicationsFromCommandLine (System.String applications) [0x00000]
    at (wrapper remoting-invoke-with-check) Mono.WebServer.ApplicationServer:AddApplicationsFromCommandLine (string)
    at Mono.XSP.Server.Main (System.String[] args) [0x00000]
    Another mod-mono-server with the same arguments is already running.

    Unhandled Exception: System.ArgumentException: Should be something like [[hostname:]port:]VPath:realpath
    at Mono.WebServer.ApplicationServer.AddApplicationsFromCommandLine (System.String applications) [0x00000]
    at (wrapper remoting-invoke-with-check) Mono.WebServer.ApplicationServer:AddApplicationsFromCommandLine (string)
    at Mono.XSP.Server.Main (System.String[] args) [0x00000]
    Another mod-mono-server with the same arguments is already running.
    Another mod-mono-server with the same arguments is already running.

    Unhandled Exception: System.ArgumentException: Should be something like [[hostname:]port:]VPath:realpath
    at Mono.WebServer.ApplicationServer.AddApplicationsFromCommandLine (System.String applications) [0x00000]
    at (wrapper remoting-invoke-with-check) Mono.WebServer.ApplicationServer:AddApplicationsFromCommandLine (string)
    at Mono.XSP.Server.Main (System.String[] args) [0x00000]

    Unhandled Exception: System.ArgumentException: Should be something like [[hostname:]port:]VPath:realpath
    at Mono.WebServer.ApplicationServer.AddApplicationsFromCommandLine (System.String applications) [0x00000]
    at (wrapper remoting-invoke-with-check) Mono.WebServer.ApplicationServer:AddApplicationsFromCommandLine (string)
    at Mono.XSP.Server.Main (System.String[] args) [0x00000]
    [Tue Dec 05 22:15:56 2006] [notice] caught SIGTERM, shutting down
    [Tue Dec 05 22:15:58 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Tue Dec 05 22:15:58 2006] [warn] module actions_module is already loaded, skipping
    [Tue Dec 05 22:15:58 2006] [warn] module userdir_module is already loaded, skipping
    [Tue Dec 05 22:15:59 2006] [notice] Apache/2.2.0 (Linux/SUSE) configured -- resuming normal operations
    Another mod-mono-server with the same arguments is already running.
    Another mod-mono-server with the same arguments is already running.
    Another mod-mono-server with the same arguments is already running.
    Another mod-mono-server with the same arguments is already running.
    Another mod-mono-server with the same arguments is already running.
    Another mod-mono-server with the same arguments is already running.
    Another mod-mono-server with the same arguments is already running.
    Another mod-mono-server with the same arguments is already running.
    Another mod-mono-server with the same arguments is already running.
    Another mod-mono-server with the same arguments is already running.
    Another mod-mono-server with the same arguments is already running.
    Another mod-mono-server with the same arguments is already running.


    I change also the mod_mono.conf for asp pages.
     
  6. EL7oot

    EL7oot New Member

    i have same problem can any one help me ??

    this is my error_log
    ***************************************************************************
    [Sat Apr 14 16:35:56 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sat Apr 14 16:35:57 2007] [error] Failed running '/usr/lib/pkgconfig/../../bin/mono /usr/lib/pkgconfig/../../lib/xsp/1.0/mod-mono-server.exe --filename /tmp/mod_mono_server_global --nonstop --master (null) (null) (null) (null) (null) (null) (null)'. Reason: No such file or directory
    [Sat Apr 14 16:35:57 2007] [error] Failed running '/usr/lib/pkgconfig/../../bin/mono /usr/lib/pkgconfig/../../lib/xsp/1.0/mod-mono-server.exe --filename /tmp/mod_mono_server_global --nonstop --master (null) (null) (null) (null) (null) (null) (null)'. Reason: No such file or directory
    [Sat Apr 14 16:35:57 2007] [error] Failed running '/usr/lib/pkgconfig/../../bin/mono /usr/lib/pkgconfig/../../lib/xsp/1.0/mod-mono-server.exe --filename /tmp/mod_mono_server_global --nonstop --master (null) (null) (null) (null) (null) (null) (null)'. Reason: No such file or directory
    [Sat Apr 14 16:35:57 2007] [error] Failed running '/usr/lib/pkgconfig/../../bin/mono /usr/lib/pkgconfig/../../lib/xsp/1.0/mod-mono-server.exe --filename /tmp/mod_mono_server_global --nonstop --master (null) (null) (null) (null) (null) (null) (null)'. Reason: No such file or directory
    [Sat Apr 14 16:35:57 2007] [error] Failed running '/usr/lib/pkgconfig/../../bin/mono /usr/lib/pkgconfig/../../lib/xsp/1.0/mod-mono-server.exe --filename /tmp/mod_mono_server_global --nonstop --master (null) (null) (null) (null) (null) (null) (null)'. Reason: No such file or directory
    [Sat Apr 14 16:35:57 2007] [error] Failed running '/usr/lib/pkgconfig/../../bin/mono /usr/lib/pkgconfig/../../lib/xsp/1.0/mod-mono-server.exe --filename /tmp/mod_mono_server_default --applications /:/srv/www/web1/web --nonstop --root /srv/www/web1/web (null) (null) (null) (null)'. Reason: No such file or directory
    [Sat Apr 14 16:35:57 2007] [notice] Apache/2.2.0 (Linux/SUSE) configured -- resuming normal operations
    [Sat Apr 14 16:35:57 2007] [error] Failed running '/usr/lib/pkgconfig/../../bin/mono /usr/lib/pkgconfig/../../lib/xsp/1.0/mod-mono-server.exe --filename /tmp/mod_mono_server_global --nonstop --master (null) (null) (null) (null) (null) (null) (null)'. Reason: No such file or directory
    [Sat Apr 14 16:35:57 2007] [error] Failed running '/usr/lib/pkgconfig/../../bin/mono /usr/lib/pkgconfig/../../lib/xsp/1.0/mod-mono-server.exe --filename /tmp/mod_mono_server_default --applications /:/srv/www/web1/web --nonstop --root /srv/www/web1/web (null) (null) (null) (null)'. Reason: No such file or directory
    [Sat Apr 14 16:35:57 2007] [error] Failed running '/usr/lib/pkgconfig/../../bin/mono /usr/lib/pkgconfig/../../lib/xsp/1.0/mod-mono-server.exe --filename /tmp/mod_mono_server_global --nonstop --master (null) (null) (null) (null) (null) (null) (null)'. Reason: No such file or directory
    [Sat Apr 14 16:35:57 2007] [error] Failed running '/usr/lib/pkgconfig/../../bin/mono /usr/lib/pkgconfig/../../lib/xsp/1.0/mod-mono-server.exe --filename /tmp/mod_mono_server_global --nonstop --master (null) (null) (null) (null) (null) (null) (null)'. Reason: No such file or directory
    [Sat Apr 14 16:35:57 2007] [error] Failed running '/usr/lib/pkgconfig/../../bin/mono /usr/lib/pkgconfig/../../lib/xsp/1.0/mod-mono-server.exe --filename /tmp/mod_mono_server_default --applications /:/srv/www/web1/web --nonstop --root /srv/www/web1/web (null) (null) (null) (null)'. Reason: No such file or directory
    [Sat Apr 14 16:35:57 2007] [error] Failed running '/usr/lib/pkgconfig/../../bin/mono /usr/lib/pkgconfig/../../lib/xsp/1.0/mod-mono-server.exe --filename /tmp/mod_mono_server_global --nonstop --master (null) (null) (null) (null) (null) (null) (null)'. Reason: No such file or directory
    [Sat Apr 14 16:35:57 2007] [error] Failed running '/usr/lib/pkgconfig/../../bin/mono /usr/lib/pkgconfig/../../lib/xsp/1.0/mod-mono-server.exe --filename /tmp/mod_mono_server_default --applications /:/srv/www/web1/web --nonstop --root /srv/www/web1/web (null) (null) (null) (null)'. Reason: No such file or directory
    [Sat Apr 14 16:35:57 2007] [error] Failed running '/usr/lib/pkgconfig/../../bin/mono /usr/lib/pkgconfig/../../lib/xsp/1.0/mod-mono-server.exe --filename /tmp/mod_mono_server_global --nonstop --master (null) (null) (null) (null) (null) (null) (null)'. Reason: No such file or directory
    [Sat Apr 14 16:35:57 2007] [error] Failed running '/usr/lib/pkgconfig/../../bin/mono /usr/lib/pkgconfig/../../lib/xsp/1.0/mod-mono-server.exe --filename /tmp/mod_mono_server_default --applications /:/srv/www/web1/web --nonstop --root /srv/www/web1/web (null) (null) (null) (null)'. Reason: No such file or directory
    ***************************************************************************
     
    Last edited: Apr 14, 2007
  7. falko

    falko Super Moderator ISPConfig Developer

    There seems to be a missing file or directory. Do /usr/bin/mono, /usr/lib/xsp/1.0/mod-mono-server.exe and /tmp/mod_mono_server_global exist?
     

Share This Page