Can't create website on remote server

Discussion in 'Installation/Configuration' started by pixelmonkey, Aug 10, 2009.

  1. pixelmonkey

    pixelmonkey New Member


    I've built a multiserver setup that I believe works and the 2nd server apears OK in the control panel on the 1st server.

    When I create a website via server1 on server2 I get no errors however the new directories are not created on server 2. As a result when I point my browser at the new website I get "It Works" from the root of /var/www on server2.

    Web sites created on server1 are all OK

    My plan is to have email on server1 and web sites on server2 which I believe should be possible.

    Any pointer as to where I should be looking to resolve this issue??

    Servers are both Ubuntu 9.04 with ISPC3

    Many Thanks
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    How did you add the second server to the ISPConfig master server?
  3. pixelmonkey

    pixelmonkey New Member


    I built server1 as per the ubuntu perfect server how to ( BTW excellent How To)

    Then built server2 installed MYSql, Apache2 etc & finallay did expert install of ISPC3. Created local DB & conected to server1 db.

    After that I was able to see server2 from server1 " I think"

  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. pixelmonkey

    pixelmonkey New Member

    Hi Till

    Done that & now get error message:

    10.08.2009-15:27 - WARNING - DB::connect()-> mysql_connect Access denied for user 'ispcsrv3'@'' (using password: YES)

    So my guess is that I need to add ispcsrv3'@' to server1 SQL permissions?

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. This problem can occur e.g. when the hostnames of all systems in a multiserver system can not be resolved from every node.
  7. pixelmonkey

    pixelmonkey New Member

    Ok - What SQl permissions will this account need - would it just be select ??

    If I ping server1 from server2 the names resolves to the correct IP & the same if I ping server2 from server1
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Select permissions are not enough. The best is that you change just the hostname field of the existing records of the user ispcsrv3 so that they allow access from the hostname of the secondary server and the IP of the secondary server.
  9. pixelmonkey

    pixelmonkey New Member

    Looking in PHPMYADMIN it would appear that the account ispcsrv3'@' has "N" against all priviledges, should these all be set to "Y" same as root???
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    No, do not change the permissions! Just change the hostname as I explianed above and do this in all the permission tables.
  11. pixelmonkey

    pixelmonkey New Member

    OK not sure if I've done the right thing but on server1 MYSQL|user changed ispcsrv3'@' to host name & the same in MYSQL|DB. So in both areas I have hostname and correct IP i.e changed to

    These details appear to only be on the master server i.e server1 & not on the slave, server2
  12. pixelmonkey

    pixelmonkey New Member


    Just a quick update to let you know problem has now been resolved. I added all the server details to the /etc/hosts files on both servers & now all is OK.

    Looks as though I may have a DNS issues here, which I will dig in to further

    Many thnaks for your help

Share This Page