Can't create new FTP user

Discussion in 'Installation/Configuration' started by JonathanMM, Jul 5, 2020.

  1. JonathanMM

    JonathanMM New Member

    Hello everyone,
    after an upgrade to Ubuntu Server 20.04 LTS, with issue with pureftpd, I can't connect to FTP using an user configured with ISPConfig. After investigation, the database of pureftpd was gone. So, I uninstall and install pure-ftpd-mysql, I create a new database and a dedicated mysql user associate, add a table users with a script from tutoriel on the web, and updated the configuration of pure ftpd mysql with new mysql user credentials.
    When I try to create a new user in ISP Config, the task is executed without issue (no error message) but the users table of pureftpd still empty. And I don't know why.
    Can you help me?
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Ubuntu 20.04 is not yet officially supported for ISPConfig. So maybe it just does not work.
    You wrote you upgraded, but did not say how. Have you followed Ubuntu release upgrade instructions? Have you followed the ISPConfig Perfect Server Guide for Ubuntu 20.04 to check all needed packages are installed and configurations made according to that Guide? Have you forced reconfigure services in ISPConfig so they are up to date?
    There are threads in this forum on upgrading OS and ISPConfig.
  3. JonathanMM

    JonathanMM New Member

    Hello Taleman,
    yes, I followed the Ubuntu release upgrade instructions. I think the issue with pureftpd happened because we tried to reconfigure it without a mysql/mariadb server started…
    I tried to reconfigure services and now, everything works fine. Many thanks!!!!
    ahrasis likes this.

Share This Page