Can't create email user

Discussion in 'Installation/Configuration' started by mzo, Feb 9, 2006.

  1. mzo

    mzo New Member


    Just having small problem over here. That is previously I'm using and create email [email protected]. So later, I reinstall Ispconfig and change my domain to and try to create [email protected] but the mesaage is "user exist". I already check my recycle bin and nothing there.

    I also notice that after reinstall ispconfig, I fail to use web statistic. Is there any configuration that I need to change ? please advise.

  2. falko

    falko Super Moderator ISPConfig Developer

    The ISPConfig installer puts all users that exist on the system prior to the installation into the file/home/admispconfig/ispconfig/users. Whenever you want to create a new user in ISPConfig this file is checked in order to avoid creating a user that already exists. If you remove the user from the file (and make sure the user doesn't exist in /etc/passwd and /etc/shadow anymore!) then you can create the user in ISPConfig.
  3. mzo

    mzo New Member

    MZO : I also notice that my local-host-names in etc/postfix still point to old domain, example :


    Any idea on how I want to change it to server.b.b.b?

    MZO : I see many email fail delivery on previous domain in /var/log/maillog. All still in queu and keep trying to send again. How I want to remove these previous domain email ?

    Sample my maillog in /var/log

    Feb 10 09:26:12 server postfix/qmgr[7395]: 94FE62EEBA1: to=<[email protected]>, orig_to=<[email protected]>, relay=none, delay=51025, status=deferred (delivery t
    emporarily suspended: connect to[]: Connection timed out)
    Feb 10 09:26:12 server postfix/qmgr[7395]: 94FE62EEBA1: to=<[email protected]>, orig_to=<[email protected]>, relay=none, delay=51025, status=deferred (delivery tempo
    rarily suspended: connect to[]: Connection timed out)
    Feb 10 09:26:12 server postfix/qmgr[7395]: 43A772EEB9E: to=<[email protected]>, orig_to=<[email protected]>, relay=none, delay=79271, status=deferred (delivery temporarily suspen
    ded: connect to[]: Connection timed out)

    I'm not using and already remove the in ispconfig but it still exist in the system. Please advise.

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you changed the hostname in /etc/hostname?

    echo > /etc/hostname
    /bin/hostname -F /etc/hostname

    You can delete messages from your mailqueue with the "postsuper" command. To empty the complete mailqueue, execute the command:

    postsuper -d ALL
  5. element609

    element609 New Member

    another users issue, bump

    Great software, btw.

    I noticed that deleting and recreating users didn't work for me.

    OK so I made sure that ALL recycle bins are empty, all users were gone. I only have 2 resellers and 5 domains, not too hard to look through.

    So, I found this post and it works. Just confirm they aren't in /etc/passwd and backup and delete the users from /home/admispconfig/ispconfig/users

    So I checked /home/admispconfig/ispconfig/users later, and it doens't seem to get updated anymore - whether I add or remove user names.

    I'm using 2.2.2 on Ubuntu 5.10.

    Any suggestions?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig manages only users, that where created trough ISPConfig. All other users where listed in the file /home/admispconfig/ispconfig/users which is a blacklist for ISPConfig. The Blacklist is created once at installation time.
  7. moserwi

    moserwi New Member

    User already exists

    I've read the bb messages of 2006 about editing /home/admispconfig/ispconfig/user.

    I have the same problem BUT:

    etc/passwd - users have been added
    passwd- users missing
    /home/admispconfig/ispconfig/user - no entries

    Though I added a new user, saved the first form and tried to enter a redirection adress afertwards with result "User already exists"

    The user dirs of web1 have been created correctly

    We are talking about a VMWare Centos5 with a ln -s of /var/www to the raid mirrors(/dev/md0 mounted as /home) directory /home/www
    a test account as webmaster have not have been a problem but the other accounts refuse correct configuration

    The CentOS-VM is running on an 3800 Dual with 8GIG RAM and the actual vmware server is acting as gateway and shorewall for 3 external and 1 internal interfaces.

    CentOS5 is not yet supported by VMware - the CentOS5-VM is dead slow. I suppose there will be a fix from VMware soon and it should not really affect my ISPConfig Problem.

    Thank you for your very appreciated help.

    brgds willi
  8. falko

    falko Super Moderator ISPConfig Developer

    Have you checked the recycle bins if that user is in there?
  9. moserwi

    moserwi New Member

    recycle bin

    sorry no - I have ignored them sind 2005 ,-)

    What I did is deleting manually

    resetting /etc/postfix to original settings
    resetting /etc/httpd/httpd.conf to original settings

    what I actually forget was this recycle bin thing
    but I think I managed it deleting the db_ispconfig before running setup again

    I think you really should add an unistall script to clear all data and I think additional checks should be done in user manipuilation.

    For me it is not clear which name I should use for the server.
    With the old configuration it is

    blue.lan internal and gets its names form the local named like



    Thoug the best way would be to use the http base www.FQDN and blue.lan for internal http requests

    I did 4-5 installs with little problems, one was a localIP behind a firewall, but I am really having troubles now.

    as it looks like, with the webmaster accout ther is a mismatch again incoming/outgoing

    sqirrelmail message
    Email delivery error
    Server antwortete: 67 Can't execute command '/usr/sbin/sendmail -i -t -fweb1_webmaster@localhost'.

    that meas for me that ISPConfig does not implement the mailadresses properly with postfix.

    /etc/hosts is localhost.localdomain localhost blue.FQDN blue

    -> wanted to create a domain blue.lan
    issue Invalid domain name lan

    I have not had this Problems 2006/7 - ???

    Thank you
  10. falko

    falko Super Moderator ISPConfig Developer

    Such a script exists: /root/ispconfig/uninstall

    When you install ISPConfig, you must make sure that the FQDN that you specify is already existing (either in DNS or in /etc/hosts) so that the installer can ping this FQDN. If it can't ping it, the installation fails.
  11. moserwi

    moserwi New Member

    sorry for beeing late with my reply. I think I solved it.

    The setup was as described in "perfect setup".
    But Due to the shorewall-firewall layout I do have to have a split brained DNS.
    editing resolv.conf with the very first nameserver as did it. ( the lan adress is which caused DNS queries to be answered for 192.168. and not with the external settings at

    Thank you for your guidance.

    p.s.: INFO

    CentOS 5.1 in vmware 1.0.4 was dead slow -becoming better now.
    Critical: using mc for fileops on the md0 array (the 2 drives are defined as sdb and sdc in vmware.vmdk? is drowning the CentOS Server!
    installing vmware-tools is an adventure - my kernel should be patched
    drivers/input/serio/i9042.c claims tainted kernel due to some licensing problems of the vmnet drivers.

    really a mess

    greetings willi, vienna

Share This Page