Can't create database

Discussion in 'General' started by briandelshasta, Nov 6, 2009.

  1. briandelshasta

    briandelshasta New Member

    I've create a couple databases, both with the admin account and with client accounts. Now for some reason when I create a database in ISPConfig 3 is doesn't actually exist in mysql. ISPConfig does not seem to notice any problem and does display the database, but obviously no webapps can connect to the non-existent db.

    Does anyone know where to begin troubleshooting this?

    Thanks
     
  2. rootfive

    rootfive New Member

    Database is created but it does not grant privileges to user. Use phpmyadmin to give privileges and it will be ok.
     
  3. briandelshasta

    briandelshasta New Member

    Perhaps I wasn't clear. The database is not getting created. I've logged into the mysql cli and the database is not there.
    I thinking some privs got messed up for the ispconfig user maybe, but I can't remember where to find those creds.
     
  4. rootfive

    rootfive New Member

    I finished ispconfig3 this morning on CentOS5.4 and I have no problem creating database, the only problem is it does not grant rights.
     
  5. till

    till Super Moderator

    Then you must have installed ispconfig with a wrong mysql user. When the installer aksks for a mysql user, you have to use the root user, otherweise ispconfig does not have the rights later to create new mysql users and databases.
     
  6. rootfive

    rootfive New Member

    I installed with the right user. ISPConfig create the database and user. The only thing is it does not grant the permission to user for the created database. When I grant the user permission from myphpadmin it works fine. Otherwise joomla give me it cannot connect to database. I am not sure it is either bug or installation problem. I followed the procedure of perfect setup with ISPconfig 3 and centos5.4

    Thanks
     
  7. till

    till Super Moderator

    Which ispconfig version?
     
  8. rootfive

    rootfive New Member

    ISPConfig 3.0.1.6 running on CentOS 5.4
     
  9. s0l0n

    s0l0n New Member

    database shown in ISPConfig3 but not in Mysql

    I have the same problem: database is shown as created in ISPConfig3 but it does not exists in Mysql. I've connected with user root in phpmyadmin and there is no database created.

    I installed ispconfig 3.0.2.1 with centos 5.5 as in The Perfect Server - CentOS 5.5 x86_64 [ISPConfig 3]

    There are no errors. I looks like ISPConfig doesn't even try to create the databases in MySql. It just insert them in dbispconfig database.
     
  10. mike_p

    mike_p Member

    How are you checking whether the database is there? If the mysql user you are logging in as doesn't have rights to the database, then it won't report it's existence.

    If thats the case then your problem is the same as the other guys on this thread.

    In all these cases, it has to be some unusual configuration because, obviously, the majority of people using ISPConfig don't have the problem.

    @rootfive - the clear recommndation will be to upgrade to version 3.0.2.1
     
  11. s0l0n

    s0l0n New Member

    ISP Config action log

    Is there any ISP Config action log? I could check there all the ISP Config actions and status for them.

    I activated MySql General Query log and when I try to create a database from ISP Config, the only query sent to MySql is insert into dbispconfig. There is no create database tried.

    It will be very useful to have an ISP Config action log where I can see all the task done like directories created, sql queries or other shell commands run.
     
  12. till

    till Super Moderator

Share This Page