Cant create a webID when creating new website.

Discussion in 'General' started by SamTzu, Dec 18, 2019.

  1. SamTzu

    SamTzu Active Member

    Cant create a webID when creating new website.
    Not even with admin account.
    /etc/shadow file does not show new webID account.
    All sites are created with root:clientXX permissions.
    Normally client root folder would look something like this...
    Code:
    drwxr-xr-x 11 root  root    11 Mar 23  2018 .
    drwxr-xr-x  3 root  root     4 Nov 14  2016 ..
    drwx------  2 web21 client7  2 Mar 23  2018 .ssh
    drwxr-xr-x  2 web21 client7  2 Nov 26  2016 backup
    drwxr-xr-x  2 web21 client7  2 Nov 14  2016 cgi-bin
    drwxr-xr-x  2 root  root    69 Dec 18 05:39 log
    drwx--x---  2 web21 client7  2 Nov 14  2016 private
    drwxr-xr-x  2 root  root     5 Apr 15  2019 ssl
    drwxrwx---  2 web21 client7  2 Nov 17 06:26 tmp
    drwx--x--x 22 web21 client7 33 Aug 14 08:09 web
    drwx--x---  2 web21 client7  2 Nov 14  2016 webdav
    But now all new folders look like:
    Code:
    root:client7 web
    It's the same problem with both admin account and reseller accounts.
    Where should I start looking first?
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

  3. SamTzu

    SamTzu Active Member

    Nothing in the logs.
    No new clients get added to /etc/shadow file and there is no error in ispconfig.log.
     
  4. SamTzu

    SamTzu Active Member

    Code:
    19.12.2019-16:26 - DEBUG - safe_exec cmd: useradd -d '/var/www/clients/client50/web342' -g 'client50'  -G sshusers 'web342' -s /bin/false - return code: 10
    19.12.2019-16:26 - DEBUG - Adding the user: web342
    19.12.2019-16:26 - DEBUG - safe_exec cmd: chattr -i '/var/www/clients/client50/web342' - return code: 0
    19.12.2019-16:26 - DEBUG - chown failed: /var/www/clients/client50/web342/.ssh : web342
    19.12.2019-16:26 - DEBUG - chown failed: /var/www/clients/client50/web342/private : web342
    
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Run this command as root user:

    Code:
    useradd -d '/var/www/clients/client50/web342' -g 'client50'  -G sshusers 'web342' -s /bin/false
    which error do you get on the shell?
     
  6. SamTzu

    SamTzu Active Member

    Oddly enough "Make web folders immutable (extended attributes)" is NOT enabled but I can see chattr command still in debug log.
     
  7. SamTzu

    SamTzu Active Member

    Ok now lightbulp lights up.
    thx Till.
    Code:
    Multiple entries named 'sshusers' in /etc/group. Please fix this with pwck or grpck.
    useradd: failed to prepare the new /etc/group entry 'sshusers'
    
     
  8. SamTzu

    SamTzu Active Member

    After removing the extra sshusers from group file and reboot I get no more error messages.
     
    till likes this.
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Try using the command:

    grpck

    which can clean up the group file for you.
     

Share This Page