Can't connect to the internet

Discussion in 'HOWTO-Related Questions' started by Leadwings, May 5, 2008.

  1. Leadwings

    Leadwings New Member

    I'm about ready to pull my hair out over this problem.:confused: I have 2 computers at my house, one is a dual boot with Windows XP and PCLinuxOS 2007, the other is just running PCLinuxOS 2007. I have a cable internet connection that goes through a router, and both computers are connected to the router. The problem is that I can only access the internet from the dual boot system, and only when running Windows XP, not when running Linux. I've done countless internet searches to find some way of fixing the problem, but even though the router recognizes the connection and the lights on my NIC show a valid connection I still can't access the internet. I keep going through the procedure step by step, and at the end of the procedure I get the "Congratulations" screen, but when I attempt to access a web page, nothing ever happens. Before choosing PCLinuxOS, I had tried Mandriva, and it always showed that a connection was made, but it would only receive a few packages at a time, and I could never pull up an internet page. I should tell you that I can pull up the router configuration page, so my connection to the router is good, but beyond that, I don't know. I had a very difficult time even connecting the Windows OS to the internet. I'm an American living in Israel, so I don't ever get anything accomplished when I call the Internet company due to the language barrier. I'm new to Linux, and I want to drop Windows altogether, but I just need to get past this hurdle. Any help you could give would be greatly appreciated.
  2. Leadwings

    Leadwings New Member

    A gentleman from the cable internet company called my house last night and worked for almost an hour to get me online. To make a long story short, when I hung up the phone I was connected on the internet. An hour or so later however, my router dropped the connection, and somehow the IP address changed. I'm not sure how this happened, and I'm wondering if I have a defective router. When I was on the phone with him last night, he was having me ping the IP address, and then he had me log in as root in the terminal. From there he led me through a process that opened up KWrite, and it showed the IP address on there. The command was SomethingSomething??.resolv, I can't remember the exact command. If anyone knows the command, could you please let me know for future reference? I'm a little better off today than I was yesterday, but I'm still not online. If anyone could help me out I would appreciate it. I don't know if I'll be able to get the same person that helped me last night when I call again.
  3. falko

    falko Super Moderator ISPConfig Developer

    Two commands that might help you are:
    (shows the IP addresses of the system)
    route -nee
    (shows IP addresses and the gateway).
  4. Leadwings

    Leadwings New Member

    Can't connect to the internet (Solved)

    I just got off the phone with the guy from the cable internet company. He helped me get connected again, so I'm in good shape now. I still have no idea what happened. He told me that I need to get a static IP address, and that should solve the problem. Thanks for the help though.

Share This Page