Cant connect to SMTP server

Discussion in 'Installation/Configuration' started by mbogh, May 19, 2010.

  1. mbogh

    mbogh New Member

    Hello guys,

    When I telnet to my server from an external source and type "ehlo hostname" I get disconnected.

    in mail.log:
    Code:
    May 19 09:45:02 monkey postfix/smtpd[21795]: connect from localhost[127.0.0.1]
    May 19 09:45:02 monkey postfix/smtpd[21795]: lost connection after CONNECT from localhost[127.0.0.1]
    May 19 09:45:02 monkey postfix/smtpd[21795]: disconnect from localhost[127.0.0.1]
    
    If i try from the server itself, it works like a charm.

    Please help me to figure out this problem.

    -mbogh
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    the linews from the mail log are not from your connection attempt, they are from the automatic system check which runs every 5 minutes.

    As you say internal and external, I guess you run your server behind a router? In this case, check the router settings to ensure that you forwarded port 25 from the server to the router. Another possibility is that your internet access provider blocks the connects, many cable and dsl providers do not allow connections on port 25 to prevent spam.
     
  3. mbogh

    mbogh New Member

    As far as i know Hetzner.de does not block port 25 and in the firewall settings are standard ispconfig 3.

    Acoording to http://www.t1shopper.com/tools/port-scan/ "hostname is responding on port 25 (smtp)."
     
  4. mbogh

    mbogh New Member

  5. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ? Are there any other errors in your mail log?
     
  6. mbogh

    mbogh New Member

    Found that all the connections I tried from had blocked port 25 outgoing so I have opened port 587 for smtp. So now it works :)

    Thank you for your help.
     

Share This Page