Can't Connect to Server from Browser

Discussion in 'Server Operation' started by BMan12, Jun 8, 2008.

  1. BMan12

    BMan12 New Member

    I have Ubuntu 9.04 Server installed and I followed "The Perfect Server" guide. However, I cannot access my server from a browser. I go to http://[myipaddress]/ and all I get is "The connection timed out".

    If I do
    Code:
    telnet localhost 80
    and then
    Code:
    GET
    on the server itself it works.

    What am I missing? What can I do to troubleshoot? I have port forwarding setup.
     
  2. d2e2

    d2e2 New Member

    same here!

    I am having a similar problem. And I can see there is not much help here. I will keep working on it. If I can figure it out, I'll be back.
     
  3. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ?
    Any errors in Apache's error log?
     
  4. d2e2

    d2e2 New Member

    This is the readout from netstat -tap

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 2024/mysqld
    tcp 0 0 *:sunrpc *:* LISTEN 3106/portmap
    tcp 0 0 *:ftp *:* LISTEN 3111/proftpd: (acce
    tcp 0 0 grapevine.manyco:domain *:* LISTEN 3023/named
    tcp 0 0 localhost:domain *:* LISTEN 3023/named
    tcp 0 0 *:smtp *:* LISTEN 3181/master
    tcp 0 0 localhost:953 *:* LISTEN 3023/named
    tcp 0 0 *:cycleserv *:* LISTEN 3136/rpc.rquotad
    tcp 0 0 localhost:phonebook *:* LISTEN 3135/famd
    tcp 0 0 *:imaps *:* LISTEN 3057/couriertcpd
    tcp 0 0 *:pop3s *:* LISTEN 3098/couriertcpd
    tcp 0 0 *:pop3 *:* LISTEN 3064/couriertcpd
    tcp 0 0 *:imap *:* LISTEN 3046/couriertcpd
    tcp 0 0 *:www-http *:* LISTEN 3236/httpd2-prefork
    tcp 0 0 *:domain *:* LISTEN 3023/named
    tcp 0 0 *:ssh *:* LISTEN 3006/sshd
    tcp 0 0 *:smtp *:* LISTEN 3181/master
    tcp 0 0 localhost:953 *:* LISTEN 3023/named
    tcp 0 0 *:https *:* LISTEN 3236/httpd2-prefork
    tcp 0 0 grapevine.manycolor:ssh applegreen.manyco:16726 ESTABLISHED 3269/sshd: me [priv
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Ok, Apache seems to be running. Are there any errors in Apache's error log?

    Does your firewall maybe block port 80?
     
  6. d2e2

    d2e2 New Member

    The following is from Apache2 error-logs

    It looks like the daemon caught itself, but it is doing this over and over. There are about thirty lines with the same statements. As far as blocking port 80, the firewall is not enabled right now, but that shouldn't affect this because I am trying to connect to 81.

    [Tue Jun 10 17:20:10 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Tue Jun 10 17:20:14 2008] [notice] Apache/2.2.4
    (Linux/SUSE) mod_ssl/2.2.4 OpenSSL/0.9.8e PHP/5.2.6 with Suhosin-Patch configured -- resuming normal operations
    [Tue Jun 10 17:50:05 2008] [notice] caught SIGTERM, shutting down
    [Tue Jun 10 17:51:21 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Tue Jun 10 17:51:24 2008] [notice] Apache/2.2.4 (Linux/SUSE) mod_ssl/2.2.4 OpenSSL/0.9.8e PHP/5.2.6 with Suhosin-Patch configured -- resuming normal operations
     
    Last edited: Jun 11, 2008
  7. falko

    falko Super Moderator ISPConfig Developer

    So you're trying to connect ISPConfig? As far as I can see, ISPConfig isn't running. Please start it:
    Code:
    /etc/init.d/ispconfig_server start
     
  8. d2e2

    d2e2 New Member

    rebooted and got to the server using ip address

    I don't know what is wrong yet. I reinstalled the whole system and got to the login using the ip socket. Still cannot get to the web page using hostname.sitename.tld.
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Please check if hostname.sitename.tld is pointing to the correct server:
    Code:
    dig hostname.sitename.tld
     
  10. d2e2

    d2e2 New Member

    Got it done!!!

    Falko thank you again for all the help. I do not know what happened in the original server setup but the setup I have now, which does not require the https, is working.

    In my last post, I reported problems connecting. Using the ip-port number it worked. This lead me to check my resolver configurations. And that is where I found the answer to my problem.

    Now that I have it running, I can begin to learn how to take advantage of the system. Thanks again.

    Dennis
     

Share This Page