can't connect to pure-ftpd

Discussion in 'Server Operation' started by ben_stilwell, Dec 13, 2010.

  1. ben_stilwell

    ben_stilwell New Member

    I installed the perfect server ubuntu 10.10 with pure-ftpd. I can connect to ftp on my internal lan but haven't been able to connect externally.

    Ports 20 and 21 are forwarded to my server.

    Filezilla is giving me this message:
    Connection attempt failed with "ECONNREFUSED - Connection refused by server".

    so erm help?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you try both active and passive transfers in your FTP client?
     
  3. ben_stilwell

    ben_stilwell New Member

    yes. Filezilla gives me the same error whether I use Passive or Active.

    I also tried cuteftp lite on both active and passive and it failed to connect.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    As it is working on your LAN, it must be something with your router. Does your router support loopbacks? Also make sure that your ISP doesn't block ports 20 and 21.
     
  5. ben_stilwell

    ben_stilwell New Member

    I'm testing the external connection from outside of the lan, so the loopback issue shouldn't be an issue.

    I'm also connecting with different ports from 20 and 21, just forwarding those ports to 20 and 21 on the server.

    ETA:

    And that was the problem. I wanted to connect via port 8021 forwarded to 21 on the server which didn't work. I changed the server port to 8021 and forwarded to that port and it works fine.
     
    Last edited: Dec 16, 2010

Share This Page