Can't connect to local MySQL server through socket

Discussion in 'Server Operation' started by ababneh, Mar 20, 2013.

  1. ababneh

    ababneh New Member

    I have ISPconfig latest version on Ubuntu 12 and nginx following this tutorial http://www.howtoforge.com/perfect-se...ispconfig-3-p5 and had everything working well until today when I tried to login to ispconfig I get this message:

    Code:
    DB::__construct Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' 
    (2)DB::__construct Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)DB::__construct Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' 
    (2)DB::__construct Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)DB::__construct Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' 
    (2)DB::__construct Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)DB::__construct Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' 
    (2)DB::__construct Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)DB::__construct Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' 
    (2)DB::__construct Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

    [​IMG]


    root@server:~# /etc/init.d/mysql restart
    start: Job failed to start

    root@server:~# telnet 127.0.0.1 3306
    Trying 127.0.0.1...
    telnet: Unable to connect to remote host: Connection refused

    with that, I can't connect to ftp either:

    Command: USER client1client1
    Response: 331 User client1client1 OK. Password required
    Command: PASS *********
    Response: 530 Login authentication failed
    Error: Critical error
    Error: Could not connect to server


    here is my config file

    Code:
    #
    # The MySQL database server configuration file.
    #
    # You can copy this to one of:
    # - "/etc/mysql/my.cnf" to set global options,
    # - "~/.my.cnf" to set user-specific options.
    #
    # One can use all long options that the program supports.
    # Run program with --help to get a list of available options and with
    # --print-defaults to see which it would actually understand and use.
    #
    # For explanations see
    # http://dev.mysql.com/doc/mysql/en/server-system-variables.html
    
    # This will be passed to all mysql clients
    # It has been reported that passwords should be enclosed with ticks/quotes
    # escpecially if they contain "#" chars...
    # Remember to edit /etc/mysql/debian.cnf when changing the socket location.
    [client]
    port            = 3306
    socket          = /var/run/mysqld/mysqld.sock
    
    # Here is entries for some specific programs
    # The following values assume you have at least 32M ram
    
    # This was formally known as [safe_mysqld]. Both versions are currently parsed.
    [mysqld_safe]
    socket          = /var/run/mysqld/mysqld.sock
    nice            = 0
    
    [mysqld]
    #
    # * Basic Settings
    #
    user            = mysql
    pid-file        = /var/run/mysqld/mysqld.pid
    socket          = /var/run/mysqld/mysqld.sock
    port            = 3306
    basedir         = /usr
    datadir         = /var/lib/mysql
    tmpdir          = /tmp
    lc-messages-dir = /usr/share/mysql
    skip-external-locking
    #
    # Instead of skip-networking the default is now to listen only on
    # localhost which is more compatible and is not less secure.
    #bind-address           = 127.0.0.1
    #
    # * Fine Tuning
    #
    key_buffer              = 16M
    max_allowed_packet      = 16M
    thread_stack            = 192K
    thread_cache_size       = 8
    # This replaces the startup script and checks MyISAM tables if needed
    # the first time they are touched
    myisam-recover         = BACKUP
    #max_connections        = 100
    #table_cache            = 64
    #thread_concurrency     = 10
    # * Query Cache Configuration
    #
    query_cache_limit       = 1M
    query_cache_size        = 16M
    #
    # * Logging and Replication
    #
    # Both location gets rotated by the cronjob.
    # Be aware that this log type is a performance killer.
    # As of 5.1 you can enable the log at runtime!
    #general_log_file        = /var/log/mysql/mysql.log
    #general_log             = 1
    #
    # Error log - should be very few entries.
    #
    log_error = /var/log/mysql/error.log
    #
    # Here you can see queries with especially long duration
    #log_slow_queries       = /var/log/mysql/mysql-slow.log
    #long_query_time = 2
    #log-queries-not-using-indexes
    #
    # The following can be used as easy to replay backup logs or for replication.
    # note: if you are setting up a replication slave, see README.Debian about
    #       other settings you may need to change.
    #server-id              = 1
    #log_bin                        = /var/log/mysql/mysql-bin.log
    expire_logs_days        = 10
    max_binlog_size         = 100M
    #binlog_do_db           = include_database_name
    #binlog_ignore_db       = include_database_name
    #
    # * InnoDB
    #
    # InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
    # Read the manual for more InnoDB related options. There are many!
    #
    # * Security Features
    #
    # Read the manual, too, if you want chroot!
    # chroot = /var/lib/mysql/
    #
    # For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
    #
    # ssl-ca=/etc/mysql/cacert.pem
    # ssl-cert=/etc/mysql/server-cert.pem
    # ssl-key=/etc/mysql/server-key.pem
    
    
    
    [mysqldump]
    quick
    quote-names
    max_allowed_packet      = 16M
    
    [mysql]
    #no-auto-rehash # faster start of mysql but no tab completition
    
    [isamchk]
    key_buffer              = 16M
    
    #
    # * IMPORTANT: Additional settings that can override those from this file!
    #   The files must end with '.cnf', otherwise they'll be ignored.
    #
    !includedir /etc/mysql/conf.d/
    
    
    
    any help is much appreciated!!!

    Thanks
     
    Last edited: Mar 20, 2013
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

  3. ababneh

    ababneh New Member

    Thanks for sharing that article. It turned out that my hard disk was full and that's the reason mysql service failed:rolleyes: can't believe I let 1 tb gets full...:)
     
: mysql sock

Share This Page