cant connect to hostname but sites r fine

Discussion in 'Installation/Configuration' started by jimmie, Apr 27, 2020.

  1. jimmie

    jimmie Member

    my host name is computer-hosting.com and i can nolonger access through hostname. computer-hosting.com:8080 does not work but jnsflooringandsupplies.com:8080 works. what did i do wrong, i created a computer-hosting site in admin with dns, but deleted it to do it different, created new but cant see it
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. jimmie

    jimmie Member

    connecting through ip address works,
     
  4. jimmie

    jimmie Member

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Which exact error message do you get in the web browser?
     
  6. jimmie

    jimmie Member

    server not found, when i try to putty in says host not found
     
  7. jimmie

    jimmie Member

    i tried to create new site for computer-hosting.com, wont connect either
     
  8. jimmie

    jimmie Member

    the 1 and only website i host (mine) works and i can access all areas of ispconfig through jnsflooringandsupplies.com
     
  9. jimmie

    jimmie Member

    netstat - tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 0.0.0.0:ftp 0.0.0.0:* LISTEN 2027/pure-ftpd (SER
    tcp 0 0 rrcs-97-76-140-1:domain 0.0.0.0:* LISTEN 964/named
    tcp 0 0 localhost:domain 0.0.0.0:* LISTEN 964/named
    tcp 0 0 localhost:domain 0.0.0.0:* LISTEN 825/systemd-resolve
    tcp 0 0 0.0.0.0:ssh 0.0.0.0:* LISTEN 1285/sshd
    tcp 0 0 0.0.0.0:smtp 0.0.0.0:* LISTEN 1831/master
    tcp 0 0 localhost:953 0.0.0.0:* LISTEN 964/named
    tcp 0 0 0.0.0.0:imaps 0.0.0.0:* LISTEN 932/dovecot
    tcp 0 0 0.0.0.0:pop3s 0.0.0.0:* LISTEN 932/dovecot
    tcp 0 0 localhost:10023 0.0.0.0:* LISTEN 1827/postgrey --pid
    tcp 0 0 localhost:10024 0.0.0.0:* LISTEN 2039/amavisd-new (m
    tcp 0 0 localhost:10025 0.0.0.0:* LISTEN 1831/master
    tcp 0 0 localhost:10026 0.0.0.0:* LISTEN 2039/amavisd-new (m
    tcp 0 0 localhost:10027 0.0.0.0:* LISTEN 1831/master
    tcp 0 0 0.0.0.0:submission 0.0.0.0:* LISTEN 1831/master
    tcp 0 0 localhost:11211 0.0.0.0:* LISTEN 1156/memcached
    tcp 0 0 0.0.0.0:pop3 0.0.0.0:* LISTEN 932/dovecot
    tcp 0 0 0.0.0.0:imap2 0.0.0.0:* LISTEN 932/dovecot
    tcp 0 0 0.0.0.0:urd 0.0.0.0:* LISTEN 1831/master
    tcp 0 0 localhost:imap2 localhost:59326 TIME_WAIT -
    tcp 0 0 rrcs-97-76-140-17:imaps 172.16.0.10:62796 ESTABLISHED 3251/dovecot/imap-l
    tcp 0 0 rrcs-97-76-140-17:imap2 172.16.0.10:62801 ESTABLISHED 3257/dovecot/imap-l
    tcp 0 0 rrcs-97-76-140-174.:ssh 112.85.42.185:52384 ESTABLISHED 4225/sshd: [accepte
    tcp 0 0 localhost:59326 localhost:imap2 TIME_WAIT -
    tcp 0 0 rrcs-97-76-140-17:imaps 172.16.0.10:62802 ESTABLISHED 3258/dovecot/imap-l
    tcp 0 208 rrcs-97-76-140-174.:ssh 172.16.0.10:63190 ESTABLISHED 4256/sshd: jimmie [
    tcp 0 0 rrcs-97-76-140-17:imaps 172.16.0.10:62803 ESTABLISHED 3259/dovecot/imap-l
    tcp 0 0 rrcs-97-76-140-17:imap2 172.16.0.10:62800 ESTABLISHED 3256/dovecot/imap-l
    tcp 0 0 rrcs-97-76-140-17:imaps 172.16.0.10:62804 ESTABLISHED 3260/dovecot/imap-l
    tcp 0 80 rrcs-97-76-140-174.:ssh 222.186.42.155:27280 ESTABLISHED 4226/sshd: root [pr
    tcp6 0 0 [::]:ftp [::]:* LISTEN 2027/pure-ftpd (SER
    tcp6 0 0 [::]:domain [::]:* LISTEN 964/named
    tcp6 0 0 [::]:ssh [::]:* LISTEN 1285/sshd
    tcp6 0 0 ip6-localhost:953 [::]:* LISTEN 964/named
    tcp6 0 0 [::]:https [::]:* LISTEN 1785/apache2
    tcp6 0 0 [::]:imaps [::]:* LISTEN 932/dovecot
    tcp6 0 0 [::]:pop3s [::]:* LISTEN 932/dovecot
    tcp6 0 0 ip6-localhost:10024 [::]:* LISTEN 2039/amavisd-new (m
    tcp6 0 0 ip6-localhost:10026 [::]:* LISTEN 2039/amavisd-new (m
    tcp6 0 0 [::]:mysql [::]:* LISTEN 1552/mysqld
    tcp6 0 0 [::]:pop3 [::]:* LISTEN 932/dovecot
    tcp6 0 0 [::]:imap2 [::]:* LISTEN 932/dovecot
    tcp6 0 0 [::]:http-alt [::]:* LISTEN 1785/apache2
    tcp6 0 0 [::]:http [::]:* LISTEN 1785/apache2
    tcp6 0 0 [::]:tproxy [::]:* LISTEN 1785/apache2
    tcp6 0 0 rrcs-97-76-140:http-alt 172.16.0.10:63178 TIME_WAIT -
    tcp6 0 32120 rrcs-97-76-140-17:https baiduspider-220-1:46007 ESTABLISHED 3107/apache2
    tcp6 0 0 rrcs-97-76-140-174:http qwantbot-91-242-1:56045 TIME_WAIT -
    tcp6 0 0 rrcs-97-76-140:http-alt 172.16.0.10:63196 TIME_WAIT -
    tcp6 0 0 rrcs-97-76-140-174:http qwantbot-91-242-1:55977 TIME_WAIT -
    tcp6 0 0 rrcs-97-76-140-17:https 114-119-166-255.a:43272 SYN_RECV -
    tcp6 0 0 rrcs-97-76-140-17:https ip-72-167-226-188:56662 ESTABLISHED -
    tcp6 0 0 rrcs-97-76-140:http-alt 172.16.0.10:63180 TIME_WAIT -
    tcp6 0 0 rrcs-97-76-140-174:http ip-72-167-226-188:56570 TIME_WAIT -
    tcp6 0 0 rrcs-97-76-140:http-alt 172.16.0.10:63192 TIME_WAIT -
    tcp6 0 0 rrcs-97-76-140:http-alt 172.16.0.10:63184 TIME_WAIT -
    tcp6 0 0 rrcs-97-76-140:http-alt 172.16.0.10:63197 ESTABLISHED 2190/apache2
    tcp6 0 0 rrcs-97-76-140:http-alt 172.16.0.10:63174 TIME_WAIT -
    tcp6 0 0 rrcs-97-76-140:http-alt 47.205.186.47:49189 TIME_WAIT -
    tcp6 0 0 rrcs-97-76-140-17:https 114-119-160-206.a:29358 TIME_WAIT -
    tcp6 0 0 rrcs-97-76-140:http-alt 172.16.0.10:63173 TIME_WAIT -
    tcp6 0 0 rrcs-97-76-140-17:https 114-119-160-206.a:29244 TIME_WAIT -
    tcp6 0 0 rrcs-97-76-140:http-alt 172.16.0.10:63169 TIME_WAIT -
    tcp6 0 0 rrcs-97-76-140-174:http qwantbot-91-242-1:55999 TIME_WAIT -
    tcp6 0 0 rrcs-97-76-140:http-alt 172.16.0.10:63172 TIME_WAIT -
    tcp6 0 44516 rrcs-97-76-140-17:https baiduspider-116-1:38592 ESTABLISHED 4125/apache2
    tcp6 0 0 rrcs-97-76-140-174:http ip-72-167-226-188:56616 TIME_WAIT -
    tcp6 0 0 rrcs-97-76-140-174:http ip-72-167-226-188:56616 TIME_WAIT -
     
  10. nhybgtvfr

    nhybgtvfr Active Member

    check your dns servers / dns zone for computer-hosting.com

    nslookup against google dns servers:
    nslookup computer-hosting.com 8.8.8.8
    Server: 8.8.8.8
    Address: 8.8.8.8#53
    ** server can't find computer-hosting.com: SERVFAIL

    nslookup against registered SOA servers for that domain:

    nslookup computer-hosting.com ns1.computer-hosting.com
    nslookup: couldn't get address for 'ns1.computer-hosting.com': failure
     
  11. nhybgtvfr

    nhybgtvfr Active Member

    further to that, check in /etc/bind/ make sure there isn't a recent pri.computer-hosting.com.err file. if there is you've got a problem in that file you need to find.

    otherwise the dns zone in ispconfig needs an A record for computer-hosting.com. and for ns and ns2 (or ns1.computer-hosting.com. and ns2.computer-hosting.com. * note if using the full domain, always include the trailing . )
    and two ns records for computer-hosting.com. with targets ns1.computer-hosting.com. and ns2.computer-hosting.com. respectively.
    also since you're using the domain to specify the name servers for the same domain, you need to make sure that glue records exist for the domain in your godaddy control panel. (basically they need to know the IP's of your dns servers)
     
  12. jimmie

    jimmie Member

    Dns on ispconfig is same as all other sites, except n1.eachsites name
     
  13. nhybgtvfr

    nhybgtvfr Active Member

    ok, but when you set the nameservers for the domain in the godaddy control panel, did you also set the ip for those nameservers?

    if seems like you've told godaddy to use ns1.computer-hosting.com and ns2.computer-hosting.com as the nameservers for the computer-hosting.com domain. but to find the nameservers, it has to look up the nameservers ip's in the computer-hosting.com zone file, but it can only find the computer-hosting.com zone file by looking up the nameserver ip's for computer-hosting.com in the zone file. bit of a vicious circle there.

    that's why godaddy needs the ip's for those two nameservers as well.
     
  14. jimmie

    jimmie Member

    Yes this was all working, now i did something and it aint
     
  15. nhybgtvfr

    nhybgtvfr Active Member

    right, well, forget what you did in ispconfig re websites. the website/apache stuff is irrelevant right now. the problem is with the dns somewhere.
    so what did you change regarding dns settings? did you check for a .err file in /etc/bind/?
    is the bind service still running?
    can you post a screenshot of the dns records in ispconfig.
     
  16. jimmie

    jimmie Member

    Working will post bac later
     
  17. jimmie

    jimmie Member

    ispconfig records file
    upload_2020-4-27_17-8-11.png
     
  18. jimmie

    jimmie Member

    from godaddy DNS page
    upload_2020-4-27_17-9-26.png
     
  19. jimmie

    jimmie Member

    from godaddy nameserver ip page
    upload_2020-4-27_17-10-41.png
     
  20. jimmie

    jimmie Member

    im not sure godaddy settings matter, nor ispconfig dns on computer-hosting.com. when first installed server i could connect to localhost(computer-hosting.com)
     

Share This Page