can't connect to ftp "cannot display the directory content"

Discussion in 'General' started by martodox, Jul 27, 2013.

  1. martodox

    martodox New Member

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Any errors in the syslog file?
  3. martodox

    martodox New Member

    Where do I find pure-ftp error log?

    /var/log/pure-ftp has only transfer logs.
  4. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    pure-ftpd should put errors into /var/log/syslog
  5. martodox

    martodox New Member

    and log from filezilla

  6. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Have you tried using a different ftp client?
  7. martodox

    martodox New Member

    OK. I got it working (almost).
    As you suggested I had tried a different ftp client (total cmd) and it connecter right away.
    hmmm... why can't filezilla do that anymore. So I tracked down the cause - passive and active mode. My whole life always connected using passive mode.
    So how do I enable back the passive mode in pure-ftpd?
  8. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

  9. mikervrm

    mikervrm New Member

    you must to try to activate passive mode un ftp client
  10. VegasTech

    VegasTech New Member

    If you have installed a firewall that restricts FTP to only port 21 then you may observe this problem. To fix that, open /etc/pure-ftpd/pure-ftpd.conf for editing and remove the hash to uncomment the following line (about 1/3rd of the way down the file).

    # PassivePortRange 30000 50000

    Restart pure-ftpd by issuing this command.

    service pure-ftpd restart

    Finally, you'll need to open that TCP port range in your firewall. Normally that's done by adding "30000_50000" (less quotes) to the ingress & egress TCP open port lists.

    You should now be able to list content with an FTP client.
    Last edited: Nov 24, 2015

Share This Page