Can't connect to Courier-IMAP

Discussion in 'Server Operation' started by dekat, Apr 25, 2007.

  1. dekat

    dekat New Member

    Hi there,

    I just completed a re-installation of courier-imap and related packages on Ubuntu 6.10 that has ISPConfig installed, and I can't access my mail from Evolution. I've set up the accounts on Evolution, and entered details of the IMAP and SMTP servers I am using, but nothing works. Whenever I attempt to connect, I get the following message "Error while Scanning folders in "IMAP server". However, I telnet to the server both on my laptop, and using an ssh connection.

    Where should I start from in trying to figure out what's the matter? Thanks in advance for your help. And please pardon me for the cross posting; I put this on Ubuntu forums (http://ubuntuforums.org/showthread.php?t=421688), but no one has replied.

    Katim
     
    Last edited: Apr 25, 2007
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Did you enable maildir support in ISPConfig under management > server > settings on the mail tab? Have you sent a email to the account? The Maildirs where created when the first email arrives.

    Please check your /var/log/mail.log for error messages and post them here.

    If you have problems with either ISPConfig or one of the howtoforge setups, It is always better to post the questions here as most of the howto authors and ISPConfig developers are not in the ubuntu forums :)
     
  3. dekat

    dekat New Member

    Hi Till,

    Thanks for your reply to my posting about my problems connecting to my IMAP server. I used to be able to download my e-mail using a client, but I'm no longer able to.

    As per your suggestions, I have checked my ISPConfig maildir setting, and it's on. Secondly, I re-sent e-mails to the addresses concerned, and they all got delivered. But I still can't get them from my Evolution client.

    And here's the output of my /var/log/mail.log file:

    Apr 25 23:59:02 localhost postfix/pickup[2818]: 34E0537D3F: uid=0 from=<root>

    Apr 25 23:59:02 localhost postfix/cleanup[3428]: 34E0537D3F: message-id=<20070425235902.34E0537D3F@dego.gm>

    Apr 25 23:59:02 localhost postfix/local[3431]: 34E0537D3F: to=<katim@dego.gm>, orig_to=<root>, relay=local, delay=0.42, delays=0.39/0.01/0/0.01, dsn=2.0.0, status=sent (delivered to maildir)

    Apr 25 23:59:02 localhost postfix/master[16429]: terminating on signal 15

    Apr 25 23:59:03 localhost postfix/master[3509]: daemon started -- version 2.3.3, configuration /etc/postfix

    Apr 25 23:59:03 localhost postfix/pickup[3510]: 351E737D3F: uid=0 from=<root>

    Apr 25 23:59:03 localhost postfix/cleanup[3549]: 351E737D3F: message-id=<20070425235903.351E737D3F@dego.gm>

    Apr 25 23:59:03 localhost postfix/qmgr[3511]: 351E737D3F: from=<root@dego.gm>, size=599, nrcpt=1 (queue active)

    Apr 25 23:59:03 localhost postfix/local[3551]: 351E737D3F: to=<katim@dego.gm>, o

    rig_to=<root>, relay=local, delay=0.21, delays=0.18/0.02/0/0.02, dsn=2.0.0, status=sent (delivered to maildir)

    Apr 25 23:59:03 localhost postfix/qmgr[3511]: 351E737D3F: removed

    Apr 25 23:59:08 localhost postfix/pickup[3510]: 07BB837D3F: uid=0 from=<root>

    Apr 25 23:59:08 localhost postfix/cleanup[3549]: 07BB837D3F: message-id=<20070425235908.07BB837D3F@dego.gm>

    Apr 25 23:59:08 localhost postfix/qmgr[3511]: 07BB837D3F: from=<root@dego.gm>, size=557, nrcpt=1 (queue active)

    Apr 25 23:59:08 localhost postfix/local[3551]: 07BB837D3F: to=<katim@dego.gm>, orig_to=<root>, relay=local, delay=0.17, delays=0.16/0/0/0.01, dsn=2.0.0, status=sent (delivered to maildir)

    Apr 25 23:59:08 localhost postfix/qmgr[3511]: 07BB837D3F: removed

    Apr 26 01:04:36 localhost postfix/smtpd[4517]: connect from 59-117-78-40.dynamic.hinet.net[59.117.78.40]

    Apr 26 01:04:38 localhost postfix/smtpd[4517]: NOQUEUE: reject: RCPT from 59-117-78-40.dynamic.hinet.net[59.117.78.40]: 554 5.7.1 <candy59839@yahoo.com.tw>: Relay access denied; from=<michael78694@MyMainServer.com> to=<candy59839@yahoo.com.tw> proto=SMTP helo=<www.MyMainServer.com>

    Apr 26 01:04:38 localhost postfix/smtpd[4517]: lost connection after RCPT from 59-117-78-40.dynamic.hinet.net[59.117.78.40]

    Apr 26 01:04:38 localhost postfix/smtpd[4517]: disconnect from 59-117-78-40.dynamic.hinet.net[59.117.78.40]

    Apr 26 01:07:58 localhost postfix/anvil[4522]: statistics: max connection rate 1/60s for (smtp:59.117.78.40) at Apr 26 01:04:36

    Apr 26 01:07:58 localhost postfix/anvil[4522]: statistics: max connection count 1 for (smtp:59.117.78.40) at Apr 26 01:04:36

    Apr 26 01:07:58 localhost postfix/anvil[4522]: statistics: max cache size 1 at Apr 26 01:04:36

    Apr 26 04:00:18 localhost postfix/pickup[6222]: EDBC637D3F: uid=0 from=<root>

    Apr 26 04:00:18 localhost postfix/cleanup[6851]: EDBC637D3F: message-id=<20070426040018.EDBC637D3F@dego.gm>

    Apr 26 04:00:19 localhost postfix/qmgr[3511]: EDBC637D3F: from=<root@dego.gm>, size=572, nrcpt=1 (queue active)

    Apr 26 04:00:19 localhost postfix/local[6853]: EDBC637D3F: to=<katim@dego.gm>, orig_to=<root>, relay=local, delay=0.09, delays=0.06/0.01/0/0.02, dsn=2.0.0, status=sent (delivered to maildir)

    Apr 26 04:00:19 localhost postfix/qmgr[3511]: EDBC637D3F: removed

    Apr 26 09:54:22 localhost postfix/smtpd[11573]: connect from web60620.mail.yahoo.com[209.73.178.188]

    Apr 26 09:54:22 localhost postfix/smtpd[11575]: connect from web60620.mail.yahoo.com[209.73.178.188]

    Apr 26 09:54:23 localhost postfix/smtpd[11573]: 42E6437CA5: client=web60620.mail.yahoo.com[209.73.178.188]

    Apr 26 09:54:23 localhost postfix/smtpd[11575]: 8254937D03: client=web60620.mail.yahoo.com[209.73.178.188]

    Apr 26 09:54:24 localhost postfix/cleanup[11581]: 8254937D03: message-id=<766674.79293.qm@web60620.mail.yahoo.com>

    Apr 26 09:54:24 localhost postfix/pickup[10234]: A11D537D25: uid=10010 from=<web5_kstouray>

    Apr 26 09:54:24 localhost postfix/cleanup[11581]: A11D537D25: message-id=<20070426095424.A11D537D25@dego.gm>

    Apr 26 09:54:24 localhost postfix/local[11582]: 8254937D03: to=<web5_kstouray@dego.gm>, orig_to=<kstouray@dego.gm>, relay=local, delay=1.4, delays=1.3/0.02/0/0.05, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)

    Apr 26 09:54:24 localhost postfix/local[11582]: A11D537D25: to=<admispconfig@localhost.localdomain>, relay=local, delay=0.04, delays=0.02/0/0/0.02, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)

    Apr 26 09:54:24 localhost postfix/smtpd[11575]: disconnect from web60620.mail.yahoo.com[209.73.178.188]

    Apr 26 09:54:25 localhost postfix/cleanup[11578]: 42E6437CA5: message-id=<766674.79293.qm@web60620.mail.yahoo.com>

    Apr 26 09:54:25 localhost postfix/local[11582]: 42E6437CA5: to=<katim@dego.gm>, relay=local, delay=2.4, delays=2.4/0/0/0.01, dsn=2.0.0, status=sent (delivered to maildir)

    Apr 26 09:54:25 localhost postfix/smtpd[11573]: disconnect from web60620.mail.yahoo.com[209.73.178.188]

    Apr 26 09:57:45 localhost postfix/anvil[11576]: statistics: max connection rate 2/60s for (smtp:209.73.178.188) at Apr 26 09:54:22

    Apr 26 09:57:45 localhost postfix/anvil[11576]: statistics: max connection count 2 for (smtp:209.73.178.188) at Apr 26 09:54:22

    Apr 26 09:57:45 localhost postfix/anvil[11576]: statistics: max cache size 1 at Apr 26 09:54:22

    Apr 26 10:01:50 localhost postfix/smtpd[11775]: connect from web60618.mail.yahoo.com[209.73.178.186]

    Apr 26 10:01:51 localhost postfix/smtpd[11775]: 9D7A037CA5: client=web60618.mail.yahoo.com[209.73.178.186]

    Apr 26 10:01:52 localhost postfix/cleanup[11779]: 9D7A037CA5: message-id=<334727.12244.qm@web60618.mail.yahoo.com>

    Apr 26 10:01:52 localhost postfix/pickup[11605]: 7E04337D0A: uid=10011 from=<web4_info>

    Apr 26 10:01:52 localhost postfix/cleanup[11779]: 7E04337D0A: message-id=<20070426100152.7E04337D0A@dego.gm>

    Apr 26 10:01:52 localhost postfix/local[11780]: 9D7A037CA5: to=<web4_info@dego.gm>, orig_to=<info@fossic.org>, relay=local, delay=1.1, delays=1/0.02/0/0.04, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)

    Apr 26 10:01:52 localhost postfix/local[11780]: 7E04337D0A: to=<admispconfig@localhost.localdomain>, relay=local, delay=0.04, delays=0.02/0/0/0.02, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)

    Apr 26 10:01:52 localhost postfix/smtpd[11775]: disconnect from web60618.mail.yahoo.com[209.73.178.186]

    Apr 26 10:04:41 localhost postfix/pickup[11605]: 8832F37D03: uid=0 from=<web4_info@localhost.localdomain>

    Apr 26 10:04:41 localhost postfix/cleanup[11884]: 8832F37D03: message-id=<1177581881.11870@localhost.localdomain>

    Apr 26 10:05:03 localhost postfix/smtp[11886]: 8832F37D03: to=<kaamt@yahoo.com>, relay=a.mx.mail.yahoo.com[209.191.118.103]:25, delay=22, delays=0.06/0.02/21/0.71, dsn=2.0.0, status=sent (250 ok dirdel)

    Apr 26 10:05:12 localhost postfix/anvil[11777]: statistics: max connection rate 1/60s for (smtp:209.73.178.186) at Apr 26 10:01:50

    Apr 26 10:05:12 localhost postfix/anvil[11777]: statistics: max connection count 1 for (smtp:209.73.178.186) at Apr 26 10:01:50

    Apr 26 10:05:12 localhost postfix/anvil[11777]: statistics: max cache size 1 at Apr 26 10:01:50


    So what's the problem? Again, thanks in advance for your help.

    Katim
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ?
     
  5. dekat

    dekat New Member

    Hi Falko,

    Here's the output of my netstat -tap command:

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdom:2208 *:* LISTEN 1596/hpiod
    tcp 0 0 *:8000 *:* LISTEN 4276/icecast2
    tcp 0 0 *:mysql *:* LISTEN 16703/mysqld
    tcp 0 0 *:10000 *:* LISTEN 13724/perl
    tcp 0 0 dego.gm:10000 212.60.65.174:52444 SYN_RECV -
    tcp 0 0 *:81 *:* LISTEN 23378/ispconfig_htt
    tcp 0 0 dego.gm:domain *:* LISTEN 23671/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 23671/named
    tcp 0 0 localhost.localdoma:ipp *:* LISTEN 25739/cupsd
    tcp 0 0 *:smtp *:* LISTEN 22660/master
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 23671/named
    tcp 0 0 localhost.localdo:56637 *:* LISTEN 1601/python
    tcp 0 0 dego.gm:10000 212.60.65.173:22098 ESTABLISHED14827/perl
    tcp 0 8956 dego.gm:10000 212.60.65.174:52437 ESTABLISHED6243/index.cgi
    tcp6 0 0 *:imaps *:* LISTEN 14883/couriertcpd
    tcp6 0 0 *:pop3s *:* LISTEN 14961/couriertcpd
    tcp6 0 0 *:pop3 *:* LISTEN 14922/couriertcpd
    tcp6 0 0 *:imap2 *:* LISTEN 21874/couriertcpd
    tcp6 0 0 *:www *:* LISTEN 23498/apache2
    tcp6 0 0 *:ftp *:* LISTEN 22707/proftpd: (acc
    tcp6 0 0 *:ssh *:* LISTEN 7615/sshd
    tcp6 0 0 ip6-localhost:953 *:* LISTEN 23671/named
    tcp6 0 0 *:https *:* LISTEN 23498/apache2


    I hope you find something in the output above. Again, thanks for your help.

    Katim
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Courier-IMAP is running. Does your firewall allow connections to port 143?
     
  7. dekat

    dekat New Member

    Hi Falko,

    The output from my portscanner is as follows:

    Port 143 (tcp) is open (imap2)!

    I suppose that means its open, and allows all connections.

    Again, thanks for your help.

    Katim
     
  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    From where did you run the portscanner? On the server itself, or from a different system? In the first case this doesn't mean that the firewall allows connections to port 143. The firewall can block outbound connections on port 143, while your local portscanner can connect.
     
  9. dekat

    dekat New Member

    You're right, Falko. I found that port 143 is not open to the outside world. I want to use SSL connections, but the question now is "how do I turn on the appropriate ports?"

    Katim
     
  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    To use IMAPS, port 993 must be open in your firewall.
     
  11. dekat

    dekat New Member

    I know, but how do I turn on ports 143 and 993? TIA.

    Katim
     
  12. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    From your netstat output I see that you're already using these ports.
     

Share This Page