Can't add new sites and/or subdomains as vhost

Discussion in 'Installation/Configuration' started by alecvannoten, Apr 19, 2013.

  1. alecvannoten

    alecvannoten New Member

    Hi guys,

    I recently had to edit some apache conf files for some subdomains to work...
    e.g. cp.domain.com instead of domain.com:ispport, webmail.domain.com for Roundcube, phpmyadmin.domain.com instead of domain.com/phpmyadmin etc

    I have a multi server setup with 2 web, 1 db, 1 mail, 2 dns servers
    all on debian 6, ispc v3.0.5.2

    one of the web (web1) servers runs the ispconfig cp over ssl.

    i can login, I can see the whole configuration, I can add domains on web1 but they don't appear as folder in var/www nor as apache conf file in etc/apache2

    when i add sites/vhosts on web2 all functions correctly...

    when I look into ispc cron log of web1 (via ssh directly instead of the cp monitor tab) I see following errors
    Code:
    PHP Warning:  mysqli::mysqli(): (28000/1045): Access denied for user 'ispcsrv1'@'web1.srv.alecvannoten.net' (using password: YES) in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 72
    DB::__construct Access denied for user 'ispcsrv1'@'web1.srv.alecvannoten.net' (using password: YES)
    can you guys help me?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems a sif the second node is not able to connect to mysql on the master anymore. ensure that there is no firewall blocking the connection and that mysql on the master listens on the external ip as well.
     
  3. alecvannoten

    alecvannoten New Member

    Thanks for reply Till

    excuse me but it can't be a firewall issue:

    ispconfig cp is running on web1, not on web2.

    web2 listen to the cp on web1, but web1 does not listen to ispconfig while it's on the same machine...

    firewall is ok end mysql listen remote
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The sql error you posted is from a remote ispconfig connection to mysql, it is not froma localhost connection as localhost connection in ispconfig use the user "ispconfig" and not "ispcsrv*".
     
  5. alecvannoten

    alecvannoten New Member

    FIXED,

    thanks
     
  6. morktadela

    morktadela New Member

    How do you fix this??
    I have same problem.

    Thanks
     

Share This Page