Can't add new mailboxes

Discussion in 'Installation/Configuration' started by hfr, Dec 10, 2012.

  1. hfr

    hfr New Member

    Hello,

    ISPConfig-Version 3.0.4.6
    Linux: CentOS release 5.8 (Final) 32-Bit (setup According to "perfect server guide centos 5")

    It is not possible to add new mailboxes anymore via ispconfig. Since I don't add mailboxes very often I am not sure when it stopped working, but 1-2 month ago it still worked.

    In ispconfig gui everything seems ok (mailbox is added successfully), but when trying to login to roundcube or catching mails via imap the following error msgs are written to /var/log/maillog:

    Code:
    Dec 10 10:39:32 server imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 10 10:39:32 server imapd: LOGIN, user=bb@domain.de, ip=[::ffff:127.0.0.1], port=[59956], protocol=IMAP
    Dec 10 10:39:32 server imapd: Error reading ACLs for INBOX.sieve: No such file or directory
    
    This only happens with new mailboxes, all existing mailboxes work.

    Any ideas what can cause this?

    Regards
    Hans
     
  2. hfr

    hfr New Member

    Tried with pop3, also does not work with another error message in maillog:

    Sending mail via smtp works.

    Any Ideas?!
     
  3. hfr

    hfr New Member

    OK, it seems ispconfig does not generate valid mailboxes in filesystem anymore. After adding a mailbox in ispconfig, /var/vmail/domain.de/bb looks like:

    One of the old mailboxes (which still work) looks like:

    So the second error message (opendir cur) makes sense.

    I then tried to create the mailboxes with maildirmake and it worked. The mailbox created with maildirmake looks like:

    The mailbox seems to work fine (imap + pop3, smtp worked before).

    How can I find out what goes wrong when ispconfig tries to create the mailbox?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. hfr

    hfr New Member

    Thanks. Output:

    sh: dovecot: command not found

    I use courierd not dovecot. In ispconfig -> System -> Serverconfig -> Server -> Mail the attribute POP3/IMAP Daemon was set to dovecot (don't know why but i am sure i did not change this). I set it to courier now but error stays the same.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to delete the mailbox and then create it again after you changed the settings as the maildir layout from dovecot and courier is different.
     
  7. hfr

    hfr New Member

    That is exactly what I tried (create completely new mailbox). But it still says sh: dovecot: command not found in ispconfig log.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Dovecot must have been installed on your server at the time when the last ispconfg update was installed as your server is configured for dovecot at the moment.

    Check with:

    which dovecot

    that really no dovecot binary is installed anymore now, then download ispconfig tar.gz agaian, run the update.php script and choose to reconfigure services so that your server gets configured for courier again. You should see in the installer output that it configures courier then and not dovecot.
     
  9. hfr

    hfr New Member

    I found some evidence of a previous/old dovecot installation.

    How does ispconfig determines, which mta is actually used?
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    With the command:

    which dovecot

    So the dovecot package must have been installed at the time you installed ispconfig or updated it the last time as this configuration can only be changed by the installer 7 updater. To fix it, follow the steps I explained above.
     
  11. hfr

    hfr New Member

    I will try that but I can definitely say dovecot wasn't installed when I updated to 3.0.4.6.
     

Share This Page