Cant Acsess Internet On Kali Linux

Discussion in 'Installation/Configuration' started by GalZNagar, Mar 11, 2016.

  1. GalZNagar

    GalZNagar New Member

    Hello Yesterday I installed kali linux on my computer and i cant acsess the internet
    I checked my connection to the wifi and it looked fine.
    If anybody can help me it will be nice.
    Thanks for all.
     
  2. ztk.me

    ztk.me Active Member

    Check your network
    Code:
    ifconfig
    
    Any links up? wlan0 showing?
    If not, try
    Code:
    ifconfig wlan0 up
    
    any issue with the following command?
    Code:
    ping 8.8.8.8
    ping google.com
    
    btw. Why on ISPConfig2 sub board?
    Are you running kali in a virtual environment?
     
  3. GalZNagar

    GalZNagar New Member

    wlan0 is showing
    and im running kali linux and windows on the same pc not on vm
    ping 8.8.8.8 says "connect:Network is unreachable"
    ping google.com says : "ping: unknown host google.com"
     
  4. ztk.me

    ztk.me Active Member

    I think I found something interesting to configure your wifi from command line.
    However, using your network manager should also work. What's ifconfig showing exactly?
    It should show something like
    inet addr:192.168.0.5
     
  5. GalZNagar

    GalZNagar New Member

    i cant copy what ifconfig showing exactly because its from another computer but its not showing something like inet addr: 192.168.0.5
     
  6. ztk.me

    ztk.me Active Member

    then kali is either not requesting or receiving automated network configuration via DHCP.
    I assume you have DHCP server in your network.
    On the other hand, you're giving not much feedback on this.

    Have you set up your wifi according to your network settings? WPA2 setup correctly?
    No Networkmanager? Did you enable DHCP discovery? Did you try static IP setup?
    Does it work if you connect via LAN?

    Figure what network setup you have.
    For example you have a Router connecting you to your internet which has IP: 192.168.178.1
    If you can connect to your wifi but don't get an IP you could try:
    Code:
    ifup wlan0
    ifconfig wlan0 192.168.178.200
    ifconfig wlan0 netmask 255.255.255.0
    ifconfig wlan0 broadcast 192.168.178.255
    route add default gw 192.168.178.1 wlan0
    echo "nameserver 192.168.178.1\n nameserver 8.8.8.8" >> /etc/resolv.conf
    
    as root user from your command line if you don't have any network manager available.

    However, if this doesn't work either, your wifi seems not beeing connected to your network using WPA correctly,

    Put your SSID and password into /etc/wpa_supplicant.conf
    Code:
    network={
        ssid="ssid_name"
        psk="password"
    }
    
    As root do:

    Code:
    wpa_supplicant -B -iwlan0 -c/etc/wpa_supplicant.conf -Dwext
    dhclient wlan0
    
    "wext" is a driver and that will be specific for each card; refer to wpa_supplicant -h. Examples:
    Code:
    hostap (default) Host AP driver (Intersil Prism2/2.5/3). (this can also be used with Linuxant DriverLoader).
    hermes Agere Systems Inc. driver (Hermes-I/Hermes-II).
    madwifi MADWIFI 802.11 support (Atheros, etc.).
    atmel ATMEL AT76C5XXx (USB, PCMCIA).
    wext Linux wireless extensions (generic).
    ndiswrapper Linux ndiswrapper.
    broadcom Broadcom wl.o driver.
    ipw Intel ipw2100/2200 driver.
    wired wpa_supplicant wired Ethernet driver
    roboswitch wpa_supplicant Broadcom switch driver
    bsd BSD 802.11 support (Atheros, etc.).
    ndis Windows NDIS driver.
    
     
  7. GalZNagar

    GalZNagar New Member

    I do have dhcp server on my network
    and im connected correctly to my internet but it still doesnt work :\
     
  8. ztk.me

    ztk.me Active Member

    Did you try reaching your local Router using its internal IP?
    Either way if this does work or not, I'm not quite sure what you're doing. Maybe ask on Kali Linux forums.
    You could also try another Linux distribution, Kali is just a flavour with certain preinstalled packages / themes of Debian.
     

Share This Page