can't access webmail after moving /var/www to /home/www

Discussion in 'General' started by JESUSSAVES, Oct 8, 2014.


    JESUSSAVES New Member

    I'm not sure what the cause is but I just moved /var/www to /home HOWTO and now i notice i can't access webmail with 500 server error, error.log says
    [Wed Oct 08 14:30:24 2014] [error] [client] SoftException in Application.cpp:221: File "/usr/share/roundcube/index.php" is not in document root of Vhost "/var/www"
    [Wed Oct 08 14:30:24 2014] [error] [client] Premature end of script headers: index.php
    I had some time ago set up Roundcube with this tutorial: roundcube debian wheezy and it's been working fine until now.

    Could someone please tell me what the problem might be?

    Debian 7.6, Apache2, ISPConfig

    Thank you for the help.
  2. srijan

    srijan New Member HowtoForge Supporter

    Please paste and check your /etc/fstab file.
  3. till

    till Super Moderator Staff Member ISPConfig Developer


    JESUSSAVES New Member

    /etc/fstab is here:
    [email protected]:~# cat /etc/fstab
    # /etc/fstab: static file system information.
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/mapper/vg_ns01-lv_root /               ext4    errors=remount-ro,usrjquota=aquota.user,,jqfmt=vfsv0 0       1
    # /boot was on /dev/sda1 during installation
    UUID=4668637a-b79b-4baa-8a51-e61fad218deb /boot           ext3    defaults        0       2
    /dev/mapper/vg_ns01-lv_tmp /tmp            ext4    defaults        0       2
    /dev/mapper/vg_ns01-lv_usr /usr            ext4    defaults        0       2
    /dev/mapper/vg_ns01-lv_var /var            ext4    defaults        0       2
    /dev/mapper/vg_www1-lv_home /home       ext4    defaults        0       2
    /home/www /var/www none bind,nobootwait,_netdev 0 0
    # swap was on /dev/sda2 during installation
    UUID=689b162d-36e7-43b9-ab3a-a22c18b74379 none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,nosuid     0       0
    /dev/sdd1       /mnt/flashDrive         auto    noauto,nosuid   0 0
    /dev/vg_delcohost1b/lv_opersystem_backup        /mnt/systembackup ext4 nosuid   0 3
    /dev/vg_delcohost1b/lv_tar_work                 /mnt/tarwork ext4 noauto,nosuid   0 3
    /dev/vg_delcohost1b/lv_home_backup              /mnt/homebackup ext4 nosuid   0 3
    /dev/vg_delcohost1b/lv_www_backup               /mnt/wwwbackup ext4 nosuid   0 3
    /dev/vg_delcohost1b/lv_ispconfig_backup         /mnt/ispcbackup ext4 nosuid   0 3
    /var/log/ispconfig/httpd/ /var/www/clients/client7/web25/log    none    bind,nobootwait    0 0
    Yes, Till that is the guide I followed. Here is /etc/apache2/conf.d/roundcube
    [email protected]:~# cat /etc/apache2/conf.d/roundcube
    # Those aliases do not work properly with several hosts on your apache server
    # Uncomment them to use it or adapt them to your configuration
    #    Alias /roundcube/program/js/tiny_mce/ /usr/share/tinymce/www/
    #    Alias /roundcube /var/lib/roundcube
    Alias /webmail /var/lib/roundcube
    # Access to tinymce files
    <Directory "/usr/share/tinymce/www/">
          Options Indexes MultiViews FollowSymLinks
          AllowOverride None
          Order allow,deny
          allow from all
    <Directory /var/lib/roundcube/>
      Options +FollowSymLinks
      DirectoryIndex index.php
      # This is needed to parse /var/lib/roundcube/.htaccess. See its
      # content before setting AllowOverride to None.
      <IfModule mod_php5.c>
        AddType application/x-httpd-php .php
        php_flag magic_quotes_gpc Off
        php_flag track_vars On
        php_flag register_globals Off
        php_value include_path .:/usr/share/php
      AllowOverride All
      order allow,deny
      allow from all
    # Protecting basic directories:
    <Directory /var/lib/roundcube/config>
            Options -FollowSymLinks
            AllowOverride None
    <Directory /var/lib/roundcube/temp>
            Options -FollowSymLinks
            AllowOverride None
            Order allow,deny
            Deny from all
    <Directory /var/lib/roundcube/logs>
            Options -FollowSymLinks
            AllowOverride None
            Order allow,deny
            Deny from all
    Everything else with Apache2 is working properly.

    JESUSSAVES New Member

    My mistake /webmail is working as . But I'm having a DNS problem with one domain. Thanks for your help!

Share This Page