can't access the admin interface, apache lost the conf?

Discussion in 'Installation/Configuration' started by Esuk, Jul 24, 2006.

  1. Esuk

    Esuk New Member

    A couple of days ago the hosting company where my server is standing had some netissues and my server was offline for a couple of hours. When the server came back again I couldn't access the ISPConfig Admin page anymore.
    (located at https://87.237.208.94:81)

    I have browsed these forums for a while to see if I can find a solution to my problem but nothing seems to do the trick for me.

    - I checked wheter or not ISPconfig was running but it wasn't so I started it but still no luck in accessing the admin page.

    - I checked my "netstat -tap" but can't find any problems there

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:imaps *:* LISTEN 13655/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 13655/dovecot
    tcp 0 0 *:mysql *:* LISTEN 13844/mysqld
    tcp 0 0 *:pop3 *:* LISTEN 13655/dovecot
    tcp 0 0 *:imap *:* LISTEN 13655/dovecot
    tcp 0 0 *:http *:* LISTEN 21712/httpd
    tcp 0 0 *:ftp *:* LISTEN 21852/proftpd: (acc
    tcp 0 0 87.237.208.95:domain *:* LISTEN 21829/named
    tcp 0 0 87.237.208.94:domain *:* LISTEN 21829/named
    tcp 0 0 217042:domain *:* LISTEN 21829/named
    tcp 0 0 *:ssh *:* LISTEN 13692/sshd
    tcp 0 0 217042:rndc *:* LISTEN 21829/named
    tcp 0 0 *:smtp *:* LISTEN 21802/master
    tcp 0 0 *:https *:* LISTEN 21712/httpd
    tcp 0 0 87.237.208.94:ssh 1-1-13-47a.gmt.gbg.bos:2872 ESTABLISHED 17848/sshd: root@no
    tcp 0 968 87.237.208.94:ssh 1-1-13-47a.gmt.gbg.bos:2873 ESTABLISHED 17881/0

    - I then turned to apache and the httpd.conf and when I looked thrue it I can't find any directions to listen on port 81 for ISPConfig. The only things I have is my vhosts and they are working nice.

    I suspect that it's the apache conf that is missing but I don't know how to restore it.

    My httpd.conf can be found here http://www.esuk.se/temp/httpd.conf
    and the vhosts here http://www.esuk.se/temp/Vhosts_ispconfig.conf
     
  2. Ben

    Ben HowtoForge Supporter

    Well I can't see any apache listening on Port 81.

    There is an http on 80 and 443 but that's the one for your website, not the one ISPConfig is using.
    Try /etc/init.d/ispconfig_server start ;)

    Because if I make a netstat -tap then there is sth like
     
  3. till

    till Super Moderator

    First, the directions to listen on port 81 are not in your apache configuration, ISPConfig has its own apache installed in /root/ispconfig/httpd/ so your apache configuration is OK.

    Please run:

    /etc/init.d/ispconfig_server start
     
  4. Esuk

    Esuk New Member

    Thank you for your quick response :)

    /etc/init.d/ispconfig_server start
    Starting ISPConfig system...
    [Mon Jul 24 11:05:26 2006] [alert] ispconfig_httpd: Could not determine the server's fully qualified domain name, using 0.3.79.210 for ServerName
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    FreshClam is already running!
    ISPConfig system is now up and running!

    netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:imaps *:* LISTEN 13655/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 13655/dovecot
    tcp 0 0 *:mysql *:* LISTEN 13844/mysqld
    tcp 0 0 *:pop3 *:* LISTEN 13655/dovecot
    tcp 0 0 *:imap *:* LISTEN 13655/dovecot
    tcp 0 0 *:http *:* LISTEN 9749/httpd
    tcp 0 0 *:ftp *:* LISTEN 9874/proftpd: (acce
    tcp 0 0 87.237.208.95:domain *:* LISTEN 9855/named
    tcp 0 0 87.237.208.94:domain *:* LISTEN 9855/named
    tcp 0 0 217042:domain *:* LISTEN 9855/named
    tcp 0 0 *:ssh *:* LISTEN 13692/sshd
    tcp 0 0 217042:rndc *:* LISTEN 9855/named
    tcp 0 0 *:smtp *:* LISTEN 9832/master
    tcp 0 0 *:https *:* LISTEN 9749/httpd
    tcp 0 0 87.237.208.94:ssh 1-1-13-47a.gmt.gbg.bos:2872 ESTABLISHED 17848/sshd: root@no
    tcp 0 1452 87.237.208.94:ssh 1-1-13-47a.gmt.gbg.bos:2873 ESTABLISHED 17881/0
    tcp 0 0 87.237.208.95:pop3 1-1-13-47a.gmt.gbg.bos:4036 TIME_WAIT -

    doesn't seem to get the :81 for ISPConfig and the Admin interface isn't avaiable :/
     
  5. Ben

    Ben HowtoForge Supporter

    does /root/ispconfig/httpd/logs/error.log tell anything between a stop and restart?
    Maybe is httpd crashed?
     
  6. Esuk

    Esuk New Member

    I had a look and it shows a lot of errors.

    [Mon Jul 24 09:15:01 2006] [alert] ispconfig_httpd: Could not determine the serv
    er's fully qualified domain name, using 0.3.79.210 for ServerName
    [Mon Jul 24 09:15:01 2006] [warn] pid file /root/ispconfig/httpd/logs/httpd.pid
    overwritten -- Unclean shutdown of previous Apache run?
    [Mon Jul 24 09:15:02 2006] [error] mod_ssl: Init: (87.237.208.94:81) Unable to c
    onfigure RSA server private key (OpenSSL library error follows)
    [Mon Jul 24 09:15:02 2006] [error] OpenSSL: error:0B080074:x509 certificate rout
    ines:X509_check_private_key:key values mismatch
    [Mon Jul 24 09:37:41 2006] [alert] ispconfig_httpd: Could not determine the serv
    er's fully qualified domain name, using 0.3.79.210 for ServerName
    [Mon Jul 24 09:37:41 2006] [warn] pid file /root/ispconfig/httpd/logs/httpd.pid
    overwritten -- Unclean shutdown of previous Apache run?
    [Mon Jul 24 09:37:41 2006] [error] mod_ssl: Init: (87.237.208.94:81) Unable to c
    onfigure RSA server private key (OpenSSL library error follows)
    [Mon Jul 24 09:37:41 2006] [error] OpenSSL: error:0B080074:x509 certificate rout
    ines:X509_check_private_key:key values mismatch
    [Mon Jul 24 09:44:14 2006] [alert] ispconfig_httpd: Could not determine the serv
    er's fully qualified domain name, using 0.3.79.210 for ServerName
    [Mon Jul 24 09:44:14 2006] [warn] pid file /root/ispconfig/httpd/logs/httpd.pid
    overwritten -- Unclean shutdown of previous Apache run?
    [Mon Jul 24 09:44:15 2006] [error] mod_ssl: Init: (87.237.208.94:81) Unable to c
    onfigure RSA server private key (OpenSSL library error follows)
    [Mon Jul 24 09:44:15 2006] [error] OpenSSL: error:0B080074:x509 certificate rout
    ines:X509_check_private_key:key values mismatch
    [Mon Jul 24 11:05:27 2006] [alert] ispconfig_httpd: Could not determine the serv
    er's fully qualified domain name, using 0.3.79.210 for ServerName
    [Mon Jul 24 11:05:27 2006] [warn] pid file /root/ispconfig/httpd/logs/httpd.pid
    overwritten -- Unclean shutdown of previous Apache run?
    [Mon Jul 24 11:05:27 2006] [error] mod_ssl: Init: (87.237.208.94:81) Unable to c
    onfigure RSA server private key (OpenSSL library error follows)
    [Mon Jul 24 11:05:27 2006] [error] OpenSSL: error:0B080074:x509 certificate rout
    ines:X509_check_private_key:key values mismatch
    [Mon Jul 24 11:13:54 2006] [alert] ispconfig_httpd: Could not determine the serv
    er's fully qualified domain name, using 0.3.79.210 for ServerName
    [Mon Jul 24 11:13:54 2006] [warn] pid file /root/ispconfig/httpd/logs/httpd.pid
    overwritten -- Unclean shutdown of previous Apache run?
    [Mon Jul 24 11:13:55 2006] [error] mod_ssl: Init: (87.237.208.94:81) Unable to c
    onfigure RSA server private key (OpenSSL library error follows)
    [Mon Jul 24 11:13:55 2006] [error] OpenSSL: error:0B080074:x509 certificate rout
    ines:X509_check_private_key:key values mismatch
    [Mon Jul 24 11:15:30 2006] [alert] ispconfig_httpd: Could not determine the serv
    er's fully qualified domain name, using 0.3.79.210 for ServerName
    [Mon Jul 24 11:15:30 2006] [warn] pid file /root/ispconfig/httpd/logs/httpd.pid
    overwritten -- Unclean shutdown of previous Apache run?
    [Mon Jul 24 11:15:30 2006] [error] mod_ssl: Init: (87.237.208.94:81) Unable to c
    onfigure RSA server private key (OpenSSL library error follows)
    [Mon Jul 24 11:15:30 2006] [error] OpenSSL: error:0B080074:x509 certificate rout
    ines:X509_check_private_key:key values mismatch
     
  7. Ben

    Ben HowtoForge Supporter

    That seems if anything with your ssl certs is broken...

    if i look at
    Would that time match the "network" crash of your provider? If yes, sure that it was only the network not the powerline? Maybe a power loss on your server caused a demage on your filesystem destroying any certs?
    Or just take a look at you uptime to see if your server was rebooted withoud you knowledge...
     
  8. Esuk

    Esuk New Member

    I re-generated the server cert as described by falko in this thread http://www.howtoforge.com/forums/showpost.php?p=358&postcount=4 and after restarting ISPConfig the problem was solved.
    (I can now access the admin interface and I got ISPConfig listening on port 81)

    netstat -tap
    tcp 0 0 *:81 *:* LISTEN 22042/ispconfig_htt

    Thank you all for your help, I don't regret changing from "the Pleskvirus" to ISPConfig, my best decission ever!
     

Share This Page