Can't access subdomain on port 80

Discussion in 'Installation/Configuration' started by Sir Henry, Aug 13, 2012.

  1. Sir Henry

    Sir Henry Member

    This must be a stupid misconfiguration but I can't figure it out, perhaps somebody has a good idea.

    I have ISPConfig running on I want to configure port 80 as a portal for my clients, so I configured a site with domain "" and auto-subdomain "*.". Now this site can be accessed on port 80 with its main domain and all subdomains except For instance, works fine.

    The error in the Apache log is:
    I have been searching for a dedicated setting of anywhere else, but I can't find any. For instance, when I grep -r its /etc/apache2, there is no result.

    When I configure an explicit subdomain '', the situation does not change.

    The question is, why is subdomain 'its' handled in a special way? Anybody any idea?

    [edit]Forgot to mention that '' is also the hostname of my server, which might be the core of the problem.
    Last edited: Aug 13, 2012
  2. Sir Henry

    Sir Henry Member

    I solved this problem by explicitly allowing access to the base directory in /etc/apache2/conf.d/default.vhost:
        <Directory /var/www/>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
    ... but I have no idea why Apache does not take the wildcard subdomain settings. Must be because the host is the real server, not a virtual server.

Share This Page