Can't access phpmyadmin

Discussion in 'General' started by PermaNoob, Oct 6, 2010.

  1. PermaNoob

    PermaNoob New Member

    When I click the phpmyadmin button on the database page I get

    An error occurred during a connection to server3.mydomain.com.

    SSL received a record that exceeded the maximum permissible length.

    (Error code: ssl_error_rx_record_too_long)

    -------------

    Before I could just delete the s from https in the resulting URL, but now that doesn't work.

    Hovering over the link shows:

    https://server3.mydomain.com:8080/sites/database_phpmyadmin.php?id=1

    and the resulting URL is

    https://server3.mydomain.com/phpmyadmin

    neither of which works

    nor does

    http://server3.mydomain.com/phpmyadmin

    which gives The requested URL was not found on this server.

    or

    http://server3.mydomain.com:8080/sites/database_phpmyadmin.php?id=1

    which gives

    Your browser sent a request that this server could not understand.
    Reason: You're speaking plain HTTP to an SSL-enabled server port.
    Instead use the HTTPS scheme to access this URL, please.
     
    Last edited: Oct 6, 2010
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    try the ip and not the servername.
     
  3. PermaNoob

    PermaNoob New Member

    That doesn't work either.
     
  4. PermaNoob

    PermaNoob New Member

    It seems to have something to do with the https access to the controlpanel where the link from the database page includes the https when it normally wouldn't, but deleting the s doesn't fix the problem.
     
    Last edited: Oct 6, 2010
  5. PermaNoob

    PermaNoob New Member

    Until there's a fix (and maybe after) I'm using Adminer--works perfectly and no installation--just upload a single file: http://www.adminer.org/
     

Share This Page