cant access phpMyAdmin returns uncompiled PHP file

Discussion in 'Installation/Configuration' started by andreasnrb, Mar 23, 2010.

  1. andreasnrb

    andreasnrb New Member

    I can't access phpMyAdmin anymore. I had to uninstall and reinstall ISPConfig 3 and somewhere a long the line phpMyAdmin stopped being interpreted as PHP.
    When I go to the phpMyAdmin adress it returns an uncompiled PHP file.

    I've tried removing and reinstalling. Adding to apache2.conf but that didn't work since it was already added apparently. Used dkpg reconfigure and chose apache2. That didn't work either.

    How can I get PHP activated for phpMyAdmin?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    How do you access phpmyadmin? phpmyadmin can only be accessed trogh the default vhost of the server, so you have to use e.g. the IP address of the server. If you access it trough a domian name of a website, it might be that you get only the php sourcecode.
  3. andreasnrb

    andreasnrb New Member

    I cant access it in anyway =).
    ip/phpmyadmin cant accesss server
    mydomain/phpmyadmin cant access server

    ip:8080/phpmyadmin returns do you want to save php returns do you want to save php

    This is how I used to access it but no more returns do you want to save php
  4. falko

    falko Super Moderator ISPConfig Developer

    Any errors in Apache's error log? Is the PHP module enabled?
  5. andreasnrb

    andreasnrb New Member

    No errors and the php module is loaded. ISPConfig 3 runs fine, all my wp websites run.
    Is it possible there is some messup in a vhost file?

Share This Page