Can't access PHPMyAdmin (PMA)

Discussion in 'Installation/Configuration' started by snowweb, Aug 19, 2020.

  1. snowweb

    snowweb Member

    Tried all my keys at the lock... I'm expecting to access it on https://<main-server-site>/phpmyadmin/
    • SSL is enabled and working on ISPConfig site and main server site.
    • PHP is enabled and set to Fast-CGI (is that the most appropriate)?
    • PHPMyAdmin URL is unchanged at /phpmyadmin
    I don't see it in /etc/apache2/sites-available/ although "whereis" says it is existing in /etc/phpmyadmin/ and /usr/share/phpmyadmin.

    I found the following advice, to:
    here, but I don't have /etc/apache2/conf.d/ so it looks like things changed since that advice in 2013.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Correct, as it should not be in that folder. phpmyadmin uses an alias, it is not a website. If you can't reach it, then the most likely reason is that you kissed activating it at install time.


    dpkg-reconfigure phpmyadmin

    and take care to enable the apache2 option, an option in apt is enabled by using the space bar, it is not enough to just highlight it.
  3. snowweb

    snowweb Member

    I ran dpkg-reconfigure phpmyadmin as you suggested and it seems to have fixed my situation, in that the phpmyadmin login page is now available and I can log in there using mysql 'root' credentials. However, I did get the following output when I ran the command and am wondering what the error will do to us down the road?
    Do you think this is a problem?
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I would assume it is a problem, and fix it by looking what is in that file. It should have two password lines and they should have the same password, which is the database root password.
    I do not know what troubles it causes, and am too lazy to research that.
    snowweb likes this.
  5. snowweb

    snowweb Member

    Forgot to mention... I checked the file and both passwords are identical and are set to the current root user password for MySQL. This password is different to the root password used for the server root user, but as far as I understand that's okay, since they are separate accounts.
    Anyway, I've done some testing and PMA appears to be working okay, so I think I'll just wait and see.
    Thanks Taleman.

Share This Page