Can't access munin via web browser

Discussion in 'HOWTO-Related Questions' started by wpwood3, Nov 13, 2007.

  1. wpwood3

    wpwood3 New Member

    I installed munin last night and everything was working fine. All the charts were created and were updating.

    This morning, I try to look at the charts and Apache gives me a 404 Error - File not found. All the files ARE there and Munin seems to be updating them. I just can't access them via web browser.

    Here' s where the munin files are located:

    /var/www/web2/web/munin

    I removed the .htaccess and .htpasswd files and I still cannot get the browser to access munin.

    http://www.mysite.com/munin/index.html gives me Error 404.

    If I try to access http://www.mysite.com/munin/ I get an Apache 403 Error - Forbidden!

    I'm stumped! :(
     
    Last edited: Nov 13, 2007
  2. wpwood3

    wpwood3 New Member

    Update

    If I delete this file then Apache will let me access Munin:

    /etc/httpd/conf.d/munin.conf

    The file contains the following:
    Code:
     
    # For SSL-servers
    ScriptAlias /munin/cgi/ /var/www/munin/cgi/
    #<Directory /var/www/munin/cgi/>
    #   Options ExecCGI
    #   SSLRequireSSL
    #   order deny,allow
    #   deny from all
    #   AuthType Basic
    #   AuthUserFile /site/cfg/passwd
    #   AuthGroupFile /site/cfg/group
    #   AuthName "munin"
    #   require group munin
    #   Satisfy Any
    #</Directory>
    #
    Alias /munin/ /var/www/munin/
    #<Directory /var/www/munin/>
    #   Options None
    #   SSLRequireSSL
    #   order deny,allow
    #   deny from all
    #   AuthType Basic
    #   AuthUserFile /site/cfg/passwd
    #   AuthGroupFile /site/cfg/group
    #   AuthName "munin"
    #   require group munin
    #   Satisfy Any
    #</Directory>
    
    
    Why is this file even there?
    Should I be deleting it or changing it?
     
  3. falko

    falko Super Moderator ISPConfig Developer

    It's for a default munin installation where the document root is in /var/www/html. This doesn't apply to you because you're using virtual hosts with different document roots, therefore it's correct to comment that out. :)
     
  4. wpwood3

    wpwood3 New Member

    Thanks Falko!

    Yes, Munin has been working fine since I commented out the lines in /etc/httpd/conf.d/munin.conf.

    ScriptAlias points to /var/www/munin/cgi/. I looked there and Munin had installed munin-cgi-graph at that location. It does not appear that Munin is using that file for anything. Maybe it is an option that can be turned on but is not used in the default configuration.
     

Share This Page