Can't access ISPCONFIG web interface

Discussion in 'ISPConfig 3 Priority Support' started by toyinal, Nov 3, 2016.

  1. toyinal

    toyinal Member HowtoForge Supporter

    On a new Centos 7.2 install of ISPConfig 3.1, access to https://xxxxx.com:1234 is showing directory index (port 1234 is ISPConfig port). On checking httpd log, apache is directing to /var/www/html rather than ispconfig directory /var/www/ispconfig.

    httpd -S below
    Code:
    [Thu Nov 03 01:36:22.167912 2016] [alias:warn] [pid 26257] AH00671: The ScriptAlias directive in /etc/httpd/conf.d/mailman.conf at line 6 will probably never match because it overlaps an earlier ScriptAlias.
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/httpd/conf/httpd.conf:357
    VirtualHost configuration:
    *:443                  xxxxx.com (/etc/httpd/conf.d/ssl.conf:56)
    *:8081                 xxxxx.com (/etc/httpd/conf/sites-enabled/000-apps.vhost:9)
    *:1234                 xxxxx.com (/etc/httpd/conf/sites-enabled/000-ispconfig.vhost:9)
    ServerRoot: "/etc/httpd"
    Main DocumentRoot: "/var/www/html"
    Main ErrorLog: "/etc/httpd/logs/error_log"
    Mutex rewrite-map: using_defaults
    Mutex authdigest-client: using_defaults
    Mutex ssl-stapling: using_defaults
    Mutex proxy: using_defaults
    Mutex authn-socache: using_defaults
    Mutex ssl-cache: using_defaults
    Mutex default: dir="/run/httpd/" mechanism=default
    Mutex mpm-accept: using_defaults
    Mutex authdigest-opaque: using_defaults
    Mutex proxy-balancer-shm: using_defaults
    PidFile: "/run/httpd/httpd.pid"
    Define: DUMP_VHOSTS
    Define: DUMP_RUN_CFG
    User: name="apache" id=48
    Group: name="apache" id=48
    
    I've re-installed ISPConfig twice & I did not modified any, but same issue

    Thanks
     
  2. toyinal

    toyinal Member HowtoForge Supporter

    SOLVED
    mod_fcgi was missing from my installation and ispconfig vhost require it to set document root to the /var/ww/ispconfig DocumentRoot. Installing the fcgi module with
    yum install -y mod_fcgid
    resolve it
     

Share This Page