can't access ispconfig panel nor my websites

Discussion in 'General' started by Robin.k, Jul 21, 2019.

  1. Robin.k

    Robin.k Member

    I can´t access my ispconfig panel nor my websites after update/upgrade
    When i run in terminal ¨service apache2 status¨ i get the error in 000-apps.vhost line 6
    What to change to get it work again.
    Thanks


    ● apache2.service - LSB: Apache2 web server
    Loaded: loaded (/etc/init.d/apache2; bad; vendor preset: enabled)
    Drop-In: /lib/systemd/system/apache2.service.d
    └─apache2-systemd.conf
    Active: failed (Result: exit-code) since zo 2019-07-21 11:41:44 CEST; 29min ago
    Docs: man:systemd-sysv-generator(8)
    Process: 6575 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

    jul 21 11:41:44 server1.her.nl apache2[6575]: * The apache2 configtest failed.
    jul 21 11:41:44 server1.her.nl apache2[6575]: Output of config test was:
    jul 21 11:41:44 server1.her.nl apache2[6575]: AH00526: Syntax error on line 6 of /etc/apache2/sites-enabled/000-apps.vhost:
    jul 21 11:41:44 server1.her.nl apache2[6575]: Listen requires 1 or 2 arguments.
    jul 21 11:41:44 server1.her.nl apache2[6575]: Action 'configtest' failed.
    jul 21 11:41:44 server1.her.nl apache2[6575]: The Apache error log may have more information.
    jul 21 11:41:44 server1.her.nl systemd[1]: apache2.service: Control process exited, code=exited status=1
    jul 21 11:41:44 server1.her.nl systemd[1]: Failed to start LSB: Apache2 web server.
    jul 21 11:41:44 server1.her.nl systemd[1]: apache2.service: Unit entered failed state.
    jul 21 11:41:44 server1.her.nl systemd[1]: apache2.service: Failed with result 'exit-code'.

    The 000-apps.vhost gives me
    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig apps vhost
    ######################################################

    Listen
    # NameVirtualHost *:

    <VirtualHost _default_:>
    ServerAdmin [email protected]


    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>

    <IfModule mod_headers.c>
    RequestHeader unset Proxy early
    </IfModule>

    <IfModule mod_php5.c>
    DocumentRoot /var/www/apps
    AddType application/x-httpd-php .php
    <Directory /var/www/apps>
    Options FollowSymLinks
    AllowOverride None
    Require all granted
    </Directory>
    </IfModule>

    <IfModule mod_fcgid.c>
    DocumentRoot /var/www/apps
    SuexecUserGroup ispapps ispapps
    <Directory /var/www/apps>
    Options +Indexes +FollowSymLinks +MultiViews +ExecCGI
    AllowOverride AuthConfig Indexes Limit Options FileInfo
    <FilesMatch "\.php$">
    SetHandler fcgid-script
    </FilesMatch>
    FCGIWrapper /var/www/php-fcgi-scripts/apps/.php-fcgi-starter .php
    Require all granted
    </Directory>
    </IfModule>

    </VirtualHost>

    What to change to get it work again






    I
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Change the first lines to:

    Code:
    Listen 8081
    # NameVirtualHost *:
    
    <VirtualHost _default_:8081>
     
  3. Robin.k

    Robin.k Member

    Is the server correct started?
    If i tried to connect to the server with 192.168.1.20:8081 and get the message ¨


    403 Forbidden
    nginx/1.10.3 (Ubuntu)


    I have changed this lines and i get with ¨service apache2 status¨

    ● apache2.service - LSB: Apache2 web server
    Loaded: loaded (/etc/init.d/apache2; bad; vendor preset: enabled)
    Drop-In: /lib/systemd/system/apache2.service.d
    └─apache2-systemd.conf
    Active: inactive (dead) since zo 2019-07-21 13:28:32 CEST; 23min ago
    Docs: man:systemd-sysv-generator(8)
    Process: 2375 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
    Process: 1242 ExecStart=/etc/init.d/apache2 start (code=exited, status=0/SUCCESS)

    jul 21 13:28:32 server1.her.nl apache2[1242]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
    jul 21 13:28:32 server1.her.nl apache2[1242]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
    jul 21 13:28:32 server1.her.nl apache2[1242]: no listening sockets available, shutting down
    jul 21 13:28:32 server1.her.nl apache2[1242]: AH00015: Unable to open logs
    jul 21 13:28:32 server1.her.nl apache2[1242]: Action 'start' failed.
    jul 21 13:28:32 server1.her.nl apache2[1242]: The Apache error log may have more information.
    jul 21 13:28:32 server1.her.nl apache2[1242]: *
    jul 21 13:28:32 server1.her.nl apache2[2375]: * Stopping Apache httpd web server apache2
    jul 21 13:28:32 server1.her.nl apache2[2375]: *
    jul 21 13:28:32 server1.her.nl systemd[1]: Started LSB: Apache2 web server.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    That's exactly what should be displayed then. so it's working fine now.

    Regarding the 'in use' error now, it seems as if you have installed another webserver (nginx) which uses the same ports than your apache web server. If its a apache webserver, then stop nginx and start apache. If it's an nginx web server, then stop apache and start nginx.
     
  5. Robin.k

    Robin.k Member

    I stopt the nginx server and restsrt the apache2 server
    But i can´t connect with the server 192.168.1.20:8081
    On the server browser i tried https://192.168.1.20:8081/ and get the message SSL_ERROR_RX_RECORD_TOO_LONG



    ● nginx.service - A high performance web server and a reverse proxy server
    Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
    Active: inactive (dead) since zo 2019-07-21 14:06:39 CEST; 4min 38s ago
    Process: 7958 ExecStop=/sbin/start-stop-daemon --quiet --stop --retry QUIT/5 --pidfile /run/nginx.pid (code=exited, status=0/SUCCESS)
    Process: 1120 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
    Process: 1026 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
    Main PID: 1122 (code=exited, status=0/SUCCESS)

    jul 21 13:27:38 server1.her.nl systemd[1]: Starting A high performance web server and a reverse proxy server...
    jul 21 13:27:47 server1.her.nl systemd[1]: Started A high performance web server and a reverse proxy server.
    jul 21 14:06:39 server1.her.nl systemd[1]: Stopping A high performance web server and a reverse proxy server...
    jul 21 14:06:39 server1.her.nl systemd[1]: Stopped A high performance web server and a reverse proxy server.
    ~

    ● apache2.service - LSB: Apache2 web server
    Loaded: loaded (/etc/init.d/apache2; bad; vendor preset: enabled)
    Drop-In: /lib/systemd/system/apache2.service.d
    └─apache2-systemd.conf
    Active: active (running) since zo 2019-07-21 14:07:25 CEST; 1min 25s ago
    Docs: man:systemd-sysv-generator(8)
    Process: 2375 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
    Process: 8002 ExecStart=/etc/init.d/apache2 start (code=exited, status=0/SUCCESS)
    CGroup: /system.slice/apache2.service
    ├─8021 /usr/sbin/apache2 -k start
    ├─8023 vlogger (access log
    ├─8024 /usr/sbin/fcgi-pm -k start
    ├─8026 /usr/sbin/apache2 -k start
    ├─8027 /usr/sbin/apache2 -k start
    ├─8028 /usr/sbin/apache2 -k start
    ├─8029 /usr/sbin/apache2 -k start
    ├─8030 /usr/sbin/apache2 -k start
    ├─8031 /usr/sbin/apache2 -k start
    ├─8042 /usr/sbin/apache2 -k start
    ├─8128 /usr/sbin/apache2 -k start
    ├─8133 /usr/sbin/apache2 -k start
    └─8134 /usr/sbin/apache2 -k start
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The apps vhost is http and not https, so you must get that message when you access an http vhost by https. Besides that, the apps vhost is normally empty, so not sure why you focus on accessing it. ISPConfig itself is not in the apps vhost, its on port 8080 and not 8081.
     
  7. Robin.k

    Robin.k Member

    Thanks for the support, finally it works again.
    I replaced the apache2 directory with an older backup from the apache2 directory.
    After that I could not reach my websites, but I can reach the ISPConfig pannel again and unmark SLL and LetsEncript from my website. After this i mark SLL and LetsEncript again. Now everything works again.
     

Share This Page