Can't Access ISPConfig Login After Installation (Gutsy 7.10)

Discussion in 'Installation/Configuration' started by giganet, Oct 24, 2007.

  1. giganet

    giganet New Member

    SOLVED 10/02/2007


    Have been following http://howtoforge.com/perfect_server_ubuntu7.10

    After installing ISPConfig I attempted to access ISPConfig as prompted to do from the CLI at the end of installation.
    ISPConfig login would never load though.

    Tried re-booting the server to see if ISPConfig would become accessible...
    This time when I attempt to access ISPConfig admin login I am presented with this SSL cert error:
    Code:
    Could not establish an encrypted connection because certificate presented by myserver.net is invalid or corrupted. Error code -8182
    I searched HTF and came upon this article: http://www.howtoforge.com/faq/14_63_en.html
    When I attempt the 2nd command in this article the system returns:
    Code:
    openssl req -new -passin pass:!!!!!! -passout pass:!!!!!! -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.csr/ssl.csr -days 365
    openssl req -new -passin pass:365P_c1 -passout pass:365P_c1 -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.csr/ssl.csr -days 365
    unable to load Private Key
    16002:error:06065064:digital envelope routines:EVP_DecryptFinal_ex:bad decrypt:evp_enc.c:461:
    16002:error:0906A065:PEM routines:PEM_do_header:bad decrypt:pem_lib.c:425:
    Shorewall and iptables are both configured with rules allowing port 80, 81, 443, 3306 and such.

    Shorewall will not start and outputs this error:
    Code:
    ERROR: Command "/sbin/iptables -A @all2all -m limit LEVEL -j RETURN"
    Failed.
            /sbin/shorewall: line 356:   15022 Terminated
    Is this command originating at '/sbin/iptables'?
    How would I change this situation?

    Thanking you in advance for your help

    Regards
     
    Last edited: Nov 2, 2007
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. giganet

    giganet New Member

    Have resumed working on generating a new SSL cert for ISPConfig...

    I have attempted generating a new SSL cert for ISPConfig as defined at: http://www.howtoforge.com/faq/14_63_en.html and a also http://www.howtoforge.com/forums/showthread.php?t=121 as suggested by Falko.

    The first step works seems to work- it completes rather quickly.
    Code:
    1) openssl genrsa -des3 -passout pass:xxxxxx -out /root/ispconfig/httpd/conf/ssl.key/server.key2 1024
    The second step ...
    Code:
    2) openssl req -new -passin pass:xxxxxx -passout pass:xxxxxx -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.csr/server.csr -days 365
    is where I encounter this error:
    Code:
    unable to load Private key
    7645:error:06065064: digital envelope routines:EVP_DecryptFinal_ex:bad decrypt:evp_enc.c:461
    
    7645:error:0906A065:PEM routines:PEM_do_header:bad decrupt:pem_lib.c:425
    I can't make it past this step to generate a new SSL cert for ISPConfig.

    In addition to the above- I have found that when booting the server OS it seems that when ISPConfig is starting it causes confusion when attempting to log in as a user to the server with entering the PEM Passphrase.

    It will first prompt you for a user name and once entered it immediately tells you that the passphrase was incorrect!
    Warning with SSL_mod errors.
    From that point on you are agrivated for many re-attempts that always seem to fail until finally for no apparant reason you are logged into the server with ISPConfig running but MySQL is not?


    What should be done to correct these issues?


    Thanking you in advance for your help and response


    Regards
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try to create the SSL cert again and use a simple password with no special chers in it, just upper and lower case chars and numbers.
     
  5. giganet

    giganet New Member

    Thank you Till..

    The new password variant worked for generating the SSL cert.

    I am able to log into ISPConfig now but am presented with the following:
    Code:
    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77
    
    Warning: mysql_real_escape_string() [function.mysql-real-escape-string]: Access denied for user 'admispconfig'@'localhost' (using password: NO) in /home/admispconfig/ispconfig/web/login/login.php on line 40
    
    Warning: mysql_real_escape_string() [function.mysql-real-escape-string]: A link to the server could not be established in /home/admispconfig/ispconfig/web/login/login.php on line 40
    
    Warning: mysql_real_escape_string() [function.mysql-real-escape-string]: Access denied for user 'admispconfig'@'localhost' (using password: NO) in /home/admispconfig/ispconfig/web/login/login.php on line 41
    
    Warning: mysql_real_escape_string() [function.mysql-real-escape-string]: A link to the server could not be established in /home/admispconfig/ispconfig/web/login/login.php on line 41
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/web/login/login.php on line 60
    I have found that upon restart of ISPConfig it is unable to connect to MySQL:
    Code:
    [email protected]:/home/admispconfig/ispconfig/lib# /etc/init.d/ispconfig_server restart
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd stopped
    ISPConfig system stopped!
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    Could not connect to MySQL server!ISPConfig system is now up and running!
    
    I am able to log onto MySQL by running 'mysql -u root -p'
    however if I try using the ISPConfig.db I can not log on when running the command 'mysql -u root -f ispconfig.db -p'
    I receive the following error:
    Code:
    ERROR 1102 (42000): Incorrect database name 'ispconfig.db'
    Thanking you in advance for your help...

    Regards
     
    Last edited: Oct 31, 2007
  6. giganet

    giganet New Member

    Sorry for the duplicate posting...
     
    Last edited: Oct 30, 2007
  7. giganet

    giganet New Member

    I have been comparing ISPConfig settings on a Ubuntu 6.06 server that is up and running versus my newest server Ubuntu 7.10 and have found the potential cause of why ISPConfig on the 7.10 server can't access it's db when ISPConfig starts up...


    It appears that when I named the db in the 7.10 server I named it 'ispconfig.db' rather than 'ispconfigdb'.

    AS shown below from '/home/admispconfig/ispconfig/lib/config.inc.php'
    Code:
    $go_info["server"]["db_name"] = "ispconfig.db";
    
    Is it possible this could be causing the problem I exeprience when logging into ISPConfig CP?

    I just logged into mysql using 'mysql -u root -p' then ran 'SHOW DATABASES;'
    Which returns the following result:
    Code:
    mysql> SHOW DATABASES;
    +--------------------+
    | Database           |
    +--------------------+
    | information_schema |
    | mysql              |
    +--------------------+
    2 rows in set (0.00 sec)
    
    Would I need to create a new db for ISPConfig, or what?

    Thank you for your help

    Regards
     
    Last edited: Oct 31, 2007
  8. giganet

    giganet New Member

    Update

    I logged into mysql and created the db 'ispconfigdb'
    Code:
    mysql> SHOW DATABASES;
    +--------------------+
    | Database           |
    +--------------------+
    | information_schema |
    | ispconfigdb        |
    | mysql              |
    +--------------------+
    3 rows in set (0.01 sec)
    
    I am now able to log into 'ispconfigdb' running 'mysql -u root -f ispconfigdb -p'

    Then I opened '/home/admispconfig/ispconfig/lib/config.inc.php' and modified the db name line to reflect the new db I created without '.db' at the end.

    After making these changes I have restarted 'mysql' successfully-- 'ISPConfig' starts but complains of not being able to connect to the mysql still...
    Code:
    [email protected]:/home/admispconfig/ispconfig/lib# /etc/init.d/ispconfig_server restart
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd stopped
    ISPConfig system stopped!
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    Could not connect to MySQL server!ISPConfig system is now up and running!
    
    What should I check to resolve this issue?

    Thanking you in advance for your help.

    Regards
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Database names with a dot inside are always a problem in mysql, as the dot is used in the mysql sql syntax to divide bwtween the database and table name.

    I guess you will have to reinstall ISPConfig. Run:

    rm -rf /root/ispconfig
    rm -rf /home/admispconfig

    delete the ispconfig mysql database and reinstall ISPConfig.
     
  10. giganet

    giganet New Member

    Thank you Till...

    I ran the commands 'rm -rf /root/ispconfig' 'rm -rf /home/admispconfig'-
    after that I logged into mysql and ran 'drop database ispconfig;'.


    After running the ISPConfig installation script and logging back into the CP I am still presented with the same errors:
    Code:
    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77
    
    Warning: mysql_real_escape_string() [function.mysql-real-escape-string]: Access denied for user 'admispconfig'@'localhost' (using password: NO) in /home/admispconfig/ispconfig/web/login/login.php on line 40
    
    Warning: mysql_real_escape_string() [function.mysql-real-escape-string]: A link to the server could not be established in /home/admispconfig/ispconfig/web/login/login.php on line 40
    
    Warning: mysql_real_escape_string() [function.mysql-real-escape-string]: Access denied for user 'admispconfig'@'localhost' (using password: NO) in /home/admispconfig/ispconfig/web/login/login.php on line 41
    
    Warning: mysql_real_escape_string() [function.mysql-real-escape-string]: A link to the server could not be established in /home/admispconfig/ispconfig/web/login/login.php on line 41
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/web/login/login.php on line 60

    When I run 'netstat -a | grep mysql' I see the following:
    Code:
     netstat -a | grep mysql
    tcp        0      0 localhost.localdo:mysql *:*                     LISTEN
    unix  2      [ ACC ]     STREAM     LISTENING     20751    /var/run/mysqld/mysqld.sock
    

    I am able to ping 'localhost' 'localhost.localdomain' '127.0.0.1' '65.197.209.3' 'giganetwireless.net' all successfully.

    Firewall rules are also properly applied to Shorewall and Iptables.







    After re-installing ISPConfig I logged into mysql to validate that 'ispconfigdb' exists also.

    Thanking you in advance for your help.

    Regards
     
    Last edited: Nov 1, 2007
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Take the mysql username and password that you find in the file /home/admispconfig/ispconfig/lib/config.inc.php and run the command:

    mysql -h localhost -u root -p

    then enter the password from the file above. Are you able to login?
     
  12. giganet

    giganet New Member

    Thank you Till...

    Yes I am able to log into mysql using copy/paste of the usr/pwd found in config.inc.php.

    The password consists of 'special characters', 'upper/lower case alpha', & 'numerics'.



    This is very strange how ISPConfig using these very credentials cannot gain access to the mysql db???


    Regards
     
  13. giganet

    giganet New Member

    Till

    I thought maybe the combination of special characters|alphas|numerics was causing the problem so I logged into mysql and changed the root password as used by ISPConfig to a password consisting of upper/lower case alphas with one numeric.

    When I restart ISPConfig with the new pwd it returns:
    Code:
    [email protected]:/home/bender# /etc/init.d/ispconfig_server restart
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd stopped
    ISPConfig system stopped!
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
    No results found!ISPConfig system is now up and running!
    
    Likewise with the above values if I attmept to log into the CP after entering the default usr/pwd I am returned to the login screen.


    Thank you Till
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    The mysql password should not contain special characters. Cahnging the password after the ISPConfig installation wont help, as the installation itself is not successful when the password contianed characters that might be interpreted by the shell. You will have to remove ISPConfig and the database, then install it agaian and make sure that the mysql password does not contain special chars.
     
  15. giganet

    giganet New Member

    Hmm, Ok- I will drop ispconfigdb and remove ISPConfig to re-install it all over again....

    My other server running Ubuntu 6.06 uses a password which begins with a special character and works flawlessly though????



    Thanks Till


    Regards
     
  16. giganet

    giganet New Member

    That did it Till!

    I will mark this post as SOLVED

    Thank you very much for your help Till.

    I am confused though how my other server running Ubuntu 6.06 utilizes a special character in it's mysql pwd- go figure heh?
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    I depends on which special character you used. The ISPConfig installer is partly a shell script and if the special character is something that might be interpreted as pipe sign or commad or variable, the installation might fail.
     

Share This Page