Can't access ISPConfig from a LAN machine

Discussion in 'Installation/Configuration' started by Nap, Oct 6, 2006.

  1. Nap

    Nap Member

    Can't access ISPConfig from a LAN machine [Resolved]

    [For ppl who've fried their brains during the Linux install process.]

    Hi,
    I am new to Linux, and have setup a Debian Sarge LAMP server following Falko's great guide. (Prior to finding it, I had been floundering with Debian and Ubuntu for a month! arrrrgggg)

    The LAMP server is located on an internal LAN that has a number of Windows machines on it as well.

    Everything seems to be working when I browse to it from other machines on the LAN; I can access Apache2, I can administrate MySQL through phpMyAdmin, connect via FTP, etc.

    When I installed ISPConfig, I answered the questions as per the online documentation. At the end, when I had to nominate the IP, I entered the machine's LAN IP, and the domain as the local domain name (webdev.abmsdomain.local) (webdev is the host name). Since I haven't setup my Hosts file yet, I am accessing this machine via it's IP address.

    When I use the link: http://192.168.0.5:81 to access ISPConfig from another PC on the LAN, I get an error message:
    The connection was reset
    The connection to the server was reset while the page was loading.


    I haven't tested it locally on the linux machine itself (since the machine hangs when I run the browser) but since I can access Apache etc from my other machines, I'm pretty sure that ISPConfig should work.

    I looked in the httpd.conf file for ISPConfig but couldn't see anything there that would prevent external access.
    What do I need to change to enable ISPConfig to be accessable via my LAN?

    Cheers,
    Nap
     
    Last edited: Oct 8, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    This sounds like ISPConfig SSL certificate is corrupt. Did you try with Firefox? IS the error message something like "firefox -8182"? Then you should recreate the certificate as shown here: http://www.howtoforge.com/forums/showthread.php?t=121
     
  3. Nap

    Nap Member

    Hi Falko,
    Thnx for taking the time to help me. Your guide is a fabulous document! Thank you for taking the time to create it.

    I don't get any error number is my browser (which is Firefox). I will have a look at the link you gave me, coz when I went through the certificate creation process, I simply accepted the defaults. (I suspected that it might have consequences, especially since the domain doesn't match the certificate.)

    Cheers,
    Nap
     
  4. Nap

    Nap Member

    Hi Falko,
    I tried the following steps:
    Code:
    openssl genrsa -des3 -passout pass:yourpassword -out /root/ispconfig/httpd/conf/ssl.key/server.key2 1024
    openssl req -new -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.csr/server.csr -days 365
    openssl req -x509 -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -in /root/ispconfig/httpd/conf/ssl.csr/server.csr -out /root/ispconfig/httpd/conf/ssl.crt/server.crt -days 365
    openssl rsa -passin pass:yourpassword -in /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.key/server.key
    chmod 400 /root/ispconfig/httpd/conf/ssl.key/server.key
    
    But no joy. Still getting the same message as before:
    The connection was reset
    The connection to the server was reset while the page was loading.

    and no error numbers.

    When I was asked to enter the details for the Certificate, I entered in values for each one, but I was a little confused on how to answer the email (I used [email protected]).

    The hostname is webdev and the domain name is abmsdomain.local. I am using the .local because that's what my W2K Server has it's domain name set to (even though when I log on from another machine, it doesn't show the .local part.
    Since this is a machine that is not accesable from the Internet, is there a particular way I should be doing this?


    Also, I've found that while I can access Apache2 via http, I cannot acces it via https.

    With this, I get the message:
    The connection was interrupted
    The connection to webdev.abmsdomain.local was interrupted while the page was loading.

    and again, no error numbers.
    I have setup my HOSTS file to point 192.168.0.5 to webdev.abmsdomain.local.

    Cheers,
    Nap
     
  5. Nap

    Nap Member

    Hi Falko,
    Here is my netstat -tap output.

    Cheers,
    Nap

    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State PID/Program name
    tcp        0      0 *:mysql                 *:*                     LISTEN     2 1327/mysqld
    tcp        0      0 *:sunrpc                *:*                     LISTEN     2 166/portmap
    tcp        0      0 *:81                    *:*                     LISTEN     1 1021/ispconfig_htt
    tcp        0      0 *:ftp                   *:*                     LISTEN     1 1189/proftpd: (acc
    tcp        0      0 *:smtp                  *:*                     LISTEN     3 1715/master
    tcp        0      0 localhost.localdoma:670 *:*                     LISTEN     3 038/famd
    tcp6       0      0 *:imaps                 *:*                     LISTEN     2 734/couriertcpd
    tcp6       0      0 *:pop3s                 *:*                     LISTEN     2 755/couriertcpd
    tcp6       0      0 *:pop3                  *:*                     LISTEN     2 742/couriertcpd
    tcp6       0      0 *:imap2                 *:*                     LISTEN     2 721/couriertcpd
    tcp6       0      0 *:www                   *:*                     LISTEN     1 1052/apache2
    tcp6       0      0 *:ssh                   *:*                     LISTEN     3 034/sshd
    tcp6       0      0 *:smtp                  *:*                     LISTEN     3 1715/master
    tcp6       0      0 *:https                 *:*                     LISTEN     1 1052/apache2
    
     
  6. Nap

    Nap Member

    I just realised that the firewall on my Windows machine blocks port 81. I've opened it, and am now able to login. :)

    But, after logging in and the screen is partially updated, I get the message:
    Not Found
    The requested URL /nojsindx.htm was not found on this server.

    I looked in the /home/admispconfig/ispconfig/web folder, and it's not there. However there is a file with that name in several of the sub-folders.
    Any comments? Why isn't is in the web folder? Can I copy the file from one of the sub-folders into the web folder?

    Cheers,
    Nap
     
    Last edited: Oct 8, 2006
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The file does not exist in ISPConfig. You must enable javascript in your webbrowser.
     
  8. Nap

    Nap Member

    till,
    :) :) :)
    Oh my. What other basics will I overlook next?

    Thanks.
    Nap
     

Share This Page