Can't access ISPConfig after installation

Discussion in 'Installation/Configuration' started by Luke Roughley, Jan 11, 2016.

  1. Luke Roughley

    Luke Roughley New Member

    I followed the guide for installation of ISPConfig 3 on Centos 7 (https://www.howtoforge.com/perfect-...l-php-pureftpd-postfix-dovecot-and-ispconfig3) and I am having problem accessing the control panel after completion.
    I ran the script and it found that there was a warning "could not determind server's ip address by ifconfig"
    While trying to debug this I modified my IPTABLES also, thinking that it could be blocked by firewall, and now have no access on any of the ports.
    Firewalld is disabled as per tutorial.

    Thanks for any help anyone can offer.

    See output below:
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.0.5.4p8


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 5.4.16

    ##### PORT CHECK #####

    [WARN] Port 465 (SMTP server SSL) seems NOT to be listening

    ##### MAIL SERVER CHECK #####

    [WARN] I found no "submission" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer port 587 for smtp connections you have to enable this.
    [WARN] I found no "smtps" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer SSL for smtp (not TLS) connections you have to enable this.

    ##### RUNNING SERVER PROCESSES #####

    [INFO] I found the following web server(s):
    Unknown process (httpd) (PID 62505)
    [INFO] I found the following mail server(s):
    Postfix (PID 60473)
    [INFO] I found the following pop3 server(s):
    Dovecot (PID 60520)
    [INFO] I found the following imap server(s):
    Dovecot (PID 60520)
    [INFO] I found the following ftp server(s):
    PureFTP (PID 60555)

    ##### LISTENING PORTS #####
    (only ()
    Local (Address)
    [localhost]:953 (60577/named)
    [anywhere]:25 (60473/master)
    [anywhere]:993 (60520/dovecot)
    [anywhere]:995 (60520/dovecot)
    [localhost]:10024 (60497/amavisd)
    [localhost]:9000 (48355/php-fpm:)
    [localhost]:10025 (60473/master)
    [anywhere]:3306 (60345/mysqld)
    [anywhere]:110 (60520/dovecot)
    [anywhere]:143 (60520/dovecot)
    ***.***.***.***:53 (60577/named)
    [localhost]:53 (60577/named)
    [anywhere]:21 (60555/pure-ftpd)
    [anywhere]:22 (21444/sshd)
    *:*:*:*::*:953 (60577/named)
    *:*:*:*::*:25 (60473/master)
    *:*:*:*::*:443 (62505/httpd)
    *:*:*:*::*:993 (60520/dovecot)
    *:*:*:*::*:995 (60520/dovecot)
    *:*:*:*::*:10024 (60497/amavisd)
    [localhost]10 (60520/dovecot)
    [localhost]43 (60520/dovecot)
    *:*:*:*::*:8080 (62505/httpd)
    *:*:*:*::*:80 (62505/httpd)
    *:*:*:*::*:8081 (62505/httpd)
    *:*:*:*::*:53 (60577/named)
    *:*:*:*::*:21 (60555/pure-ftpd)
    *:*:*:*::*:22 (21444/sshd)



    ...skipping one line

    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    ACCEPT all -- [anywhere]/0 [anywhere]/0 state RELATED,ESTABLISHED
    ACCEPT all -- [anywhere]/0 [anywhere]/0
    ACCEPT tcp -- [anywhere]/0 [anywhere]/0 tcp dpt:22 state NEW
    ACCEPT all -- [anywhere]/0 [anywhere]/0 state RELATED,ESTABLISHED
    REJECT all -- [anywhere]/0 [anywhere]/0 reject-with icmp-port-unreachable
    ACCEPT tcp -- [anywhere]/0 [anywhere]/0 tcp dpt:80
    ACCEPT tcp -- [anywhere]/0 [anywhere]/0 tcp dpt:443
    ACCEPT tcp -- [anywhere]/0 [anywhere]/0 tcp dpt:143
    ACCEPT tcp -- [anywhere]/0 [anywhere]/0 tcp dpt:993
    ACCEPT tcp -- [anywhere]/0 [anywhere]/0 tcp dpt:110
    ACCEPT tcp -- [anywhere]/0 [anywhere]/0 tcp dpt:995
    ACCEPT tcp -- [anywhere]/0 [anywhere]/0 tcp dpt:25
    ACCEPT tcp -- [anywhere]/0 [anywhere]/0 tcp dpt:465
    ACCEPT tcp -- [anywhere]/0 [anywhere]/0 tcp dpt:25
    ACCEPT tcp -- [anywhere]/0 [anywhere]/0 tcp dpt:8080
    ACCEPT tcp -- [anywhere]/0 [anywhere]/0 tcp dpt:8081
    ACCEPT tcp -- [anywhere]/0 [anywhere]/0 tcp dpt:143
    ACCEPT tcp -- [anywhere]/0 [anywhere]/0 tcp dpt:993
    ACCEPT tcp -- [anywhere]/0 [anywhere]/0 tcp dpt:22

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
    ACCEPT all -- [anywhere]/0 [anywhere]/0
    ACCEPT all -- [anywhere]/0 [anywhere]/0
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig is listening on port 8080, so it should be running.

    Did you try to access it by IP?

    https://yourip:8080

    Is your server behind a router?
     
  3. Luke Roughley

    Luke Roughley New Member

    Just tried ip address also and no access. The server is not behind a Router, its a cloud server if that makes any difference.

    Tried disabling iptables just now and still nothing. I am able to access port 80 and port 443 but when trying :8080 I get connection timed out.
     
  4. Luke Roughley

    Luke Roughley New Member

    I have just fixed the issue [WARN] I found no "submission" entry in your postfix master.cf

    With the port check warning about 465 not listening, how would I go about fixing this? I only need to offer secure mail from the server.

    I am currently working on the idea that this warning "[WARN] could not determine server's ip address by ifconfig" could have something to do with me not being able to access the webpage so I am looking into where my IP address is stored now.

    Here is my latest htr_report
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.0.5.4p8


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 5.4.16

    ##### PORT CHECK #####

    [WARN] Port 465 (SMTP server SSL) seems NOT to be listening

    ##### MAIL SERVER CHECK #####

    [WARN] I found no "smtps" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer SSL for smtp (not TLS) connections you have to enable this.

    ##### RUNNING SERVER PROCESSES #####

    [INFO] I found the following web server(s):
    Unknown process (httpd) (PID 19034)
    [INFO] I found the following mail server(s):
    Postfix (PID 18882)
    [INFO] I found the following pop3 server(s):
    Dovecot (PID 18929)
    [INFO] I found the following imap server(s):
    Dovecot (PID 18929)
    [INFO] I found the following ftp server(s):
    PureFTP (PID 18963)

    ##### LISTENING PORTS #####
    (only ()
    Local (Address)
    [localhost]:953 (18985/named)
    [anywhere]:25 (18882/master)
    [anywhere]:993 (18929/dovecot)
    [anywhere]:995 (18929/dovecot)
    [localhost]:10024 (18906/amavisd)
    [localhost]:9000 (48355/php-fpm:)
    [localhost]:10025 (18882/master)
    [anywhere]:3306 (18752/mysqld)
    [anywhere]:587 (18882/master)
    [anywhere]:110 (18929/dovecot)
    [anywhere]:143 (18929/dovecot)
    ***.***.***.***:53 (18985/named)
    [localhost]:53 (18985/named)
    [anywhere]:21 (18963/pure-ftpd)
    [anywhere]:22 (21444/sshd)
    *:*:*:*::*:953 (18985/named)
    *:*:*:*::*:25 (18882/master)
    *:*:*:*::*:443 (19034/httpd)
    *:*:*:*::*:993 (18929/dovecot)
    *:*:*:*::*:995 (18929/dovecot)
    *:*:*:*::*:10024 (18906/amavisd)
    *:*:*:*::*:587 (18882/master)
    [localhost]10 (18929/dovecot)
    [localhost]43 (18929/dovecot)
    *:*:*:*::*:8080 (19034/httpd)
    *:*:*:*::*:80 (19034/httpd)
    *:*:*:*::*:8081 (19034/httpd)
    *:*:*:*::*:53 (18985/named)
    *:*:*:*::*:21 (18963/pure-ftpd)
    *:*:*:*::*:22 (21444/sshd)




    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
     
  5. Luke Roughley

    Luke Roughley New Member

    IP-address (as per hostname): value is my IP address so I don't think this is the problem. I checked this by reading the htf-common-issues.php script and modifying the ANONYMIZE constant to false.
    Seems that it finds IP correctly by hostname.

    @till Just found something a little odd, firewall-cmd --state reports running, while systemctl status firewalld.service reports inactive(dead) masked. Is this normal?
     
  6. Luke Roughley

    Luke Roughley New Member

    Turns out there was ANOTHER firewall in front of my server I had no idea existed.

    I have configured this now and as soon as I did I was able to access the control panel. Lesson learned: Always check your hosts for additional firewalls.
     
    till likes this.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    I use mostly Debian and Ubuntu, so I can't tell you if thats normal. But for my understanding, this should not be the case or at least it does not make much sense to me.
     

Share This Page