Cant access ISPCONFIG after fresh install on Centos 6.5 and Centos 7

Discussion in 'Installation/Configuration' started by 360bladez, Feb 5, 2015.

  1. 360bladez

    360bladez New Member

    I originally had ispconfig installed on this server but wanted to do a fresh install
    I have successfully installed Perfect server centos 6.5 more then 10 times, But for some reason I just cant get it to work now. It was the only reason I switched to centos7, which I am now the same issue with.

    I can install the ubuntu 14.04 and it works fine I just really like my centos 6.5 and really want to get it working

    https://www.howtoforge.com/perfect-...hp-pureftpd-postfix-dovecot-and-ispconfig3-p3
    https://www.howtoforge.com/perfect-...hp-pureftpd-postfix-dovecot-and-ispconfig3-p3

    I can access ispconfig on 2 different installs - both go to
    Unable to connect

    Firefox can't establish a connection to the server at x.x.x.x:8080.
    going just to the ip gives me the apache page
    Testing 123.

    The site could be temporarily unavailable or too busy. Try again in a few moments.
    If you are unable to load any pages, check your computer's network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.



    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.0.5.4p5


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 5.4.16

    ##### PORT CHECK #####

    [WARN] Port 8080 (ISPConfig) seems NOT to be listening
    [WARN] Port 8081 (ISPConfig Apps) seems NOT to be listening
    [WARN] Port 80 (Webserver) seems NOT to be listening
    [WARN] Port 443 (Webserver SSL) seems NOT to be listening
    [WARN] Port 143 (IMAP server) seems NOT to be listening
    [WARN] Port 993 (IMAP server SSL) seems NOT to be listening
    [WARN] Port 110 (POP3 server) seems NOT to be listening
    [[email protected] install]# iptables -L
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
    [[email protected] install]# ^C
    [[email protected] install]# ^C
    [[email protected] install]# iptables -f
    iptables v1.4.21: no command specified
    Try `iptables -h' or 'iptables --help' for more information.
    [[email protected] install]# iptables -F
    [[email protected] install]# wget -q -O htf-common-issues.php "http://gitplace.net/pixcep t/ispconfig-tools/raw/stable/htf-common-issues.php" && php -q htf-common-issues. php
    sh: netstat: command not found

    ##### SCRIPT FINISHED #####
    Results can be found in htf_report.txt
    To view results use your favourite text editor or type 'cat htf_report.txt | mor e' on the server console.

    If you want to see the non-anonymized output start the script with --debug as pa rameter (php -q htf-common-issues.php --debug).

    [[email protected] install]# cat htf_report.txt | more

    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.0.5.4p5


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 5.4.16

    ##### PORT CHECK #####

    [WARN] Port 8080 (ISPConfig) seems NOT to be listening
    [WARN] Port 8081 (ISPConfig Apps) seems NOT to be listening
    [WARN] Port 80 (Webserver) seems NOT to be listening
    [WARN] Port 443 (Webserver SSL) seems NOT to be listening
    [WARN] Port 143 (IMAP server) seems NOT to be listening
    [WARN] Port 993 (IMAP server SSL) seems NOT to be listening
    [WARN] Port 110 (POP3 server) seems NOT to be listening
    [WARN] Port 995 (POP3 server SSL) seems NOT to be listening
    [WARN] Port 25 (SMTP server) seems NOT to be listening
    [WARN] Port 465 (SMTP server SSL) seems NOT to be listening
    [WARN] Port 21 (FTP server) seems NOT to be listening
    [WARN] Port 22 (SSH server) seems NOT to be listening
    [WARN] Port 25 (SMTP server) seems NOT to be listening

    ##### MAIL SERVER CHECK #####

    [WARN] I found no "submission" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer port 587 for smtp connections you have to enable this.
    [WARN] I found no "smtps" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer SSL for smtp (not TLS) connections you have to enable this.

    ##### RUNNING SERVER PROCESSES #####

    [WARN] I could not determine which web server is running.
    [WARN] I could not determine which mail server is running.
    [WARN] I could not determine which pop3 server is running.
    [WARN] I could not determine which imap server is running.
    [WARN] I could not determine which ftp server is running.

    ##### LISTENING PORTS #####




    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    I also ran that script on my working centos install
    I dont understand why I have a lot of info on my listening ports and nothing on this vps.
     
    Last edited: Feb 6, 2015
  2. sobertillnoon

    sobertillnoon New Member

  3. 360bladez

    360bladez New Member

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The servicel like apache, postfix and dovecot does not seem to be started. try to start or restart them.
     
  5. sanahayat

    sanahayat New Member

    Hi I am facing similar issues too. I installed Ispconfig 3 on CentOS 7 Minimal install by following the tutorial here https://www.howtoforge.com/perfect-server-centos-7-x86_64-nginx-dovecot-ispconfig-3 and I followed all the steps as is, but I am not able to open the Ispconfig's login page. It does not show up at all. here is the IP address https://23.229.4.244:8080/

    This is how the installation ends

    Email Address []:[email protected]
    Configuring Mailman
    Configuring SASL
    Configuring PAM
    Configuring Courier
    Configuring Spamassassin
    Configuring Amavisd
    Configuring Getmail
    Configure Jailkit (y,n) [y]: y

    Configuring Jailkit
    Configure FTP Server (y,n) [y]: y

    Configuring Pureftpd
    Configure DNS Server (y,n) [y]: y

    Configuring MyDNS
    Configure Firewall Server (y,n) [y]: y

    Configuring Bastille Firewall
    Install ISPConfig Web Interface (y,n) [y]: y

    Installing ISPConfig
    ISPConfig Port [8080]: 8080

    Enable SSL for the ISPConfig web interface (y,n) [y]: y

    Generating RSA private key, 4096 bit long modulus
    ********************
    writing RSA key
    Configuring DBServer
    Installing ISPConfig crontab
    Installation completed.
    [[email protected] install]#

    It does not show up anything as shown in your tutorial as below
    Email Address []:<-- ENTER
    Configuring Jailkit
    Configuring Dovecot
    Configuring Spamassassin
    Configuring Amavisd
    Configuring Getmail
    Configuring Pureftpd
    Configuring BIND
    Configuring nginx
    Configuring Vlogger
    Configuring Apps vhost
    Configuring Bastille Firewall
    Configuring Fail2ban
    Installing ISPConfig
    ISPConfig Port [8080]:<-- ENTER
     
    Last edited: Feb 22, 2015
  6. till

    till Super Moderator Staff Member ISPConfig Developer

  7. sanahayat

    sanahayat New Member

    Thanks till for your comment, I tried the default install too that was also missing a lot of the things mentioned in your tutorial, but for a quick solution I changed the OS from centOS 7 to Debian Wheezy and the install is working for me on Debian Wheezy 7. But thanks for this wonderful panel and support...
     
  8. kephra

    kephra Member

    I too had similar problems installing ispconfig on CentOS Linux release 7.1.1503 (Core)
    As soon as I installed jailkit and fail2ban, I could no longer access the server via ssh.
    I reinstalled from scratch with a fresh Centos 7.1, but did not install jailkit and fail2 ban. This time ispconfig worked UNTIL I enabled the firewall in Ispconfig.... then I was locked out again. Using the VNC login, I cleared the firewall tables, and then i could again access via ssh. But every time I enabled the firewall in Ispconfig, the firewall locked me out of everything. My Centos 6.5 installs worked perfectly.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you stop and disable the centos 7 firewall before you installled ispconfig? The cents firewall is active by default, if you dont stop and disable this firewall, then you have 2 active firewalls at the same time and this will block all connections to your server.
     
  10. kephra

    kephra Member

    Yes, I did exactly as the HowTo said. I tried it a total of three times starting with a fresh Centos install, and each time the same thing happened. I checked to make sure firewalld was not running and was disabled also.
    To make it useable, I cleared the firewall, turned it off in Ispconfig, then used system-config-firewall-tui to set it up.

    Other aspects of the install did not work right either, which I will post in a separate topic.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    I used the tutorial to install a server for a customer last week, the server worked fine without any modifications.
     
  12. kephra

    kephra Member

    Well, I started again today with another fresh install of Centos 7.1, followed to HowTo to the letters.
    After installing Ispconfig, I enabled the Ispconfig firewall and once again, port 80 was locked out. I had to disable the firewall via my VNC to regain access to the Ispconfig panel. This has happened every time to me. This time I left the Ispconfig firewall disabled and configured the ports with system-config-firewall tool.
    Also, the system won't send email because spamd is not running, and unless I missed it every time, it is not enabled and started in the tutorial. Amavisd is enabled and started though.
    Oh, and since I couldn't use the provided firewall, I did not install fail2ban, as that seems to make use of iptable chains that I did not know how to configure.
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig does not use spamd. Spamd has to be stopped on a ispconfig server as ispconfig uses amavisd for spam scanning.


    Regarding the firewall, try to run:
    Code:
    systemctl stop firewalld
    systemctl mask firewalld
    yum install iptables-services
    systemctl enable iptables
    systemctl start iptables
     
  14. kephra

    kephra Member

    iptables was already running on my system
    My fault about the spamd. I see spamd is not running on my Centos 6.5 system which has always worked perfectly. So I disabled the spamassassin server on both my 7.1 machines.
    Another issue that was my fault was that port 25 was blocked at the firewall. Once I fixed that, email worked fine. So the only thing that didn't work according to plan was the Ispconfig firewall, and that was an easy work around.
    Thanks.
     

Share This Page