Cannt login to proftpd

Discussion in 'Installation/Configuration' started by Lellel, Feb 21, 2007.

  1. Lellel

    Lellel New Member

    Hi!
    Im on Ubuntu Edgy version. And really with linux. And behind a NAT. (dLink of some kind.)

    I have followed the "perfect server setup" and installed isp-config. Everything works ok now, except porftpd.
    When I try to login to ftp://lellel.net/web it takes forever before I get the "login window". (im trying to connect via firefox).
    When i finally have entered the users login name and password, absolutely nothing happens.
    I have checked that FTPis enabled for the site, and that the user has FTP access in ISP-C.

    Heres my proftpd.conf:

    Code:
    Include /etc/proftpd/modules.conf
    
    ServerName			"Debian"
    ServerType			standalone
    DeferWelcome			off
    
    MultilineRFC2228		on
    DefaultServer			on
    ShowSymlinks			on
    
    TimeoutNoTransfer		600
    TimeoutStalled			600
    TimeoutIdle			1200
    
    DisplayLogin                    welcome.msg
    DisplayFirstChdir               .message
    ListOptions                	"-l"
    
    DenyFilter			\*.*/
    
    Port				21
    
    PassivePorts                    60000 60100
    
    MaxInstances			30
    
    User				proftpd
    Group				nogroup
    
    Umask				022  022
    AllowOverwrite			on
    
    
    TransferLog /var/log/proftpd/xferlog
    SystemLog   /var/log/proftpd/proftpd.log
    
    <IfModule mod_tls.c>
    TLSEngine off
    </IfModule>
    
    <IfModule mod_quota.c>
    QuotaEngine on
    </IfModule>
    
    <IfModule mod_ratio.c>
    Ratios on
    </IfModule>
    
    
    <IfModule mod_delay.c>
    DelayEngine on
    </IfModule>
    
    <IfModule mod_ctrls.c>
    ControlsEngine        on
    ControlsMaxClients    2
    ControlsLog           /var/log/proftpd/controls.log
    ControlsInterval      5
    ControlsSocket        /var/run/proftpd/proftpd.sock
    </IfModule>
    
    <IfModule mod_ctrls_admin.c>
    AdminControlsEngine on
    </IfModule>
    
    MasqueradeAddress lellel.net
    
    DefaultRoot ~
    
    Include /etc/proftpd_ispconfig.conf
    And some errors from /var/log/proftpd/proftpd.log

    Code:
    Feb 20 23:53:40 server.lellel.net proftpd[24318] server.lellel.net (c-6eb9e455.87-0127-74657210.cust.bredbandsbolaget.se[::ffff:85.228.185.110]): USER web1_test: Login successful.
    Feb 20 23:53:40 server.lellel.net proftpd[24318] server.lellel.net (c-6eb9e455.87-0127-74657210.cust.bredbandsbolaget.se[::ffff:85.228.185.110]): Preparing to chroot to directory '/var/www/web1'
    Feb 20 23:53:40 server.lellel.net proftpd[24318] server.lellel.net (c-6eb9e455.87-0127-74657210.cust.bredbandsbolaget.se[::ffff:85.228.185.110]): error setting IPV6_V6ONLY: Protocol not available
    Feb 20 23:53:40 server.lellel.net proftpd[24318] server.lellel.net (c-6eb9e455.87-0127-74657210.cust.bredbandsbolaget.se[::ffff:85.228.185.110]): SECURITY VIOLATION: Passive connection from ::ffff:192.168.0.185 rejected.
     
  2. Jorem

    Jorem New Member

    Maybe you can try without the last line in de config file.

    Include /etc/proftpd_ispconfig.conf (delete this one for testing)

    Ad two lines to the config file:

    IdentLookups off
    UseReverseDNS off

    Try your ftp client with active mode instead of passive mode.
     
  3. Lellel

    Lellel New Member

    Thanks for your reply Jorem!

    Im sorry to say, that the problem is still the same. =(

    Is there a way to disable IPV6?

    proftpd.log

    Code:
    Feb 21 13:42:35 server.lellel.net proftpd[5651] server.lellel.net (::ffff:85.228.185.110[::ffff:85.228.185.110]): USER web1_test: Login successful.
    Feb 21 13:42:35 server.lellel.net proftpd[5651] server.lellel.net (::ffff:85.228.185.110[::ffff:85.228.185.110]): Preparing to chroot to directory '/var/www/web1'
    Feb 21 13:42:35 server.lellel.net proftpd[5651] server.lellel.net (::ffff:85.228.185.110[::ffff:85.228.185.110]): error setting IPV6_V6ONLY: Protocol not available
    Feb 21 13:42:35 server.lellel.net proftpd[5651] server.lellel.net (::ffff:85.228.185.110[::ffff:85.228.185.110]): error setting IPV6_V6ONLY: Protocol not available
    Feb 21 13:42:35 server.lellel.net proftpd[5651] server.lellel.net (::ffff:85.228.185.110[::ffff:85.228.185.110]): SECURITY VIOLATION: Passive connection from ::ffff:192.168.0.185 rejected
     
  4. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

  5. Lellel

    Lellel New Member

    Thanks for you reply martinst! :)

    But that that didnt help me. :(
    Any other suggestions?

    Code:
    Feb 21 15:09:18 server.lellel.net proftpd[5719] server.lellel.net (::ffff:85.228.185.110[::ffff:85.228.185.110]): and any router, NAT, and firewall rules in the network path.
    Feb 21 15:09:18 server.lellel.net proftpd[5719] server.lellel.net (::ffff:85.228.185.110[::ffff:85.228.185.110]): FTP no transfer timeout, disconnected
    Feb 21 15:09:18 server.lellel.net proftpd[5719] server.lellel.net (::ffff:85.228.185.110[::ffff:85.228.185.110]): ProFTPD terminating (signal 11)
    Feb 21 15:09:18 server.lellel.net proftpd[5719] server.lellel.net (::ffff:85.228.185.110[::ffff:85.228.185.110]): FTP session closed.
    Feb 21 15:09:18 server.lellel.net proftpd[5927] server.lellel.net (::ffff:85.228.185.110[::ffff:85.228.185.110]): error setting IPV6_V6ONLY: Protocol not available
    Feb 21 15:09:28 server.lellel.net proftpd[5927] server.lellel.net (::ffff:85.228.185.110[::ffff:85.228.185.110]): FTP session opened.
    Feb 21 15:09:28 server.lellel.net proftpd[5927] server.lellel.net (::ffff:85.228.185.110[::ffff:85.228.185.110]): mod_delay/0.5: delaying for 46 usecs
    Feb 21 15:09:28 server.lellel.net proftpd[5927] server.lellel.net (::ffff:85.228.185.110[::ffff:85.228.185.110]): USER web1_test: Login successful.
    Feb 21 15:09:28 server.lellel.net proftpd[5927] server.lellel.net (::ffff:85.228.185.110[::ffff:85.228.185.110]): Preparing to chroot to directory '/var/www/web1'
    Feb 21 15:09:28 server.lellel.net proftpd[5927] server.lellel.net (::ffff:85.228.185.110[::ffff:85.228.185.110]): error setting IPV6_V6ONLY: Protocol not available
    Feb 21 15:09:28 server.lellel.net proftpd[5927] server.lellel.net (::ffff:85.228.185.110[::ffff:85.228.185.110]): SECURITY VIOLATION: Passive connection from ::ffff:192.168.0.185 rejected.
     
  6. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Oke, let's focus on disabling IPv6. That's what you want to do 1st, right? What's the output of
    Code:
    ifconfig
     
  7. Lellel

    Lellel New Member

    I dont know what i want to do first, you tell me! :)
    If disabeling IPV6 is the first step to get porftpd to work, ill surly want to do it! :D
    Thanks for your help!

    Heres the the output of ipconfig:

    Code:
    root@server:/home/daniel# ipconfig
    bash: ipconfig: command not found
    root@server:/home/daniel# ifconfig
    eth1      Link encap:Ethernet  HWaddr 00:50:8D:67:ED:4D  
              inet addr:192.168.0.164  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::250:8dff:fe67:ed4d/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:20480 errors:0 dropped:0 overruns:0 frame:0
              TX packets:20940 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:1951748 (1.8 MiB)  TX bytes:4109119 (3.9 MiB)
              Interrupt:185 Base address:0xb000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:38622 errors:0 dropped:0 overruns:0 frame:0
              TX packets:38622 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:4680421 (4.4 MiB)  TX bytes:4680421 (4.4 MiB)
    
    vmnet1    Link encap:Ethernet  HWaddr 00:50:56:C0:00:01  
              inet addr:192.168.108.1  Bcast:192.168.108.255  Mask:255.255.255.0
              inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:65 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
    
    vmnet8    Link encap:Ethernet  HWaddr 00:50:56:C0:00:08  
              inet addr:192.168.53.1  Bcast:192.168.53.255  Mask:255.255.255.0
              inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:65 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
     
  8. Hans

    Hans Moderator ISPConfig Developer

    Hi,

    If your FTP_client transfers files within "Passive mode", please turn it off.

    You can also add these lines within your proftpd.conf file:

    IdentLookups off
    UseReverseDNS off
     
    Last edited: Feb 21, 2007

Share This Page