Cannot send emails

Discussion in 'Installation/Configuration' started by statiic, Nov 12, 2006.

  1. statiic

    statiic New Member

    Somehow my email clients do receive emails, but they cannot send. It doesnt give any errors. It also says that the message has been send, but I dont receive anything.

    I checked the /var/log/mail/ dir and I only could find 3 files called: info,warnings,errors.
    But the last 2 where empty. So no errors I think.

    And the info file tells me the following:
    connect to[]: No route to host (port 25)

    I have an server back home at the moment behind my router. And yes the firewall and the router ports are open.

    Any suggestions??
    Last edited: Nov 12, 2006
  2. statiic

    statiic New Member

    Some extra info:

    This is what I get from dns reports:

    Mail server host name in greeting
    WARNING: One or more of your mailservers is claiming to be a host other than what it really is (the SMTP greeting should be a 3-digit code, followed by a space or a dash, then the host name). If your mailserver sends out E-mail using this domain in its EHLO or HELO, your E-mail might get blocked by anti-spam software. This is also a technical violation of RFC821 4.3 (and RFC2821 4.3.1). Note that the hostname given in the SMTP greeting should have an A record pointing back to the same server. Note that this one test may use a cached DNS record. claims to be non-existent host
    220 ESMTP Postfix (2.3.3) (Mandriva Linux)
  3. edge

    edge Active Member Moderator

    Try sending to a none hotmail account to see if it's working.
    Also.. For sending to hotmail you will need a SPF record!
  4. statiic

    statiic New Member

    I tryed sending to as well. Same problem.
    No route to host (port 25)

    And whats an SPF record?? How do I get it
  5. statiic

    statiic New Member

    I found this SPF thing, but I dont understand the wizard. I have no clue what to fill in.

    I just installed an server with the perfect setup for Mandriva 2007. my domain is and another one is
    both pointing to the same website.

    And do I need to do this wizard for each client I create which has its own domain name?? ~all"&use_built_from_args=1
  6. statiic

    statiic New Member

    K I went to my ispconfig panel.

    Then DNS Manager -> Then clicked on -> Tab records -> new SPF

    The it gives me an few fields. This is what I filled in:

    hostname: server1
    emails sent A record : yes
    emails sent mx record : yes
    emails sent all servers: yes
    other a records: left it blank
    other mx records: left it blank
    other ip adresses: left it blank
    contain all hosts: yes

    save. And it still doesnt work. BTW I can send emails to another internal email account.
  7. statiic

    statiic New Member

    K it seems that it succesfully sents emails to another email provider besides and

    But how can I set these SPF settings properly in ispconfig so I can sent to hotmail also?
  8. edge

    edge Active Member Moderator

    I'm not sure how this is done when you are using a DNS that is not on your system, but I think that you will have to ask "" to set a SPF for your MX.

    Hotmail is a problem.. Even if you have a correct SPF! Your setup needs to be 100% okay (like revers DNS lookup, and more..)
    A nice way to see if your SPF is "okay" is by sending emails to a Gmail account.

    If you look at the headers of the email that you have send to a Gmail account you will see a lot of info about the "Received-SPF:"

    Veel succes er mee!
    Last edited: Nov 12, 2006
  9. statiic

    statiic New Member

    Same problem with gmail. It gives me the same error.
    And I tryed to figure out this wizard. But I have no clue how to setup it properly. It seems that it isnt setup properly else gmail would except my email at least ;)
  10. edge

    edge Active Member Moderator

    Again.. I think a SPF record that is setup on your system will not work when using a DNS that is not on your system.. (but I could be wrong!)

    This is how Gmail will reply when the SPF is correct.
    (please note that I have changed the mydomain.tld and the IP)
    This is how it looks when NO SPF or a BAD SPF is used:
    Last edited: Nov 12, 2006
  11. edge

    edge Active Member Moderator

    My SPF record for a working domain is set like this

    Hostname: {empty}
    Are emails sent from A record?: Yes
    Are emails sent from MX Record?: Yes
    Are emails sent from all server of this domain?: No
    Are emails sent from other A Records?: {empty}
    Are emails sent from other MX Records?: {empty}
    Are emails sent from other IP addresses?: {empty}
    Inherit SPF Record from this zone?: {empty}
    Do the above entries contain all hosts allowed to send emails for this domain?: No
  12. statiic

    statiic New Member

    Yes, but I cannot receive any mails in gmail from my mailserver. So I have no clue if they are fine or not ;)

    And I contacted my domain provider about this SPF.

    Another thing.

    The dns servers are from and my domain is registered at

    which SPF do I need ;)
    I putted the DNS of eweka there, because they are gonna recolocate my server soon ;)
  13. edge

    edge Active Member Moderator

    An other one from Eweka. (like me). My servers are allready in the new data center :)
  14. statiic

    statiic New Member

    Edge could you send me an email ;)

    I will send you an pm.

Share This Page