Cannot send email from OE through ISPconfig site

Discussion in 'General' started by tomd, Sep 24, 2006.

  1. tomd

    tomd New Member

    I have setup an Ubuntu 6.06/ISPConfig server using Falko's excellent howto and the the ISPConfig installation guide (which is also excellent) and all has been working well. I can send and recieve email through the webmail interface and recieve mail with Outlook Express. My problem comes in sending email through Outlook Express. I get this response:

    This area's largest DSL provider blocks port 25 - and I am testing from that provider's service. So I suspect my access to the server is being blocked. Plus, I cannot see any evidence of a login attempt in the server logs. The provider says that I should access any off-network mail server using port 587, but if I change the smpt port from 25 to 587 (in OE) I get this:
    Is it possible to send email through the ISPConfig based domain's email server from outside its network?
     
  2. falko

    falko Super Moderator

    Yes, that's right.

    What's in /etc/postfix/master.cf?
     
  3. tomd

    tomd New Member

    Code:
    #
    # Postfix master process configuration file.  For details on the format
    # of the file, see the Postfix master(5) manual page.
    #
    # ==========================================================================
    # service type  private unpriv  chroot  wakeup  maxproc command + args
    #               (yes)   (yes)   (yes)   (never) (100)
    # ==========================================================================
    smtp      inet  n       -       -       -       -       smtpd
    #submission inet n      -       -       -       -       smtpd
    #       -o smtpd_etrn_restrictions=reject
    #       -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #smtps    inet  n       -       -       -       -       smtpd
    #  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
    #submission inet n      -       -       -       -       smtpd
    #  -o smtpd_etrn_restrictions=reject
    #  -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
    #628      inet  n       -       -       -       -       qmqpd
    pickup    fifo  n       -       -       60      1       pickup
    cleanup   unix  n       -       -       -       0       cleanup
    qmgr      fifo  n       -       n       300     1       qmgr
    #qmgr     fifo  n       -       -       300     1       oqmgr
    tlsmgr    unix  -       -       -       1000?   1       tlsmgr
    rewrite   unix  -       -       -       -       -       trivial-rewrite
    bounce    unix  -       -       -       -       0       bounce
    defer     unix  -       -       -       -       0       bounce
    trace     unix  -       -       -       -       0       bounce
    verify    unix  -       -       -       -       1       verify
    flush     unix  n       -       -       1000?   0       flush
    proxymap  unix  -       -       n       -       -       proxymap
    smtp      unix  -       -       -       -       -       smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay     unix  -       -       -       -       -       smtp
            -o fallback_relay=
    #       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq     unix  n       -       -       -       -       showq
    error     unix  -       -       -       -       -       error
    discard   unix  -       -       -       -       -       discard
    local     unix  -       n       n       -       -       local
    virtual   unix  -       n       n       -       -       virtual
    lmtp      unix  -       -       -       -       -       lmtp
    anvil     unix  -       -       -       -       1       anvil
    scache    unix  -       -       -       -       1       scache
    #
    # ====================================================================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent.  See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ====================================================================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop  unix  -       n       n       -       -       pipe
      flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    uucp      unix  -       n       n       -       -       pipe
      flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # Other external delivery methods.
    #
    ifmail    unix  -       n       n       -       -       pipe
      flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp     unix  -       n       n       -       -       pipe
      flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
    scalemail-backend unix  -       n       n       -       2       pipe
      flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
    mailman   unix  -       n       n       -       -       pipe
      flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
      ${nexthop} ${user}
    
     
  4. fobicodam

    fobicodam ISPConfig Developer

  5. falko

    falko Super Moderator

    Please comment out these two lines in your master.cf:

    Code:
    #smtps    inet  n       -       -       -       -       smtpd
    #  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
    and restart Postfix. It will make Postfix listen on port 465.
     
  6. tomd

    tomd New Member

    You are the master.

    Since those lines were already commented, I think you meant to say "uncomment" rather that "comment out". (I removed the hash marks) But that did the trick and I was able to send from DSL and Cable providers.

    Your Howto guides are outstanding. Thank you for this site!

    Tom
     
  7. falko

    falko Super Moderator

    Yes, right. Sorry about that.
     
  8. tomd

    tomd New Member

    No probem. I just love the clarity of your guidance. Instead of answering "Just turn on smpts" you give the details that I can learn from. Because of the clarity of the instructions, I could easily see where the intention was reversed. Thank you again.
     
  9. ryan_vanks

    ryan_vanks New Member

    Same issue but socket Error

    Hello
    I experience the same issue using Postfix on UBUNTU 6.06.
    I can receive messages using OE but I'm unable to send them.

    This is the error I got:

    "Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: 'mail.geoaec.com', Server: 'smtp.geoaec.com', Protocol: SMTP, Port: 25, Secure(SSL): No, Socket Error: 10053, Error Number: 0x800CCC0F"

    Microsoft Winsock REF : Error 10053 (DB-Library)
    Severity Level 2
    Message Text: Attempt to bulk copy a null value into a server column that does not accept null values.


    How do I fix that issue?

    Thanks
     
  10. edge

    edge HowtoForge Supporter

    Thats the same error as the person who started this thread.
    The problem is that also your ISP is blocking port 25.
    The way you can fix this is the exact same way as he did (that is if your ISP did not close port 465)
    Read "falko's" reply. You will need to set OE's SMTP port to 465.
     
  11. hsluis

    hsluis New Member

    Thanks...

    Hello Falko,

    To work with SSL in ISPConfig, or under firewall you need activate the nexts ports:

    IMAPSSL 993 tcp yes
    SMTPDSSL 465 tcp yes
    POP3SSL 995 tcp yes

    I worked, read, and practiced hard the last nights, to doing it. I'm had problem to access to IMAP SSL, I bad thinking are a problem of openssl or courier imap, but not, my problem are the firewall... I solved now...

     

Share This Page