cannot see server1.example.com

Discussion in 'Installation/Configuration' started by braakiss, Dec 19, 2006.

  1. braakiss

    braakiss New Member

    Hi,
    I have just finished the installation of ISPConfig in Fedora Core 6 following this tutorial http://www.howtoforge.com/installing_a_lamp_system_with_fedora_core_6
    I have not had any problem until the end of the installation when it asks for this data:
    Please enter your MySQL server: localhost
    Please enter your MySQL user: root
    Please enter your MySQL password: Mypassword
    Please enter a name for the ISPConfig database: ispconfigdb
    Please enter the IP address of the ISPConfig web: 192.168.202.100
    Please enter the host name: E.g. server1
    Please enter the domain: E.g. example.com
    Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system: I have chosen with SSL

    Those are what I have filled in. Then If I open the firefox and write https://server1.example.com:81 or https://192.168.202.100:81, Should it work, shouldn't it?
    But Firefox do not find the address.
    Where can I change the data from above to do more tries? I would like to remove SSL encryption in case it is the problem.

    Thank in advance
    I hope you can help me.

    PS: I have not very good english I expect you can understand me :)
     
    Last edited: Dec 19, 2006
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Dns

    Well, your browser should be able to find example.com in YOUR DNS servers. So, if you have a local DNS server, add this domain.

    Otherwise, edit your local 'hosts' file (on your client) and add example.com. Be warned, example.com is a valid domain name.

    Personally I run a local bind9 server which handles all my (test) domains. For systems on my own LAN, I add these to a domain something like myhomelan.loc.
    .loc is not a valid tld so that does not interfere with the official dns servers. And make sure the clients on your local lan use your own dns server(s) as their only dnsserver.

    A tutorial about setting up your own dns sever can be found somewhere .....
     
  3. braakiss

    braakiss New Member

    I think DNS works well

    I think DNS works well. If I write in firefox http://server1.example.com or http://192.168.202.100 it shows Apache web, with https:// and without it.
    I think the problem is SSL because I made the same instalation in another vmware virtual machine without SSL and it worked properly, I can see http://server1.example.com:81.
    May be in first configuration of ISPConfig I filled in a wrong IP :confused: .How can I change it?
    any idea else?
    I forgot to mention that I am using vmware virtual machine with NAT
    thank again

    edit: I have tried "telnet server1.example.com 81" and it does not work "connection refused". does it mean ispconfig server is down?
    with /etc/init.d/ispconfig_server restart it says:"ISPConfig system is now up and running"
    If I write "nestat -tap" which line refers to ispconfig?
     
    Last edited: Dec 20, 2006
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    What is the output of:

    netstat -tap

    and

    iptables -L
     
  5. braakiss

    braakiss New Member

    Hi till,
    netstat -tan
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State
    tcp 0 0 127.0.0.1:2208 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:56723 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:949 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN
    tcp 1 0 192.168.202.100:38898 152.3.220.166:80 CLOSE_WAIT
    tcp 0 0 :::993 :::* LISTEN
    tcp 0 0 :::995 :::* LISTEN
    tcp 0 0 :::110 :::* LISTEN
    tcp 0 0 :::143 :::* LISTEN
    tcp 0 0 :::80 :::* LISTEN
    tcp 0 0 :::21 :::* LISTEN
    tcp 0 0 ::1:53 :::* LISTEN
    tcp 0 0 :::22 :::* LISTEN
    tcp 0 0 ::1:631 :::* LISTEN
    tcp 0 0 ::1:953 :::* LISTEN
    tcp 0 0 :::443 :::* LISTEN

    and iptables -L

    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    thank

    oops I have just realized this post is not under ispconfig forum, sorry. Could someone move it there? thank
     
    Last edited: Dec 20, 2006
  6. falko

    falko Super Moderator ISPConfig Developer

    The command is
    Code:
    netstat -tap
    , not
    Code:
    netstat -tan
    . Anyway, it seems as if ISPConfig isn't running. Please restart it:

    Code:
    /etc/init.d/ispconfig_server restart
     

Share This Page