Cannot resolve IPs after ISPconfig3 install.

Discussion in 'Installation/Configuration' started by jseedev, Mar 21, 2010.

  1. jseedev

    jseedev New Member

    Hello,

    I've just finished installing ISPconfig3 for the first time on my CentOS 5.4 box. Although the installation process (followed the "Perfect Server" guide) was successful and I'm able to login, my server seems to have lost the ability to resolve any IPs.

    Code:
    [[email protected] etc]# dig yahoo.com
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.2 <<>> yahoo.com
    ;; global options:  printcmd
    ;; connection timed out; no servers could be reached
    
    My /etc/resolv.conf was not modified? Any ideas?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that the dns Servers in /etc/resolv.conf are reachable.
     
  3. jseedev

    jseedev New Member

    Ok, got that knocked out now. The only problem I'm having now is apache throwing this error:
    Code:
    Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8) at /usr/local/ispconfig/server/scripts/vlogger line 147.
    
    I remember when going through the setup guide, it mentions using yum to install perl-DateTime-Format-HTTP and perl-DateTime-Format-Builder - but I always get "No packages available."
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You seem to have missed this from step 19 of the tutorial:

    yum install webalizer perl-DateTime-Format-HTTP perl-DateTime-Format-Builder

    If the packages are not available, then there must be a repository missing. Please check the repository configuration again.
     
  5. jseedev

    jseedev New Member

    You were correct. I added the DAG repository and was able to install the needed packages. You're the man, till. Any idea why courier can't chdir to the mail directory? This was an account created through ISP config ([email protected])

    Code:
    Mar 22 12:09:57 dedi144 pop3d: chdir /var/vmail/mydomain.com/admin: Permission denied
    The directory does indeed exist on the server.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    - Please check in the monitor if there are any jobs in the jobqueue.
    - Which ispconfig version do you have installed? if its not 3.0.2.1, I recommend to run the command:

    ispconfig_update.sh as root on the shell to update to the latest release.
     
  7. jseedev

    jseedev New Member

    -Nope, nothing in the jobqueue.
    -Yes, I'm running the latest release of ISPConfig
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    ls -la /var/vmail
     
  9. jseedev

    jseedev New Member

    Here it is:
    Code:
    total 24
    drwxr-xr-x  4 root root 4096 Mar 21 15:27 .
    drwxr-xr-x 27 root root 4096 Mar 20 15:32 ..
    drwxr-xr-x  3 root root 4096 Mar 21 15:27 mydomain.com
    -rw-------  1 root root 1382 Mar 20 15:32 .mailfilter
    drwxr-xr-x  2 root root 4096 Mar 20 15:32 mailfilters
    
    Thanks for your help.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    The files and folders are owned by the wrong user.

    - Did you had any errors during ispconfig install?
    - Please post the output of:

    grep vmail /etc/passwd
    grep vmail /etc/group

    - Any errors in the system log in the ispconfig monitor?
     
  11. jseedev

    jseedev New Member

    - Neither command had any output.
    Code:
    > grep vmail /etc/group
    > grep vmail /etc/passwd
    
    - No errors while installing.
    - Systemlog has no errors.
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, then ispconfig is not installed properly. I recommend that you do an ispconfig update by using the manual update instruction that can be found here:

    http://www.howtoforge.com/forums/showthread.php?t=44277

    choose yes when you get asked if the services shall be reconfigured. Afterwards test again with the grep commands.

    Please ensure that you are logged in with the Linux root user when you start the update and do not use sudo.
     
  13. jseedev

    jseedev New Member

    Here are the only errors produced after running update.php:
    Code:
    chown: `ispapps:ispapps': invalid user
    chown: `getmail': invalid user
    
     
  14. jseedev

    jseedev New Member

    After running the update, the 2 'grep' commands still have no output. I actually cannot logon to the server as root (this is a remote dedicated server). I have to login with another account and use 'su -' to preform actions as root. Would this be the cause of the problem?
     
  15. jseedev

    jseedev New Member

    Created the user and group vmail with the proper UID/GID. Deleted all mail accounts and readded them. All is good now. Thanks for all the help.
     

Share This Page