Cannot remove, move, rename web folder even after removing immutable bit

Discussion in 'General' started by Etcetera, Nov 1, 2021.

  1. Etcetera

    Etcetera Member HowtoForge Supporter

    See here and here.
    Till's last answer in which he also closed the original thread ignored my original post in which I made clear that I did chattr -i on the web user's directory...
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    It should work. Like I wrote in the previous thread, show the exact commands issued and the resulting error messages. Use cut and paste in CODE tags.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Chattr always works as long as you use the path to the correct website and of course, the correct path (which is not the web folder or private folder, it is the website root which is a folder where these folders are in, see the other thread for the exact command to be used. You also can't use symlinked paths like the domain name, use the exact commands from my example and just exchange client ID and website ID). If it does not work, then you initially posted in the wrong thread as the issue is not related to ISPConfig and it's folder protection then. The thread I closed contains the full answer to the question of the original poster and there is nothing to be added and the thread should not be cluttered with other unrelated posts.
    Last edited: Nov 1, 2021
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    That's what I mentioned above, you used the wrong path (web subdirectory instead of the root directory of the site) and that's why it did not work. The correct path in your case is:

    sudo chattr -i /var/www/clients/client1/web55
  5. Etcetera

    Etcetera Member HowtoForge Supporter

    Thanks! That was my mistake in trying to reproduce the issue, which I noticed myself and which is why I retracted my post. It indeed works now with the correct path. I'm quite sure, though, that I did use the correct path when it failed yesterday; actually I tried both variants. There's no way knowing for sure what happened, though. So we can just as well close this thread, too...

Share This Page