cannot remotely connect to dovecot

Discussion in 'Server Operation' started by tera7, Apr 27, 2012.

  1. tera7

    tera7 New Member

    hello i have installed postfix and dovecot ,i have done it few times with no problem.I can send emails the emails are stored to maildir but dovecot dont seem to work properly so i can receive them to my email client.

    port 25 is working both local and remote.

    So when i try from localhost pop3 or 110

    Code:
    [root@hosted-by ~]# telnet localhost pop3
    Trying ::1...
    Connected to localhost.
    Escape character is '^]'.
    +OK Dovecot ready.
    quit
    +OK Logging out
    Connection closed by foreign host.
    Seems ok


    Remote

    Code:
    [root@server ~]# telnet myip***  pop3
    Trying 128.127.108.65...
    telnet: connect to address myip***: Connection refused
    
    Dovecot status

    Code:
    [root@hosted-by ~]# service dovecot status
    Redirecting to /bin/systemctl  status dovecot.service
    dovecot.service - Dovecot IMAP/POP3 email server
              Loaded: loaded (/lib/systemd/system/dovecot.service; enabled)
              Active: active (running) since Fri, 27 Apr 2012 09:15:25 -0400; 15min
    ago
            Main PID: 25265 (dovecot)
              CGroup: name=systemd:/system/dovecot.service
                      ├ 25265 /usr/sbin/dovecot -F
                      ├ 25281 dovecot/anvil
                      └ 25282 dovecot/log
    /var/log/maillog

    Code:
    Apr 27 08:49:09 localhost dovecot: master: Warning: Killed with signal 15 (by pi
    d=1 uid=0 code=kill)
    Apr 27 08:49:09 localhost dovecot: log: Warning: Killed with signal 15 (by pid=1
     uid=0 code=kill)
    Apr 27 08:49:48 localhost dovecot: master: Dovecot v2.0.20 starting up (core dum
    ps disabled)
    Apr 27 08:50:28 localhost dovecot: pop3-login: Aborted login (no auth attempts):
     rip=::1, lip=::1, secured
    Apr 27 09:11:19 localhost dovecot: master: Warning: Killed with signal 15 (by pi
    d=1 uid=0 code=kill)
    Apr 27 09:11:19 localhost dovecot: anvil: Warning: Killed with signal 15 (by pid
    =1 uid=0 code=kill)
    Apr 27 09:11:19 localhost dovecot: log: Warning: Killed with signal 15 (by pid=1
     uid=0 code=kill)
    Apr 27 09:15:25 localhost dovecot: master: Dovecot v2.0.20 starting up (core dum
    ps disabled)
    Apr 27 09:18:54 localhost dovecot: pop3-login: Aborted login (no auth attempts):
     rip=::1, lip=::1, secured
    
    
    
     
    Last edited: Apr 27, 2012
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    please post the output of:

    netstat -tap | grep pop

    and

    iptables -L
     
  3. tera7

    tera7 New Member

    iptables are stoped

    [root@hosted-by ~]# netstat -tap | grep pop
    tcp 0 0 *:pop3s *:* LIST
    EN 25265/dovecot
    tcp 0 0 localhost:pop3 *:* LIST
    EN 25265/dovecot
    tcp 0 0 *:pop3s *:* LIST
    EN 25265/dovecot
    tcp 0 0 localhost:pop3 *:* LIST
    EN 25265/dovecot
    [root@hosted-by ~]#
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Is there any other firewall between you and your server that could block access to Dovecot?
     

Share This Page