cannot reinstall ISPconfig (recompile PHP with --with-pgsql)

Discussion in 'Installation/Configuration' started by radim_h, Jan 28, 2007.

  1. radim_h

    radim_h Member HowtoForge Supporter

    ISPconfig is working well but i'd like to add phppgadmin
    so according thread

    i have backed up /home/admispconfig and /root/ispconfig
    added --with-pgsql as argument into "compile" file and reinstalled ISPconfig.
    version 2.2.9 with same 2.2.9 version
    I have tried installation twice - once with removed /root/ispconfig and once with this directory kept on palce

    But in both cases installation ended with this message:
    ERROR: Could not configure PHP

    does someone has idea whats wrong please?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You dont have to add --with-pgsql to the compile settings, ISPConfig adds this automatically when the postgres dev files are found. The thread about adding the flag is deprecated.

    Please make sure that you have the postgresql dev files from your linux distribution installed before you start the ISPOConfig installation or update. ISPCOnfig will be compiled with postgres support when the dev files are found.
  3. radim_h

    radim_h Member HowtoForge Supporter

    still not working

    Well, its sad to say to, but after new compilation i'm still getting message "PHP is not compiled with PostgreSQL support. i had all needed libraries in system, also Postgre installed.
    postgresql.x86_64 8.1.6-1.fc6 installed
    postgresql-devel.x86_64 8.1.6-1.fc6 installed
    postgresql-libs.x86_64 8.1.6-1.fc6 installed
    postgresql-server.x86_64 8.1.6-1.fc6 installed
    php-pgsql.x86_64 5.1.6-3.3.fc6 installed

    or is there something missing still? or do i have to delete /root/ispconfig before update ?
    Running on FC6

    Thank you for help

    Last edited: Jan 28, 2007
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Hi Radim,

    I've just checked the sources. I'am sorry but I gave you some wrong infos, the --with-pgsql has still to be added to the configure string. I thought that I added the autodetection to the code some time ago but it seems not to be part of the current release :(
  5. radim_h

    radim_h Member HowtoForge Supporter

    where exactky add the switch

    I'm sorry,
    maybe i was wrong, just added --with-pgsql into

    cd ../${PHP}
    ./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-pgsql .............

    is it the right place ?
  6. falko

    falko Super Moderator ISPConfig Developer

    Yes, that's right.
  7. radim_h

    radim_h Member HowtoForge Supporter

    this went thru

Share This Page