Cannot recieve mail in roundcube

Discussion in 'ISPConfig 3 Priority Support' started by saco721, Feb 6, 2017.

  1. saco721

    saco721 Member HowtoForge Supporter

    Hi,

    I have just upgraded to Multiserver setup on Debian Jessie with ISPConfig 3.1.2. & Roundcube 1.2.3. I can send messages via Roundcube but do not get any incoming emails whatsoever. Was looking for the best place to start with regards to resolving this problem. Any advice would be greatly appreciated. Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    - Check the dns records of the domain, the MX record must point to an A-Record that points to the IP address of the mail server.
    - Check the firewall (if you have one in front of the router) and ensure that port 25 is open. When your server is not in a datacenter, then ask your provider if they block port 25.
    - Check the mail.lo file of the mail server.
     
  3. saco721

    saco721 Member HowtoForge Supporter

    Hi Till,
    Firstly thank you for your time.
    As you said it looks like a dns problem as I get the following message from yahoo :
    I have tried to create an MX record that points to an A record that points to the ip address of the mail server by doing the following in the zone (ns0.mydomain.com mydomain.com. ns0.mydomain.com.) :
    This is incorrect as I still get no mail, but am not sure how to set the correct parameters. I have also included a copy of mail.log from when I send a message from yahoo. Any advice is very much appreciated.
     

    Attached Files:

    Last edited: Feb 8, 2017
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You can check your dns record at e.g. intodns.com if the dns setup part for mail is ok now.
     
  5. saco721

    saco721 Member HowtoForge Supporter

    Hi Till,
    everything from intodns is ok
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You created mydomain.com as emaildomain in ispconfig and you created a mailbox [email protected] in ispconfig, right?

    Is the domain mydomain.com listed anywhere in the file /etc/postfix/main.cf or /etc/mailname?
     
  7. saco721

    saco721 Member HowtoForge Supporter

    Hi Till,
    Email Domain is :
    Server : mail.mydomain.com Domain :mydomain.com

    Mailbox:
    [email protected]

    /etc/mailname :
    mail.mydomain.com


    Here is main.cf :
    Here is master.cf :
    Thanks Till.
     
    Last edited: Feb 14, 2017
  8. saco721

    saco721 Member HowtoForge Supporter

    Hi,
    Have looked at hosts using hostname - returns mail, hostname -f - returns mail.mydomain.com.
    I have experimented using different settings in main.cf with no success. I looked to see if port 25 was blocked, I tried :
    Does this mean that port 25 is open and accepting connections?
    I have also tried :
    and the records seem to point to the correct IP's. What else can I try
     
    Last edited: Feb 12, 2017
  9. saco721

    saco721 Member HowtoForge Supporter

    Hi,
    I am aware that I have made an error when configuring postfix, but cannot figure out where the problem is.
    I noticed a mistake in master.cf, the following line was missing :
    I added it then restarted postfix, but still getting :
    error in mail.log. I understand that you guys are really busy, but I really need some help. If you cannot assist me, what is the fee for email support?, I look forward to your response, Thank you.
     
    Last edited: Feb 14, 2017
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    The main.cf file above is not from an ispconfig system, looks as if a stock main.cf file was restored after ispconfig was installed. Please download ispconfig 3.1.2 again to your server, unpack the tar.gz file and run the update.php script in the install folder. Choose to reconfigure services during update.
     
  11. saco721

    saco721 Member HowtoForge Supporter

    Hi Till,
    mail now works perfectly:),
    thank you for your time and patience,
    best wishes,
    Saco.
     

Share This Page