cannot recieve email

Discussion in 'Installation/Configuration' started by hestin, Nov 28, 2009.

  1. hestin

    hestin New Member

    hi
    i instslled ispconfig3 in ubuntu 8.10.

    Have added some domains and mailboxes.
    I can send mails using squirrelmail.
    but if i reply to that mail or send a mail to that account, its not recieved.

    THe mail is returned to gmail with this error


    Technical details of permanent failure:
    Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 550 550 5.1.1 <isptest@*******.net>: Recipient address rejected: User unknown in local recipient table (state 14).


    and in the syslog and mail log thers nothing except this

    Nov 28 11:00:02 ispconfig pure-ftpd: (?@localhost.localdomain) [INFO] New connection from localhost.localdomain
    Nov 28 11:00:02 ispconfig pure-ftpd: (?@localhost.localdomain) [INFO] Logout.
    Nov 28 11:00:02 ispconfig pop3d: Connection, ip=[::ffff:127.0.0.1]
    Nov 28 11:00:02 ispconfig pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Nov 28 11:00:02 ispconfig imapd: Connection, ip=[::ffff:127.0.0.1]
    Nov 28 11:00:02 ispconfig imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Nov 28 11:00:02 ispconfig postfix/smtpd[4249]: connect from localhost.localdomain[127.0.0.1]
    Nov 28 11:00:02 ispconfig postfix/smtpd[4249]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Nov 28 11:00:02 ispconfig postfix/smtpd[4249]: disconnect from localhost.localdomain[127.0.0.1]
    Nov 28 11:01:01 ispconfig /USR/SBIN/CRON[13760]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
    Nov 28 11:02:01 ispconfig /USR/SBIN/CRON[27438]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
    Nov 28 11:03:01 ispconfig /USR/SBIN/CRON[10651]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
    Nov 28 11:04:01 ispconfig /USR/SBIN/CRON[22420]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
    Nov 28 11:05:01 ispconfig /USR/SBIN/CRON[22436]: (getmail) CMD (/usr/local/bin/run-getmail.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
    Nov 28 11:05:01 ispconfig /USR/SBIN/CRON[22443]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
    Nov 28 11:05:02 ispconfig pure-ftpd: (?@localhost.localdomain) [INFO] New connection from localhost.localdomain
    Nov 28 11:05:02 ispconfig pure-ftpd: (?@localhost.localdomain) [INFO] Logout.
    Nov 28 11:05:02 ispconfig pop3d: Connection, ip=[::ffff:127.0.0.1]
    Nov 28 11:05:02 ispconfig pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Nov 28 11:05:02 ispconfig imapd: Connection, ip=[::ffff:127.0.0.1]
    Nov 28 11:05:02 ispconfig imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Nov 28 11:05:02 ispconfig postfix/smtpd[22462]: connect from localhost.localdomain[127.0.0.1]
    Nov 28 11:05:02 ispconfig postfix/smtpd[22462]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Nov 28 11:05:02 ispconfig postfix/smtpd[22462]: disconnect from localhost.localdomain[127.0.0.1]



    In the database "dbispconfig" table "mail_user" the mailbox users are shown.
    but I noticed that in the table "mail_user" thers a field "access" which is a boolean (y/n) and is "n" by default for all users.

    Also theres a table "mail_access" which has no user(no records) in it.

    And this table is checked in /etc/postfix/main.cf

    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
    smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf

    smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf


    Does all these have something to do with not recieving mails.

    how to resolve this issue?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please make sure that the MX record of your domain points to the right server. You can check that with
    Code:
    dig mx yourdomain.com
     

Share This Page