Cannot receive mails on ISPconfig Account

Discussion in 'Installation/Configuration' started by celtic, Sep 10, 2009.

  1. celtic

    celtic New Member

    Hello,

    When I try from several sources to send mails to recent created accounts via ISPconfig, all users from that specific domain get similar errors:

    Reporting-MTA: dns;snt0-omc2-s34.snt0.hotmail.com
    Received-From-MTA: dns;SNT105-W58
    Arrival-Date: Thu, 10 Sep 2009 10:15:50 -0700

    Final-Recipient: rfc822;[email protected]
    Action: failed
    Status: 5.5.0
    Diagnostic-Code: smtp;554 <[email protected]>: Relay access denied


    All other domains in my ISPConfig system wok just fine.

    This domain was forwarded to an External Exchange but due to ISP problems must be delivered now via ISPConfig.

    After searching a lot cannot figure out whats wrong with it.

    any help would be appreciated.

    Kind Regards and Thanks in advance

    Joaquim Oliveira

    OPO - PORTUGAL
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please check if the MX records of the domains are pointing to your ISPConfig server.
     
  3. celtic

    celtic New Member

    Here is DNS entries where jfo.nortenet.pt is IPSConfig server:


    $TTL 86400
    @ IN SOA jfo.nortenet.pt. jamir.bsl.pt. (
    2009091006 ; serial, todays date + todays serial #
    28800 ; refresh, seconds
    7200 ; retry, seconds
    604800 ; expire, seconds
    86400 ) ; minimum, seconds
    ;
    NS jfo.nortenet.pt. ; Inet Address of name server 1
    NS ns1.twisted4life.com. ; Inet Address of name server 2
    ;


    MX 10 jfo.nortenet.pt.

    bsl.pt. A 212.13.41.2
    www A 212.13.41.2
    server A 194.79.73.146
    remote A 194.79.73.146

    bsl.pt. TXT "v=spf1 a mx ptr ~all"


    Thanks again for the prompt response
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Is bsl.pt listed in /etc/postfix/local-host-names? What's in /etc/postfix/main.cf?
     
  5. celtic

    celtic New Member

    local-host-names:

    ###################################
    #
    # ISPConfig local-host-names Configuration File
    # Version 1.0
    #
    ###################################
    localhost
    jfo.nortenet.pt
    localhost.jfo.nortenet.pt
    localhost.nortenet.pt
    localhost.localdomain
    forum.boavistafc.net
    www.raiz.pt
    www.loveliveride.com
    www.medialar.pt
    www.setascosta.pt
    www.inovacao.com.pt
    www.technodry.pt
    www.boavistafutsal.net
    www.oval.pt
    www.maxireve.pt
    www.maquishow.pt
    www.neocontrol.net
    www.bsl.pt
    www.graphdeluxe.com
    www.atsopo.com
    www.meditraba.pt
    boavistafc.net
    apcunha.pt
    medialar.pt
    setascosta.pt
    oval.pt
    inovacao.com.pt
    technodry.pt
    raiz.pt
    boavistafutsal.net
    maxireve.pt
    maquishow.pt
    neocontrol.net
    www.boavistafc.net
    graphdeluxe.com
    atsopo.com
    sifecanorte.com
    meditraba.pt
    loveliveride.com
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####

    main.cf:

    # See /usr/share/postfix/main.cf.dist for a commented, more complete version


    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myhostname=jfo.nortenet.pt
    mydomain=nortenet.pt
    #mydestination = jfo.nortenet.pt, localhost.pt, localhost
    mynetworks = 127.0.0.0/8, 212.13.41.0/26
    #relay_host=mail.nortenet.pt
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_protocols = all

    smtpd_sasl_local_domain = $myhostname
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    #smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, permit, reject_unauth_destination
    smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination
    #smtpd_sender_login_maps = hash:/etc/postfix/login_maps

    inet_interaces = all
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names
     
  6. falko

    falko Super Moderator ISPConfig Developer

    bsl.pt is not listed in /etc/postfix/local-host-names (only www.bsl.pt which is not the same). Please create a Co-Domain bsl.pt (with an empty hostname!) for the www.bsl.pt web site in ISPConfig.
     
  7. celtic

    celtic New Member

    Hello,

    Entry was added and co-domain already existed.

    Postfix was stopped and started and the problem remains.

    Please advise.

    Kind regards and once again thanks for the prompt response.
     
  8. celtic

    celtic New Member

    I have checked the existing co-domain.

    It seems that it was pointing for External mail, inspite I had changed it for Local Mail in the Options Tab.

    It appeards that it is not enough it must be changed in Co-Domain entry as well.

    After that change the mail server started accepting the mail from that domain.

    I will wait for a few hours to see if everything is allright and will post.
     

Share This Page