Cannot Receive external mail - Postfix, Courier, MySQL And SquirrelMail (Debian Lenny

Discussion in 'Server Operation' started by x-built-Stan, Jan 18, 2010.

  1. x-built-Stan

    x-built-Stan New Member

    I followed the virtual domain setup on the forge @ http://www.howtoforge.com/virtual-users-domains-postfix-courier-mysql-squirrelmail-debian-lenny

    When I send email from the local server via mailx it works fine and get to the virual user. I can log into SquirrelMail and see the message. However, when I send mail from any outside server it gets kicked with a 550 and the following message:

    Generating server: hqpexedg02.admin.cci.edu

    [email protected]
    p3pismtp01-015.prod.phx3.secureserver.net #550 #5.1.0 Address rejected [email protected] ##

    I have gone back throught eh tutorial several times and each of the checks, everything looks good. Can anyone assist?
     
  2. Mark_NL

    Mark_NL New Member

    Code:
    tail -f /var/log/mail.log
    - send another mail ..
    - paste the lines that are generated from that mail here.
     
  3. x-built-Stan

    x-built-Stan New Member

    Sent another message. No output in maill.log, mail.err, or syslog.

    Same 550 error on bounced email.
     
  4. x-built-Stan

    x-built-Stan New Member

    Sent another email. No output in the mail.log, mail.err, or syslog
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Please check if the MX record of your domain points to the correct server. You can check that with
    Code:
    dig mx yourdomain.com
     
  6. x-built-Stan

    x-built-Stan New Member

    Man - you nailed it on the head.

    My ever so helpful DNS provider routed my MX record to their mail server. Changed it mine and everything is great.

    I should have seen it - Thanks again.
     
    Last edited: Jan 21, 2010
  7. kulot

    kulot New Member

    Hello sir. I have also followed the tutorial word by word in creating virtual user in CentOS 6.5.

    I cannot open my squirrelmail account because I do not have any email yet (as based on the suggestion that the email created should have an email sent so that the email address can be opened during first time).

    I wanted to send an email from gmail but my email bounces back. I have tried the "dig" command and this is the output:

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.23.rc1.el6_5.1 <<>> mx ndtc.edu.ph
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53509
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;ndtc.edu.ph. IN MX

    ;; ANSWER SECTION:
    ndtc.edu.ph. 18994 IN MX 10 mail.ndtc.edu.ph.

    ;; Query time: 272 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Fri Aug 22 14:50:32 2014
    ;; MSG SIZE rcvd: 50

    my website is ndtc.edu.ph

    I am hoping for a response.
     
  8. srijan

    srijan New Member HowtoForge Supporter

    Did you followed the tutorial word to word? Did you installed mails and send the the welcome mail to create the account for email address?

    Which guide you are following?
     
  9. kulot

    kulot New Member

Share This Page