Cannot receive emails

Discussion in 'Installation/Configuration' started by skeeta, Sep 1, 2005.

  1. skeeta

    skeeta ISPConfig Developer ISPConfig Developer

    I have a fresh FC4 installation (using perfect Fedora 4...) and installed ISPConfig as per the installation guide.

    After setting up a site with a few email users, I can successfully send emails outside of my domain/network but I am unable to receive any, from any source.

    Using WebMiau locally, I simply get no messages and NO error messages either.
    Sending via my isp mail account (using Incredimail on XP) to my domain I get
    "554 <someone@mydomain.com> Relay access denied (in reply to RCPT TO command)"

    A "tail" from /var/log/maillog is included below.
    Any help would be greatly appreciated.


    Sep 1 21:45:23 www postfix/local[24898]: 522C55D6C21: to=<pwoodforde@worldshedsports.com.au>, relay=local, delay=8840, status=sent (delivered to command: /usr/bin/procmail -f-)
    Sep 1 21:45:23 www sendmail[24911]: j81CFNkG024911: to=admispconfig@localhost, ctladdr=ron (10005/10001), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30090, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 7BBAF5D6C1E)
    Sep 1 21:45:23 www postfix/smtpd[24927]: disconnect from www.worldshedsports.com.au[127.0.0.1]
    Sep 1 21:45:23 www postfix/local[24928]: 7BBAF5D6C1E: to=<admispconfig@www.worldshedsports.com.au>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Sep 1 21:45:23 www postfix/qmgr[24185]: 7BBAF5D6C1E: removed
    Sep 1 21:45:23 www postfix/local[24899]: 522C55D6C21: to=<ron@worldshedsports.com.au>, relay=local, delay=8840, status=sent (delivered to command: /usr/bin/procmail -f-)
    Sep 1 21:45:23 www postfix/qmgr[24185]: 522C55D6C21: removed
    Sep 1 21:46:20 www ipop3d[24980]: pop3 service init from 127.0.0.1
    Sep 1 21:46:21 www ipop3d[24980]: Login user=les host=www.worldshedsports.com.au [127.0.0.1] nmsgs=0/0
    Sep 1 21:46:21 www ipop3d[24980]: Logout user=les host=www.worldshedsports.com.au [127.0.0.1] nmsgs=0 ndele=0
    [root@www skeeta]#
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer


    Have you set the maildir / mbox setting in the ISPConfig Controlpanel correct for your linux distro? The setting is in the controlpanel under management > Server > Settings Email.

    Did your email client uses SMTP authentication when it conects to the mailserver?
     
  3. skeeta

    skeeta ISPConfig Developer ISPConfig Developer

    Hi,
    1. Yes MailDir is set.
    2. Mail errors are received when sent via another mail server, not ME using my mail server to send emails.

    BTW: I installed WebMiau & have not modified any settings. I not only don't receive emails, I receive NO returned emails/error messages when I use WebMiau.

    When using outlook express and attempting to use my mail server for reading and sending emails I get a POP3 Port 110 and SMPT Port 25 socket errors (Error 10061)

    Cheers
    Skeeta
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer


    is the domain you wnat to receive email for in the file /etc/postfix/local-host-names ?
     
  5. skeeta

    skeeta ISPConfig Developer ISPConfig Developer

    The domain in in /etc/postfix/local-host-names.

    I have just noticed that the virtusertable has entries with a "www" hostname
    (ie. les@www.worldshedsports.com.au)

    I also notice that when I login to WebMiau using les@www.worldshedsports.com.au as the user I get to see quota info. When I use just les@worldshedsports.com.au I don't see it.
    Still No Mail though getting through to mail client but emails are in user directories!

    Thanks for your quick response.
     
  6. skeeta

    skeeta ISPConfig Developer ISPConfig Developer

  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

  8. skeeta

    skeeta ISPConfig Developer ISPConfig Developer

    When the site was first added it left the HOST blank.
    In my WISDOM I added the "www to the HOST field".
    Should I simply clear the HOST field?
     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Then set the maildelivery in the controlpanel to mbox (uncheck the maildir checkbox), wait a minute, then send an email to a user and check if you cn receive the mail now.
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    No, leave the www in the site settings and add the Co-Domain with an empty host field.
     
  11. skeeta

    skeeta ISPConfig Developer ISPConfig Developer

    Problem Solved.
    Thanks heaps
     

Share This Page