Cannot reach the admin panel

Discussion in 'General' started by jopa123, Jun 11, 2011.

  1. jopa123

    jopa123 New Member

    Hey guys,

    The server has been running well. So well that I haven't logged into ISPConfig's admin panel in a long time. I tried to log in and get the "Ooops, this link appears to be broken" message on the internal ip address, the external ip address, and the domain. I may have changed the login port at sometime from 8080 to something else, maybe this is my problem?

    Anyways, here's the netstat -tap output:

    tcp 0 0 localhost.localdo:10024 *:* LISTEN -
    tcp 0 0 localhost.localdo:10025 *:* LISTEN -
    tcp 0 0 *:mysql *:* LISTEN -
    tcp 0 0 localhost.localdo:spamd *:* LISTEN -
    tcp 0 0 *:ftp *:* LISTEN -
    tcp 0 0 *:ssh *:* LISTEN -
    tcp 0 0 *:smtp *:* LISTEN -
    tcp 0 0 localhost.localdo:53299 localhost.localdo:mysql ESTABLISHED -
    tcp 0 0 192.168.1.99:mysql 192.168.1.99:35203 TIME_WAIT -
    tcp 0 0 localhost.localdo:mysql localhost.localdo:53299 ESTABLISHED -
    tcp 0 196 192.168.1.99:ssh 192.168.1.25:61717 ESTABLISHED -
    tcp6 0 0 [::]:imaps [::]:* LISTEN -
    tcp6 0 0 [::]:pop3s [::]:* LISTEN -
    tcp6 0 0 [::]:pop3 [::]:* LISTEN -
    tcp6 0 0 [::]:imap2 [::]:* LISTEN -
    tcp6 0 0 [::]:http-alt [::]:* LISTEN -
    tcp6 0 0 [::]:www [::]:* LISTEN -
    tcp6 0 0 [::]:tproxy [::]:* LISTEN -
    tcp6 0 0 [::]:ftp [::]:* LISTEN -
    tcp6 0 0 [::]:ssh [::]:* LISTEN -
    tcp6 0 0 [::]:https [::]:* LISTEN -
    tcp6 0 0 localhost:35593 localhost:www TIME_WAIT -
    tcp6 0 0 localhost:45260 localhost:ftp TIME_WAIT -
    tcp6 0 0 192.168.1.99%167483:www 119.63.196.7%8191:26200 TIME_WAIT -

    It seems to inexperienced me that ISPConfig is not running. My sites are up and running, tho. After researching the problem I tried

    "/etc/init.d/ispconfig_server restart"

    and I got the message "No such file or directory"

    Any ideas? Thanks in advance.
     
  2. jopa123

    jopa123 New Member

    Still no luck

    Just remembered that ISPConfig 3 does not use init.d.

    However, still not sure if ISPConfig is running. I can't find the admin panel login page, but the sites are still up.

    Thanks for any help.
     
  3. till

    till Super Moderator

    ISPConfig is running on port 8080:

    tcp6 0 0 [::]:http-alt [::]:* LISTEN -
     
  4. jopa123

    jopa123 New Member

    Thanks, Till.

    Any ideas on why I can't get to the admin panel?

    Once again, the sites are running. If I go to the domain, the external ip, or the internal ip I get the "It Works" message. But if I add the 8080, I get the "Oops, this link appears to be broken" message.

    I have checked the router and it is indeed forwarding the 8080 port to the correct ip, even after a reboot.

    Thanks,
     
  5. falko

    falko Super Moderator

    Are there any errors in Apache's error log?

    Does the firewall allow port 8080?
     
  6. jopa123

    jopa123 New Member

    Falko,

    Three odd things in the error logs. Thanks, I am learning how to troubleshoot, here.

    1st odd thing:
    "[Sun Jun 12 06:31:07 2011] [warn] long lost child came home! (pid 31432)"

    2nd odd thing (several of these). This seems like it is my issue:
    "[Sun Jun 12 12:14:36 2011] [error] [client 58.218.199.250] script '/usr/local/ispconfig/interface/web/proxyheader.php' not found or unable to stat"

    3rd odd thing (many of these):
    [Sun Jun 12 14:34:56 2011] [notice] mod_fcgid: call /var/www/example.info/web/index.php with wrapper /var/www/php-fcgi-scripts/web5/.php-fcgi-starter

    I will go research the 2nd error above. BTW, port 8080 is definitely open.

    thanks
     
  7. jopa123

    jopa123 New Member

    After researching the error above I realize that this is an error that was shown to a visitor (possible hacker attack?). I don't think this the error that is causing my problem.

    I did find this, though:

    [Sat Jun 11 11:27:33 2011] [error] [client 192.168.1.1] File does not exist: /var/www/80
    [Sat Jun 11 11:27:37 2011] [error] [client 192.168.1.1] File does not exist: /var/www/81
    [Sat Jun 11 11:34:34 2011] [error] [client 192.168.1.1] File does not exist: /var/www/8080

    Does this help?

    The sites are all still up and running, I just can't get to the ISPConfig GUI. Where can I check what port ISPConfig is listening on? I very well may have changed it from 8080.

    Any other ideas?
     
    Last edited: Jun 24, 2011

Share This Page