cannot open

Discussion in 'General' started by abubin, Mar 25, 2010.

  1. abubin

    abubin New Member

    I have created a new for test. --> can access --> cannot access

    When I check the error log for, I found as below:
    Everything is default. Inside .htaccess, it's empty.

    Created another sites and same problem.

    Deleted "default" website that comes with ubuntu and same problem.
  2. abubin

    abubin New Member

    hmm..ok solved the problem by chmod 755 web directory.

    But the directory permission was default created by ispconfig at
    So, I have to chmod the web folder to 755 everytime I create a website?

    Something must be wrong with my setup?
  3. abubin

    abubin New Member

    can someone help me to trace this problem? I do no want to have to chmod the web folder each time I create a new site.

  4. till

    till Super Moderator Staff Member ISPConfig Developer



    1) Which linux distribution?
    2) Which php mode?
    3) Suexec enabled?
    You should check if the apache user is
  5. abubin

    abubin New Member

  6. falko

    falko Super Moderator ISPConfig Developer

    Did you install ISPConfig 2 or 3? Because the tutorial is for ISPConfig 2, but you posted this in the ISPConfig 3 forum...
  7. abubin

    abubin New Member

  8. abubin

    abubin New Member

    ok, i have looked at my installation of ispconfig 3 in another server running This one also have the web folder's permission at drwx--x--- (710). So I am assuming this is the default permission created by ispconfig.

    Problem is, this one works fine. I can create files even with root user and it will work if I use browser to open the file. Eg, test.html.

    But the other which is running still have this problem, I must chmod 755 the web folder only it will work. I also encountered a problem when I tried to access the stats folder. After a few times I tried to key in the password wrongly, somehow the web folder will get reset back to 710.

    Please help....
  9. abubin

    abubin New Member

    anyone can help? The problem still persist. Everytime I make changes to any website, the web folder will be rwx--x--- again. I keep on have to chmod web folder to 755.

    I know this is the default method and rwx--x--- should work on normal installation.

    Apache is running as www-data.

    Appreciate any help on this matter.
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    The permissions rwx--x--- are correct and it is correct that ISPConfig changes them to rwx--x---. You should check the owner of your files. Chown then to the website user and client group of this website.
  11. kokez

    kokez New Member HowtoForge Supporter

    I found myself in the situation described by abubin after "playing" with users and groups.
    I have then restored to the default operability after adding "www-data" in /etc/group:
    clientX:x:5005:www-data # repeating this for each subsequent clientX line

    and in /etc/gshadow:

Share This Page